Configurazione rete

9 risposte [Ultimo contenuto]
Ritratto di Blender
Blender
(Junior)
Offline
Junior
Iscritto: 18/09/2007
Messaggi: 19

Un saluto a tutto il forum.
Uso Lenny 5.0.3 su un notebook. Mi capita sovente di dover cambiare l'indirizzo ip e per fare questa operazione incontro difficoltà. In sostanza devo necessariamente riavviare il pc perchè debian prenda il nuovo indirizzo. infatti con i tools di gnome anche se metto un indirizzo statico mi torna in continuazione sull'impostazione in DHCP e non varia l'ip come da me inserito. In alternativa se vario a mano il file interfaces e riavvio la rete con /etc/init.d/networking restart pur avendo di ritorno un confortante "done" l'ip non cambia.

Come dicevo prima l'unico modo sembra essere il riavvio della macchina.

Potete darmi qualche chiarimento su come funziona la cosa ?

Grazie

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Ciao, non uso i tools di gnome/kde ma credo che se leggi la documentazione in giro (compreso questo forum) puoi trovare le informazioni che ti servono.

In alternativa, se vuoi fare come faccio io, elimina i tools, fatti un bello script e guarda i man di ifconfig e/o iwconfig.

Ciao!

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Ehm, veramente non mi sembra che Blender citasse tool GNOME/KDE...

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Mi sembrava di aver letto questo
Quote:

...infatti con i tools di gnome anche se metto un indirizzo statico mi torna in continuazione sull'impostazione in DHCP e non varia l'ip come da me inserito...

Smile

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Hai ragione, scusa! Smile

Però dopo parla di interfaces e di /etc/init.d/networking e quest'ultimo, se non sbaglio, chiama proprio ifup, che a sua volta usa ifconfig. Cioè è il metodo classico prima che i tool GNOME/KDE diventassero di moda...

Forse sarebbe utile se Blender postasse il contenuto del suo interfaces.

Ritratto di Blender
Blender
(Junior)
Offline
Junior
Iscritto: 18/09/2007
Messaggi: 19

Ciao mcortese, ciao marcos83,
posto che anche a me piace andare a consolle non fidandomi più di tanto dei tool grafici, con etch modificavo il file interfaces, un bel reboot della rete e la nuova configurazione era applicata. Il file interfaces coniene, oltre all'attivazione della scheda, l'address, netmask e gateway. Purtroppo con lenny sto avendo difficoltà perchè come dicevo nel precedente post modificando i tool di rete di gnome non se ne parla di cambiare l'indirizzamento ma, ancora peggio, la configurazione di interfaces è attivata solo dopo il riavvio della macchina. L'impressione generale è comunque che gnome lavori per conto suo in modo completamente slegato da interfaces.

Ecco il mio interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
# iface eth0 inet dhcp
iface eth0 inet static
address 192.168.1.101
netmask 255.255.255.0
gateway 192.168.1.1
eth0 up

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Lo script /etc/init.d/networking, quando lanciato con il parametro start, esegue ifup -a che, a sua volta, tira su tutte le interfacce di rete dichiarate auto nel file interfaces.

Cambia allow-hotplug in auto per avere il comportamento "classico".

Ritratto di rufus
rufus
(Monster)
Offline
Monster
Iscritto: 06/04/2005
Messaggi: 255

Risolvi mettendo nel tuo interface dopo
gateway 192.168.1.1
auto eth0
Ciao.

Ritratto di marcio79
marcio79
(Newbie)
Offline
Newbie
Iscritto: 04/05/2010
Messaggi: 1

salve a tutti, ho installato debian stamattina ma non capisco come configurare la rete; ho un modem adsl di alice ed uso la scheda di rete per le connessioni. qualcuno può gentilmente dirmi la procedura da terminale?
premetto che ho già provato con pppoeconfig come in passato ho sempre fatto su altri sistemi ma non fa nulla.
grazie

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non fare il timido, dacci qualche info in più! Che so? ad esempio gli indirizzi della scheda di rete e del modem, se il modem risponde ai ping, i file di configurazione di pppoe (peers e script di chat), ma anche la versione di Debian, ecc.
Ah, e poi magari spiega anche cosa vuol dire "non fa niente". Per qualcuno vuol dire "risponde con un errore", per altri "risponde con OK, ma poi non funziona", per altri ancora potrebbe voler dire "non dà segni di vita" o "si blocca". Per le donne in genere vuol dire "non lava i piatti" e di solito è riferito ai propri mariti...