collegamento internet

14 risposte [Ultimo contenuto]
Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Un salve a tutti, ho un piccolo(spero) Thinking problema che è quello che non riesco a collegrami ad internet.
Allora ho un hd dedicato a linux ho installato debian e utunbu ma non mi collego, ho due schede di rete una collegata al modem gate di alice e l'altra ad un hub per condividere un altro computer, con xp tutto funziona da entrambi i pc posso andare in internet con linux no!!!
So che forse sbaglio qualche cosa anche perchè ho provato con mandriva e fedora ed il problema non lo risolvo lo stesso, ho installato eth0 e eth1 dopo aver installato linux perchè la rete in fase di installazione non la riconosceva e mi è stato consigliato di installarla in seguito,poichè nono alle prime armi con linux un pò di comprensione Grazie e spero che :idea:

Ritratto di Marco-S
Marco-S
(Geek)
Offline
Geek
Iscritto: 08/04/2005
Messaggi: 90

Ciao,

visto che sei alle prime armi, non mi dilungo con i comandi e rimando direttamente a questo link che potrebbe fare al tuo caso (almeno per il collegamento diretto con linux e con il tuo modem gate)

Linux e Modem Alice Gate

Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Ciao e grazie per aver risposto Laughing
1)ho svolto il punto per adsl/pppoe trovato eth0 ee eth1, digitato user e pw, connessione inizializzata, 2) verifico con plog ed ho
mar 20 ora localhost pppd[2120]:cannot detrmine ethernet address for proxy arp
mar ......local id address... remote..., primary..., secondary logicamente su righe distinte
3) digito da root ifconfig -a e vedo eth0 , eth1, lo ed infine ppp0
4) vado su applicazioni strumenti di sistema rete con password ed in impostazioni di rete in connessioni due righe
la prima tipo di interfaccia sconosciuto dsl-provider
la seconda scheda di rete ethernet eth0
5) vado in mozzilla e non va
in basso a destra sull'icona della connesione con il passaggio del mouse appare
you are online(proxy:none) click the icon to go offline
t Laughing
adesso non so più che fare, ma soprattutto dove ho sbagliato

Ritratto di Marco-S
Marco-S
(Geek)
Offline
Geek
Iscritto: 08/04/2005
Messaggi: 90

il primo messaggio che trovi con plog ignoralo. Prova a fare un ping a 151.1.1.1 (indirizzo di TNET) dopo che hai riprovato la connessione e vedi se ti risponde. Se l'esito è positivo ma non riesci comunque a navigare con mozilla fai un bel

cat /etc/resolv.conf

Se risulta vuoto, devi inserire dentro i DNS del tuo ISP.

per capirne di più prova a leggere cosa ti dice

man resolv.conf

Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Ciao, con resolv confi ci sono due indirizzi per name server, con ping 151.1.1.1 mi dice che spedisce un numero di pacchetti ma ne riceve 0 e 100% loss
per resolv config(5).... termina con the different configuration option are: manual page resol.conf(5) line 1
ps quando debian parte si sofferme molto su starter( o simile) MTA, aspetto , se possibile, lumi, grazie

Ritratto di Marco-S
Marco-S
(Geek)
Offline
Geek
Iscritto: 08/04/2005
Messaggi: 90

Posso dirti solo di leggere questo thread già discusso, e spero che riesci a risolvere Wink

Modem Alice

Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Ciao a tutti, sono collegato ad internet con linux, sono contento ,finalmente direte voi Wink , ho letto tanto ed infine una discussione di alcuni anni fa ha risolto tutto, ora avrei un altro piccolo problema la risoluzione del monitor che è fissa a800x600, un altro aiutino e risolvo, comunque grazie e non scoraggiamoci alle prime, seconde ed anche terze operazioni che non riescono perchè la quarta è quella giusta :-P Laughing Big Grin ciao da orso54

Ritratto di lordnisse
lordnisse
(Geek)
Offline
Geek
Iscritto: 17/08/2005
Messaggi: 88

Per la risoluzione bloccata dovrebbe bastare editare le linee del file /etc/X11/Xorg.conf (credo si chiami così anche in Ubuntu) e mettere la risoluzione più alta al primo posto.
Il sistema la proverà per prima all'avvio di X, e se tutto va bene la tiene. Altrimenti prosegue alla seconda e così via.

Spero d'averti aiutato, ciao. Wink

Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Big Grin Ciao e grazie per il suggerimento, sono entrato in modalità grafica in etc/x11 ed il file da configurare è xorg.conf, ho visto che la max risoluzione è 800x660, ma scusa la mia ignoranza quando uso un editor per variare i dati mi dice che non ho i permessi,ora posto da ubuntu ho rifatto la procedura di internet e funziona ma ho dovito scaricare il file rp-pppoe-3.7.tar.gz sempre in modo grafico l'ho scompattato ed ho usato pppoeconf ho risposto sempre si alle domande posto e tutto va bene, quello che non riesco a fare è spostare dei file(mv) e/o copiare dei file(cp) in un'altra directory mi dareste un aiuto? Grazie

Ritratto di Marco-S
Marco-S
(Geek)
Offline
Geek
Iscritto: 08/04/2005
Messaggi: 90

Bene sono felice che almeno i parte i problemi sono stati risolti Smile
Ora, visto il tuo ultimo problema, ti posso consigliare questo piccolo corso base (ma molto utile) su Linux. Alle sezione 5 c'è quello che cerchi, ma ti consiglio di leggerlo dall'inizio, almeno per farti un'idea sul sistema che stai utilizzando. Vedrai che molte cose ti saranno più chiare e semplici.

Corso Base Linux

Ritratto di orso54
orso54
(Junior)
Offline
Junior
Iscritto: 28/03/2006
Messaggi: 7

Ciao, non so se devo continuare a postare qui o ad aprire un'altra discussione sull'installazione dei programmi, comunque per adesso espongo il problema, ho letto la giuda che mi hai suggerito, sbagliavo non ricordandomi che linux è case sensitivo, abituato a win scrivevo senza tener conto delle maiuscole, adesso so scompattare un file compresso, vado nella cartella creata digito ./configure e mi dà
debian:/home/peppe/Desktop/aMule-2.1.0# ./configure
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for g++... g++
checking for C++ compiler default output file name... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking how to run the C++ preprocessor... g++ -E
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking whether make sets $(MAKE)... (cached) yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for ranlib... ranlib
checking for bison... bison -y
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for ar... ar
checking for ld... ld
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for zlib >= 1.1.4... no
checking for zlib in peer directory... no
configure: error: unable to use zlib - no peer found
fatto questo dovrei dare il comando make installl e dovrebbe crearmi l'eseguibile inve c'è questo messaggio
debian:/home/peppe/Desktop/aMule-2.1.0# make
make: *** No targets specified and no makefile found. Stop.
debian:/home/peppe/Desktop/aMule-2.1.0# make install
make: *** No rule to make target `install'. Stop.
per ulteriore scupolo visualizzo anche la dir creatomi dal tar
debian:/home/peppe/Desktop/aMule-2.1.0# dir
ABOUT-NLS amule.rc config.h.in convert.ico Makefile.in
acinclude.m4 aMule.spec config.log depcomp missing
aclocal.m4 amule.xpm config.rpath docs mkinstalldirs
aMule.app autogen.sh config.sub install-sh po
amule.desktop Compilation.flags.in configure intl src
amule.ico compile configure.in m4 unittests
amule.msp config.guess configWIN32.h Makefile.am
senza un aiuto credo di non poter proseguire, farò altre prove nel frattempo, un grazie anticipato

:-P