Asus P2530UA wifi non rilevato

20 risposte [Ultimo contenuto]
Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

Ciao a tutti,
Ho comprato un notebook Asus P2530UA ed ho intenzione di installarci Debian.
Per provarne la compatibilità hw sto utilizzando un'installazione (Jessie 8 main,contrib) su USB di qualche tempo fa, ma tenuta costantemente aggiornata.
Il primo ostacolo sembra essere il wifi che non viene rilevato; al contrario il bluetooth risulta attivo e funzionante da subito.

# lspci
00:00.0 Host bridge: Intel Corporation Device 1904 (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Device 1906 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 08)
00:14.0 USB controller: Intel Corporation Device 9d2f (rev 21)
00:14.2 Signal processing controller: Intel Corporation Device 9d31 (rev 21)
00:16.0 Communication controller: Intel Corporation Device 9d3a (rev 21)
00:17.0 SATA controller: Intel Corporation Device 9d03 (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device 9d14 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Device 9d15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d48 (rev 21)
00:1f.2 Memory controller: Intel Corporation Device 9d21 (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d70 (rev 21)
00:1f.4 SMBus: Intel Corporation Device 9d23 (rev 21)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
03:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 31)

Grazie in aticipo a chi potrà darmi un consiglio.

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
servirebbe qualche dettaglio in più sul modello della scheda wireless .... ma è probabile che ti manchi il firmware.

Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

Ciao badroot, grazie per aver risposto.
Sul sito Asus, alla scheda del modello (qui: https://www.asus.com/it/Commercial-Notebooks/ASUSPRO-P2530UA/specifications/ ) è indicato: Integrated 802.11 b/g/n or 802.11 a/b/g/n/ac (WiDi).
Non so se è sufficiente...

P.S.
questo è il mio source.list:

# deb cdrom:[Debian GNU/Linux 8.3.0 _Jessie_ - Official amd64 DVD Binary-1 20160123-19:03]/ jessie main contrib   
 
# deb cdrom:[Debian GNU/Linux 8.3.0 _Jessie_ - Official amd64 DVD Binary-1 20160123-19:03]/ jessie contrib main   
 
# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ jessie/updates contrib main 
# Line commented out by installer because it failed to verify:
# deb-src http://security.debian.org/ jessie/updates contrib main 
 
# jessie-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
 
deb http://ftp.ch.debian.org/debian/ jessie-updates contrib main 
deb http://ftp.ch.debian.org/debian/ jessie main contrib 
# deb-src http://ftp.ch.debian.org/debian/ jessie-updates main contrib 

Il firmware che mi suggerisci appartiene al ramo non-free, dovrei quindi optare permanentemente per quest'ultimo?

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Prova a eseguire questo comando :

dmesg | grep -i firm

dovrebbe segnalare il tentativo di caricamento di firmware.

In ogni caso devi poi abilitare il repository non-free, ma non è nemmeno detto che su Jessie ci sia il firmware che ti serve, è per quello che bisogna sapere il modello esatto di scheda, sappiamo che è una Atheros .... ma che modello di preciso ?

Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

Ecco il risultato:

root@debian:/home/xxxxxxxx# dmesg | grep -i firm
[    0.244536] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
[    1.533210] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x381f17)
[    8.709366] r8169 0000:02:00.0: firmware: failed to load rtl_nic/rtl8168g-3.fw (-2)
[    8.709460] r8169 0000:02:00.0: Direct firmware load failed with error -2
[    8.709843] r8169 0000:02:00.0 eth1: unable to load firmware patch rtl_nic/rtl8168g-3.fw (-12)

nel frattempo continuerò nella ricerca del modello preciso della scheda...

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Qui pare che sia il firmware realtek che ti manca, ma dovrebbe essere la rete cablata.

Vediamo cosa riportano questi comandi :

lspci -kn
dmesg | grep -i ath

Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

lspci -kn

root@debian:/home/xxxxxxx# lspci -kn
00:00.0 0600: 8086:1904 (rev 08)
	Subsystem: 1043:1070
00:02.0 0300: 8086:1906 (rev 07)
	Subsystem: 1043:1070
00:04.0 1180: 8086:1903 (rev 08)
	Subsystem: 1043:1070
00:14.0 0c03: 8086:9d2f (rev 21)
	Subsystem: 1043:201f
	Kernel driver in use: xhci_hcd
00:14.2 1180: 8086:9d31 (rev 21)
	Subsystem: 1043:1070
00:16.0 0780: 8086:9d3a (rev 21)
	Subsystem: 1043:1070
00:17.0 0106: 8086:9d03 (rev 21)
	Subsystem: 1043:1070
	Kernel driver in use: ahci
00:1c.0 0604: 8086:9d10 (rev f1)
	Kernel driver in use: pcieport
00:1c.4 0604: 8086:9d14 (rev f1)
	Kernel driver in use: pcieport
00:1c.5 0604: 8086:9d15 (rev f1)
	Kernel driver in use: pcieport
00:1f.0 0601: 8086:9d48 (rev 21)
	Subsystem: 1043:1070
00:1f.2 0580: 8086:9d21 (rev 21)
	Subsystem: 1043:1070
00:1f.3 0403: 8086:9d70 (rev 21)
	Subsystem: 1043:1070
	Kernel driver in use: snd_hda_intel
00:1f.4 0c05: 8086:9d23 (rev 21)
	Subsystem: 1043:1070
02:00.0 0200: 10ec:8168 (rev 10)
	Subsystem: 1043:205f
	Kernel driver in use: r8169
03:00.0 0280: 168c:0042 (rev 31)
	Subsystem: 1a3b:2231

dmesg | grep -i ath

nessun risultato, nessun output.

Nel frattempo ho aggiunto non-free al source.list, poi apt-get update | apt-get upgrade dopodiché un riavvio.

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Credo che tu debba abilitare i backports e installare il kernel più aggiornato e il relativo firmware.

sudo apt-get update
sudo apt-get -t jessie-backports linux-image-amd64 firmware-atheros

oppure passi direttamente a installare stretch, attualmente ancora in testing .... ma non dovrebbe passare molto perchè diventi la nuova stable.

Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

Scusa ma sembra che non digerisca il "-t"

root@debian:/home/xxxxxxx# apt-get -t jessie-backports linux-image-amd64 firmware-atheros
E: Opzione a riga di comando "t" [da -t] sconosciuta.

Secondo te il pacchetto firmware-iwlwifi potrebbe essere utile? L'ho letto qui: https://wiki.debian.org/InstallingDebianOn/Asus/ROG%20G752VM-GC006T

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Scusa .... la fretta o l'età, ma ovviamente il comando esatto è :

apt-get -t jessie-backports install linux-image-amd64 firmware-atheros

da root.

Ritratto di epsilon
epsilon
(Junior)
Offline
Junior
Iscritto: 24/01/2016
Messaggi: 26

root@debian:/home/xxxxxxx# apt-get -t jessie-backports install linux-image-amd64 firmware-atheros
Lettura elenco dei pacchetti... Fatto
E: Il valore "jessie-backports" non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti

CERCA TROVA (Leonardo DaVinci ~ "La Battaglia di Anghiari" 1503)