X server

10 risposte [Ultimo contenuto]
Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

Salve a tutti,
sono alla mia prima esperienza con Linux e ho un Asus N752vx. Dopo la procedura di installazione di Debian, andata a buon fine (eccezion fatta per i driver del wi-fi e del bluetooth che non vengono rilevati), provo ad entrare nel sistema ma vanamente. Nella fattispecie dopo aver inserito la chiave per il VLM, aver loggato come root, e dato il comando "startx", sulla shell appare il messaggio "waiting for X server to begin accepting connections". Dopo un poco di tempo appare il messaggio che il processo è stato soppresso.
Ho provato a cercare nel web così come a reinstallare Debian più volte ma il risultato finale è sempre lo stesso. Preciso che ho installato debian in dual-boot: ho sull'ssd windows 10 e sull'hd Debian. Mi sapreste aiutare a risolvere?
Grazie a tutti in anticipo.

Angelo

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

E loggandoti come utente non root?

Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

Sia loggando come root che come utente il risultato è lo stesso. Ho provato ieri anche la versione live ma sempre solita fine.

Angelo

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

Che scheda video hai? Che driver? Che kernel? Quale versione di Debian: Stretch, Buster o Sid?

Il dual-boot non è influente, mentre eseguire X come root è sempre una cattiva idea.

Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

Allora:
scheda video --> gtx 950m
driver istallati scheda video --> igdumdim64, igd10iumd64, igd10iumd64, igd12umd64, igdumdim32, igd10iumd32, igd10iumd32, igd12umd32
kernel --> 4.9.0-4-amd64
debian --> stretch 4.9.51.1

ti posso chiedere perchè eseguire X come root è una cattiva idea? (non è per contestare, voglio imparare!)
grazie

Angelo

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

abfwki ha scritto:

scheda video --> gtx 950m

NVIDIA, quindi. Sicuro di non avere anche una scheda integrata (una configurazione spesso chiamata "optimus")?

abfwki ha scritto:

driver istallati scheda video --> igdumdim64, igd10iumd64, igd10iumd64, igd12umd64, igdumdim32, igd10iumd32, igd10iumd32, igd12umd32

Mai sentiti. Sono due i driver solitamente usati con le schede NVIDIA: nouveau (pacchetto xserver-xorg-video-nouveau) è il driver open source che è fornito d'ufficio; nvidia è il driver proprietario che deve essere esplicitamente installato, di solito tramite il metapacchetto nvidia-driver che a sua volta richiama tutti i suoi componenti, tra cui il driver X vero e proprio e il modulo kernel.

Se non hai consciamente installato i driver proprietari, allora dovresti avere nouveau. Potrebbe non essere aggiornatissimo e non supportare le schede più recenti come la tua. Se vuoi provare i driver proprietari, segui il wiki (la versione in inglese è aggiornata, quella in italiano è ferma a Jessie). Di fatto devi abilitare i repository non-free, aggiornare la lista dei pacchetti con "apt update" e installare con "apt install nvidia-driver".

abfwki ha scritto:

ti posso chiedere perchè eseguire X come root è una cattiva idea?

Perché è come tenere il PIN vicino al bancomat. L'utente root può fare qualsiasi cosa su di una macchina Linux. I processi che girano come root dovrebbero essere il minimo indispensabile. Il server X è uno di quei programmi che si deve interfaccia con innumerevoli altri software e ha quindi una "superficie di attacco" enorme. Inoltre i protocolli su cui si basa sono gli stessi degli anni '70, quando la sicurezza informatica non andava certo di moda. Insomma, il server X è uno di quei software, insieme al browser Web e al client di posta, che non vorrei girasse come root sul mio PC...

Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

si, scusami! Ho la gtx950 come scheda dedicata e la Intel(R) HD Graphics 530 come integrata. I driver che ti ho citato seno quelli che ho installato con i pacchetti già presenti, in ogni caso provo a fare come mi ha consigliato e ti aggiorno sui risultati.
grazie mille.

Angelo

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

I miei consigli riguardano la scheda NVIDIA, ma temo che il tuo problema sia convincere la Intel a far passare il segnale generato dalla prima. Credo sia meglio leggere questo wiki (che comunque parte da una situazione con i driver proprietari già installati, quindi il mio post si rivela utile Wink )

Io non ho la (s)fortuna di una doppia scheda video, quindi non posso aiutarti oltre.

Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

ciao,
ho provato a fare quanto hai detto ma dando il "sudo apt install nvidia-driver" dopo che arriva al 10% dell'installazione mi esce un messaggio di errore dicendomi di riprovare dopo che ho settato apci=off. Ho provato a farlo dalla shell andando da /etc/default/grub ma con ogni mezzo io provi ad entrare (sudo, gksudo, gedit, sudo bash) per modificare il parametro mi nega il permesso. Ho provato anche a modificare il parametro dalla schermata iniziale: premendo "e" ed accedendo alle linee di comando; una volta inserito sulla linea linux "apci=off" però non si avvia proprio più il sistema. Sai come posso fare?

Ho provato, inoltre, ad avviare una versione di recovery dove da preimpostazioni vengono disabilitate le schede nviadia (accedendo così con la scheda optimus della intel) e il sistema mi parte che è una meraviglia. In caso, esiste un modo per far bypassare il segnale dalla nvidia sulla intel tramite shell?

grazie

Angelo

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2751

Non riesco a capire se apci è un errore di trascrizione nel tuo post o scrivi proprio apci in Grub. Perché il parametro corretto è acpi, non apci. Non so però se risolva il problema. A che punto dell'installazione ti dà questo suggerimento? Cosa dice prima e dopo?

Se non riesci a editare il file, cita bene i comandi che provi e il risultato che ottieni.

Per disabilitare i driver nouveau, aggiungi questo parametro al momento del boot:

modprobe.blacklist=nouveau
Non caricando il modulo nouveau, dovrebbe vedere solo la Intel e partire con quella. Se funziona, per non ripetere questa noiosa operazione tutte le volte, dovrai creare un file in /etc/modprobe.d/ (chiamalo con un nome che ti ricordi cosa fa, ad esempio blacklist-nouveau) con dentro una sola riga:
blacklist nouveau

Però secondo me questa è l'ultima spiaggia. Meglio far funzionare i driver proprietari e imparare a gestire le due schede.

Ritratto di abfwki
abfwki
(Junior)
Online
Junior
Iscritto: 05/11/2017
Messaggi: 6

ciao,
si assulutamente ACPI, ho sbagliato per 2 volte a scrivere, scusami.
dopo l'estrazione dei template e la preconfigurazione dei pacchetti i messaggi che escono sono:

lettura del database... 420717 file e directory attualmente installati
preparativi per estrarre .../nvidia-legacy-check_375.82-8_amd64.deb...
chechking for legacy NVIDIA GPUs appears to hang, try rebooting with 'acpi=off'
adda to the kernel boot options in the GRUB configuration.
[ 368.277892] INFO: task lspci:1445 blocked for more that 120 seconds.

Angelo