Problema upgrade install

9 risposte [Ultimo contenuto]
Ritratto di cacaocaca
cacaocaca
(Junior)
Offline
Junior
Iscritto: 23/06/2016
Messaggi: 15

Salve ragazzi ho kali linux rolling posto il comando uname -a Linux kali 4.5.0-kali1-686-pae #1 SMP Debian 4.5.5-1kali1 (2016-06-06) i686 GNU/Linux allora il problema è che quando tento di installare qualche pacchetto o fare l upgrade mi da sempre questo errore
apt-get install 4g8
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
4g8
0 aggiornati, 1 installati, 0 da rimuovere e 1 non aggiornati.
È necessario scaricare 12,2 kB di archivi.
Dopo quest'operazione, verranno occupati 73,7 kB di spazio su disco.
Scaricamento di:1 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 4g8 i386 1.0-3 [12,2 kB]
Recuperati 12,2 kB in 0s (15,6 kB/s)
Selezionato il pacchetto 4g8 non precedentemente selezionato.
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-ctypeslib" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-ecdsa" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzma" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzo" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-pyqtgraph" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "gccxml" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 312298 file e directory attualmente installati.)
Preparativi per estrarre .../archives/4g8_1.0-3_i386.deb...
Estrazione di 4g8 (1.0-3)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Configurazione di 4g8 (1.0-3)...
Qualcuno sa come risolvere questo problema ? Grazie a tutti .

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Ciao,
di solito quell'errore indica che si sono corrotti o sono stati cancellati dei file che il sistema usa per tenere traccia dei pacchetti installati.
Prova questo comando :

sudo apt-get --reinstall install python-ctypeslib

se risolve il problema per il pacchetto in questione ripetilo per gli altri che ti sono segnalati.

Ritratto di cacaocaca
cacaocaca
(Junior)
Offline
Junior
Iscritto: 23/06/2016
Messaggi: 15

root@kali:~# apt-get --reinstall install python-ctypeslib
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
La reinstallazione di python-ctypeslib non è possibile, non può essere scaricato
Niente da fare Sad

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Forse basta dare un "apt-get update".

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Strano,
guardando il repo il file dovrebbe esserci.
Prova il suggerimento di mcortese e poi cerca il pacchetto con :

aptitude search python-ctypeslib

magari invece di reinstallarlo, se non ti serve, puoi provare a rimuoverlo e vedere se risolvi il problema.
il problema dovrebbe essere legato al fatto che nella cartella /var/lib/dpkg/info ti mancano i file .list e .md5sum, puoi confermare ?
Potresti provare anche il seguente comando, se non risolvi :

dpkg -L python-ctypeslib

per vedere se ti elenca il contenuto del pacchetto.

Ritratto di cacaocaca
cacaocaca
(Junior)
Offline
Junior
Iscritto: 23/06/2016
Messaggi: 15

SE faccio upgrade mi da sempre questi errori .
Se vado su synaptic il programma è gia installato.
root@kali:~# aptitude search python-ctypeslib
i python-ctypeslib - code generator to convert header files into ctypes interfaces
root@kali:~# dpkg -L python-ctypeslib
dpkg-query: attenzione: file con l'elenco dei file del pacchetto "python-ctypeslib" mancante, il pacchetto viene considerato senza alcun file attualmente installato
Il pacchetto "python-ctypeslib" non contiene alcun file (!)
root@kali:~#
Forse l output in inglese vi sarà di aiuto.Però ricordate che ho kali rolling ed no ubuntu http://www.everybodyhertz.co.uk/ubuntu-dpkg-warning-files-list-file-for-package-x-missing-assuming-package-has-no-files-currently-installed/

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Non ho capito, dal tuo ultimo post, se hai già provato a fare quanto indicato nel link che hai menzionato e con quali risultati.

sudo touch /var/lib/dpkg/info/python-ctypeslib.list
sudo apt-get upgrade

inoltre mi sembra strano che non te lo faccia reinstallare, prova magari a scaricare il pacchetto a mano e a installarlo con dpkg.

Ritratto di cacaocaca
cacaocaca
(Junior)
Offline
Junior
Iscritto: 23/06/2016
Messaggi: 15

root@kali:~# sudo touch /var/lib/dpkg/info/python-ctypeslib.list
root@kali:~# apt-get upgrade
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Fatto
I seguenti pacchetti sono stati mantenuti alla versione attuale:
linux-image-686-pae
I seguenti pacchetti saranno aggiornati:
gdb gdbserver gnuplot libgcrypt20 python-googleapi python-pip python-pip-whl python-pyparsing python3-pyparsing rpcbind tasksel tasksel-data
12 aggiornati, 0 installati, 0 da rimuovere e 1 non aggiornati.
È necessario scaricare 5.106 kB di archivi.
Dopo quest'operazione, verranno occupati 146 kB di spazio su disco.
Continuare? [S/n] s
Scaricamento di:1 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 tasksel-data all 3.35 [18,0 kB]
Scaricamento di:2 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 tasksel all 3.35 [94,0 kB]
Scaricamento di:3 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 libgcrypt20 i386 1.7.1-2 [460 kB]
Scaricamento di:4 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 gdb i386 7.11.1-2 [2.600 kB]
Scaricamento di:5 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 gdbserver i386 7.11.1-2 [320 kB]
Scaricamento di:6 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 gnuplot all 5.0.3+dfsg3-7 [61,0 kB]
Scaricamento di:7 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 python-googleapi all 1.5.1-1 [41,6 kB]
Scaricamento di:8 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 python-pip all 8.1.2-2 [171 kB]
Scaricamento di:9 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 python-pip-whl all 8.1.2-2 [1.148 kB]
Scaricamento di:10 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 python-pyparsing all 2.1.5+dfsg1-1 [72,7 kB]
Scaricamento di:11 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 python3-pyparsing all 2.1.5+dfsg1-1 [72,8 kB]
Scaricamento di:12 http://kali.mirror.garr.it/mirrors/kali kali-rolling/main i386 rpcbind i386 0.2.3-0.5 [46,0 kB]
Recuperati 5.106 kB in 4s (1.075 kB/s)
Lettura dei changelog... Fatto
Preconfigurazione dei pacchetti in corso
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-ecdsa" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzma" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzo" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-pyqtgraph" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "gccxml" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 312706 file e directory attualmente installati.)
Preparativi per estrarre .../tasksel-data_3.35_all.deb...
Estrazione di tasksel-data (3.35) su (3.34)...
Preparativi per estrarre .../archives/tasksel_3.35_all.deb...
Estrazione di tasksel (3.35) su (3.34)...
Preparativi per estrarre .../libgcrypt20_1.7.1-2_i386.deb...
Estrazione di libgcrypt20:i386 (1.7.1-2) su (1.7.0-2)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Elaborazione dei trigger per menu (2.1.47)...
Elaborazione dei trigger per libc-bin (2.22-11)...
Configurazione di libgcrypt20:i386 (1.7.1-2)...
Elaborazione dei trigger per libc-bin (2.22-11)...
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-ecdsa" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzma" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-lzo" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "python-pyqtgraph" mancante, il pacchetto viene considerato senza alcun file attualmente installato
dpkg: attenzione: file con l'elenco dei file del pacchetto "gccxml" mancante, il pacchetto viene considerato senza alcun file attualmente installato
(Lettura del database... 312706 file e directory attualmente installati.)
Preparativi per estrarre .../archives/gdb_7.11.1-2_i386.deb...
Estrazione di gdb (7.11.1-2) su (7.10-1.1)...
Preparativi per estrarre .../gdbserver_7.11.1-2_i386.deb...
Estrazione di gdbserver (7.11.1-2) su (7.10-1.1)...
Preparativi per estrarre .../gnuplot_5.0.3+dfsg3-7_all.deb...
Estrazione di gnuplot (5.0.3+dfsg3-7) su (5.0.3+dfsg3-5)...
Preparativi per estrarre .../python-googleapi_1.5.1-1_all.deb...
Estrazione di python-googleapi (1.5.1-1) su (1.5.0-2)...
Preparativi per estrarre .../python-pip_8.1.2-2_all.deb...
Estrazione di python-pip (8.1.2-2) su (8.1.2-1)...
Preparativi per estrarre .../python-pip-whl_8.1.2-2_all.deb...
Estrazione di python-pip-whl (8.1.2-2) su (8.1.2-1)...
Preparativi per estrarre .../python-pyparsing_2.1.5+dfsg1-1_all.deb...
Estrazione di python-pyparsing (2.1.5+dfsg1-1) su (2.1.4+dfsg1-1)...
Preparativi per estrarre .../python3-pyparsing_2.1.5+dfsg1-1_all.deb...
Estrazione di python3-pyparsing (2.1.5+dfsg1-1) su (2.1.4+dfsg1-1)...
Preparativi per estrarre .../rpcbind_0.2.3-0.5_i386.deb...
Warning: Stopping rpcbind.service, but it can still be activated by:
rpcbind.socket
Estrazione di rpcbind (0.2.3-0.5) su (0.2.3-0.4)...
Elaborazione dei trigger per man-db (2.7.5-1)...
Elaborazione dei trigger per menu (2.1.47)...
Elaborazione dei trigger per systemd (230-2)...
Configurazione di gdb (7.11.1-2)...
Configurazione di gdbserver (7.11.1-2)...
Configurazione di gnuplot (5.0.3+dfsg3-7)...
Configurazione di python-googleapi (1.5.1-1)...
Configurazione di python-pip-whl (8.1.2-2)...
Configurazione di python-pip (8.1.2-2)...
Configurazione di python-pyparsing (2.1.5+dfsg1-1)...
Configurazione di python3-pyparsing (2.1.5+dfsg1-1)...
Configurazione di rpcbind (0.2.3-0.5)...
Installazione della nuova versione del file di configurazione /etc/init.d/rpcbind...
insserv: warning: current start runlevel(s) (empty) of script `rpcbind' overrides LSB defaults (S).
insserv: warning: current stop runlevel(s) (0 1 6 S) of script `rpcbind' overrides LSB defaults (0 1 6).
Configurazione di tasksel (3.35)...
Configurazione di tasksel-data (3.35)...
Elaborazione dei trigger per menu (2.1.47)...
Elaborazione dei trigger per systemd (230-2)...
root@kali:~#
L ho fatto con tutti i pacchetti mancanti a quante pare risolto Grazie tanto d'avvero.. Ho un problema con wine gecko che in pratica non c'è l ha kali nelle reposity e quindi mi da errore posso postare un altro thread su questo argomento ?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Ciao,
se hai sistemato questo problema metti risolto.
Apri un'altra discussione per wine/gecko .... o altri eventuali problemi.

Ritratto di cacaocaca
cacaocaca
(Junior)
Offline
Junior
Iscritto: 23/06/2016
Messaggi: 15

Si già fatto e grazie ancora ho anche riaperto la nuova discussione Smile