Problema pacchetti durante installazione di Qt Creator

4 risposte [Ultimo contenuto]
Ritratto di Overflow10
Overflow10
(Newbie)
Offline
Newbie
Iscritto: 25/10/2014
Messaggi: 5

Salve a tutti, sto cercando di installare qtcreator sulla mia macchina Debian wheezy, kernel 3.16.0-0.bpo.4-amd64.
Quando eseguo il comando

# apt-get install qtcreator

ottengo il seguente risultato:

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 qtcreator : Dipende: libbotan-1.10-0 ma non è installabile
             Raccomanda: qt5-doc ma non sta per essere installato
             Raccomanda: qtbase5-dev-tools ma non sta per essere installato
             Raccomanda: qtcreator-doc ma non sta per essere installato
             Raccomanda: qtdeclarative5-dev-tools ma non sta per essere installato
             Raccomanda: qtquick1-5-dev-tools ma non sta per essere installato
             Raccomanda: qttools5-dev-tools ma non sta per essere installato
             Raccomanda: qtxmlpatterns5-dev-tools ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Utilizzando invece il gestore di pacchetti Synaptic selezionando qtcreator oppure q4-tool-dev mi dice sempre che c'è un pacchetto danneggiato bloccato, come posso recuperare questi pacchetti danneggiati?
In passato ho installato qt creator senza problemi sullo stesso pc, con lo stesso sistema operativo e con lo stesso kernel nulla di diverso.

Grazie.

Ritratto di crashd
crashd
(Junior)
Offline
Junior
Iscritto: 12/10/2004
Messaggi: 26

Hai dato un apt-get update prima di installarlo?
Controllato il sources.list se è tutto corretto? Vai in /etc/apt/sources.list aprilo da root con un editor di testo e confronta i repository con quelli ufficiali per la tua distribuzione
Se cerchi libotan da synaptic ti dice che non è installabile?
Potresti scaricarlo e installarlo da qui
https://packages.debian.org/wheezy/libs/libbotan-1.10-0

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Senza ulteriori dettagli ti consiglio la classica sequenza :

sudo apt-get update
sudo apt-get upgrade

oppure un bel :

sudo apt-get install -f

nel caso il problema fosse legato ad un'anomala interruzione di qualche aggiornamento o installazione di pacchetti.

Ovviamente, come già consigliato da crashd, prima controlla che il tuo sources.list sia corretto.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Quando si mischia stable e backports si può incorrere in problemi del genere.

Sicuro di non aver attivato i backports, installato qalcosa e poi di averli disattivati? Perché la versione in stable di qtcreator non richiede libbotan, è quella in backports che dipende da essa.

Riabilita i backports, dai un update e riprova. Usa l'opzione "-t backports" per essere sicuro che apt-get prelevi i pacchetti dai backports e non da stable. Se non funziona neanche così, prova a forzare a mano l'installazione di libbotan-1.10, sempre usando l'opzione "-t backports".

Ritratto di Overflow10
Overflow10
(Newbie)
Offline
Newbie
Iscritto: 25/10/2014
Messaggi: 5

Ho risolto sistemando il file dei repository /etc/apt/sources.list
vi ringrazio