Problema di regolazione della luminosità su un portatile HP 6735s

5 risposte [Ultimo contenuto]
Ritratto di Debianfox
Debianfox
(Newbie)
Offline
Newbie
Iscritto: 29/09/2014
Messaggi: 4

Ciao...! Ho da poco installato Debian 7.6 su un HP 6735s e quindi mi sto occupando di far funzionare tutto, però non riesco a risolvere un problema con la luminosità. In pratica non ho il controllo sull'intensità dell'illuminazione (che adesso è al minimo) e non cambia nulla se provo a regolarla dal menu Impostazioni di sistema. I tastini di regolazione fn+F7, fn+F8 vengono riconosciuti perché compare un'icona quando li premo, come nello screenshot sotto, ma la luminosità resta al minimo.

La mia distribuzione è Debian 7.6 Wheezy (stable) 64-bit, con una scheda grafica integrata ATI Radeon HD3200.
Ho installato i driver proprietari della scheda grafica (pacchetto fglrx-legacy-drivers dal repository wheezy-backports) (e ho creato un file di configurazione per il server X con il comando aticonfig --initial).

Se può servire posto anche l'output del comando $lspci -nn -t -v:

-[0000:00]-+-00.0  Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
           +-01.0-[01]----05.0  Advanced Micro Devices [AMD] nee ATI RS780M/RS780MN [Mobility Radeon HD 3200 Graphics] [1002:9612]
           +-04.0-[02]----00.0  Marvell Technology Group Ltd. 88E8042 PCI-E Fast Ethernet Controller [11ab:4357]
           +-07.0-[03-05]--
           +-09.0-[06]----00.0  Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315]
           +-11.0  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] [1002:4391]
           +-12.0  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
           +-12.1  Advanced Micro Devices [AMD] nee ATI SB7x0 USB OHCI1 Controller [1002:4398]
           +-12.2  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
           +-13.0  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397]
           +-13.1  Advanced Micro Devices [AMD] nee ATI SB7x0 USB OHCI1 Controller [1002:4398]
           +-13.2  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller [1002:4396]
           +-14.0  Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller [1002:4385]
           +-14.2  Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) [1002:4383]
           +-14.3  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller [1002:439d]
           +-14.4-[80-8f]--
           +-14.5  Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399]
           +-18.0  Advanced Micro Devices [AMD] Family 11h Processor HyperTransport Configuration [1022:1300]
           +-18.1  Advanced Micro Devices [AMD] Family 11h Processor Address Map [1022:1301]
           +-18.2  Advanced Micro Devices [AMD] Family 11h Processor DRAM Controller [1022:1302]
           +-18.3  Advanced Micro Devices [AMD] Family 11h Processor Miscellaneous Control [1022:1303]
           \-18.4  Advanced Micro Devices [AMD] Family 11h Processor Link Control [1022:1304]

Riuscite a dirmi come capire dov'è il problema?

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

facendo un poco di ricerche ho notato che molti hanno tentato di risolvere mettendo mano a /etc/default/grub
alla riga

GRUB_CMDLINE_LINUX=""

modificandola in

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

Può essere un punto di partenza?

Ritratto di Debianfox
Debianfox
(Newbie)
Offline
Newbie
Iscritto: 29/09/2014
Messaggi: 4

Ti ringrazio, andr3a, il tuo commento credo che mi abbia portato sulla strada giusta. Non ho ancora risolto, ma inserendo il valore che mi hai indicato in /etc/default/grub e dando $sudo update-grub al riavvio la luminosità va al massimo; i tasti fn+F7, fn+F8 però non hanno più nessun effetto e se vado nel menu di sistema è sparita la barra di regolazione (screenshot).

Insomma come risultato sembra che abbia bloccato la luminosità ad un valore predefinito (il massimo per lo schermo forse). I lati positivi sono che così ci vedo di giorno (almeno!) e che se voglio la luminosità al minimo posso eliminare il parametro da passare al kernel ("acpi_backlight=vendor").

Dicevo che il tuo commento forse mi ha portato sulla giusta stada: all'avvio ho prestato più attenzione ai messaggi del kernel e ne ho letto uno che avevo notato ma che, non essendo segnalato come errore, avevo ignorato:
[...altro...] SP5100 TCO timer: mmio address 0xfec000f0 already in use
La luminosità cala quando quando viene stampato il messaggio, se non passo il parametro acpi_backlight (se lo passo invece il calo non c'è). Cercando un po' in rete ho letto di varie persone con un messaggio analogo a cui succedono varie cose, da "nulla" a "il sistema non si avvia". Il problema potrebbe avere a che fare con SP5100 tco timer quindi.

Purtroppo oggi non ho molto tempo per indagare, dovrò aspettare almeno domani.

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

non so se ti era capitato sottomano questo
http://ubuntuforums.org/archive/index.php/t-1958469.html
Il problema è un po' diverso ma si lavora sempre su grub e in modo diverso sembra aver risolto.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Un altro parametro del kernel che potrebbe aiutare è video.use_native_backlight=1 da usare al posto o insieme a acpi_backlight=vendor -- io proverei tutte le combinazioni. A volte l'informatica non è una scienza esatta! Smile

Ritratto di Debianfox
Debianfox
(Newbie)
Offline
Newbie
Iscritto: 29/09/2014
Messaggi: 4

Ho provato ad usare video.use_native_backlight=1 ma il kernel non lo riconosce... Ho un kernel 3.2.0.4 che non supporta ancora l'opzione. Con un prossimo aggiornamento del kernel (che spero sia imminente) però proverò.

Ho provato ad aggiungere al file di configurazione del server X "/etc/X11/xorg.conf" le seguenti righe, con cui X sarebbe stato in grado di gestire la luminosità:

Section "Device"
        Identifier "Screen"
        Option "Backlight" "intel_backlight"
EndSection

ma non ho ottenuto alcun effetto.

Nei prossimi giorni continuerò a fare ricerche, ma purtroppo non mi posso concentrare tanto a risolvere il problema per ora, il tempo scarseggia!
Chi avesse altre idee comunque si faccia avanti Big Grin