partizione dati vfat!

6 risposte [Ultimo contenuto]
Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

ho un problema con una partizione fat32 dove tengo i miei dati!!!

ho ricompilato il kernel e da quel momento in poi nn funziona più!

questo è il msg quando provo a montarla o smontarla:
" root@debian mnt # mount data
mount: wrong fs type, bad option, bad superblock on /dev/hda5, or too many mounted file systems "

questo è il file /etc/fstab:
" # /etc/fstab: static file system information.
#
#
proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hda6 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/hda5 /mnt/data vfat rw,users,auto 0 0
/dev/hda1 /mnt/windows vfat rw,users,noauto 0 0
"

e questa è la mia configurazione del kernel:
" *> Second extended fs support │ │
│ │ [*] Ext2 extended attributes │ │
│ │ [*] Ext2 POSIX Access Control Lists │ │
│ │ [*] Ext2 Security Labels │ │
│ │ Ext3 journalling file system support │ │
│ │ [*] Ext3 extended attributes │ │
│ │ [*] Ext3 POSIX Access Control Lists │ │
│ │ [*] Ext3 Security Labels │ │
│ │ [ ] JBD (ext3) debugging support │ │
│ │ Reiserfs support │ │
│ │ [ ] Enable reiserfs debug mode │ │
│ │ [ ] Stats in /proc/fs/reiserfs │ │
│ │ [ ] ReiserFS extended attributes │ │
│ │ < > JFS filesystem support │ │
│ │ < > XFS filesystem support │ │
│ │ Minix fs support │ │
│ │ ROM file system support │ │
│ │ [*] Quota support │ │
│ │ Old quota format support │ │
│ │ Quota format v2 support │ │
│ │ Kernel automounter support │ │
│ │ Kernel automounter version 4 support (also supports v3) │ │
│ │ CD-ROM/DVD Filesystems --->
DOS/FAT/NT Filesystems ---> │ │
│ │ Pseudo filesystems ---> │ │
│ │ Miscellaneous filesystems ---> │ │
│ │ Network File Systems ---> │ │
│ │ Partition Types ---> │ │
│ │ Native Language Support --->

MSDOS fs support │ │
│ │ VFAT (Windows-95) fs support │ │
│ │ (437) Default codepage for FAT │ │
│ │ (iso8859-1) Default iocharset for FAT │ │
│ │ NTFS file system support │ │
│ │ [ ] NTFS debugging support │ │
│ │ [ ] NTFS write support
"

sapete dirmi dove sta l'errore? la stessa cosa succede con la partizione fat32 windows

grazie

illoto

illoto --> :pint: --> :-o

Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

ho provato a darlo adesso ma niente da fare!

illoto --> :pint: --> :-o

Ritratto di cHroMe
cHroMe
(Geek)
Offline
Geek
Iscritto: 10/09/2004
Messaggi: 179

hai provato a montarla da root con l'opzioni -t vfat?
prova a farlo Xkè anke a me una paio di volte ha dato quell'errore (anke se era un disco esterno USB) e facendo così lo montava senza problemi, se ci riesci almeno puoi recuperare i dati finchè non riesci a risolvere
Ciao

«Faceva caldo, la notte che bruciammo Chrome....»
"Burning Chrome" William Gibson

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Ciao,
Quote:

" root@debian mnt # mount data
mount: wrong fs type, bad option, bad superblock on /dev/hda5, or too many mounted file systems "

Di solito questo mess me lo da quando tento di montare una partizione che non esiste...

Prova a postare il risultato di fdisk:
<br />#fdisk -l<br />

Che in teoria, con l'opzione auto, dovrebbe essere gia' montato...
Quote:

/dev/hda5 /mnt/data vfat rw,users,auto 0 0

Se e' solo per recuperare i dati potresti usare un cdlive (knoppix, per esempio...)

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di syneus
syneus
(Junior)
Offline
Junior
Iscritto: 17/09/2004
Messaggi: 16

Anche io dopo la ricompilazione del kernel ho avuto il tuo stesso problema.

Io l'ho risolto includendo nel kernel il seguente supporto:

File Systems ==> Native Language Support ==> Code page 437 (US, Canada)
File Systems ==> Native Language Support ==> Code page 852 (Central/EasternEurope ).

Spero di esserti stato di aiuto.

Ritratto di illoto
illoto
(Junior)
Offline
Junior
Iscritto: 16/10/2004
Messaggi: 29

perfetto era proprio questo l'errore!!! grazie mille syneus e grazie lo stesso anche agli altri!!!

illoto

illoto --> :pint: --> :-o