Non sono autorizzato a montare dischi USB!!!???

22 risposte [Ultimo contenuto]
Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho appena completato l'installazione del software che mi occorre sulla mia Jessie.
Collego un disco esterno ad una porta USB e provo a montarlo da dentro a thunar per cercare delle cose salvate in precedenza.
Mi compare un messaggio che mi dice che non sono autorizzato a compiere questa operazione.
Ho provato ad aggiungere l'utente al gruppo disk, al gruppo adm. Ho riavviato e riprovato. Niente, continuo a non essere autorizzato a montare il disco.
Ma è assurdo!!!
Come rimedio a questo?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
forse non sei nel gruppo plugdev, che DE hai installato ?

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

E invece nel gruppo plugdev ci sono da sempre.
Non ho installato nessun DE, solo OpenBox.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Zievatron ha scritto:

E invece nel gruppo plugdev ci sono da sempre.

E mica potevo saperlo io Wink

Con l'avvio di openbox avvi anche thunar --daemon ? thunar-volman è installato ?
Anche io uso openbox e thunar non mi da di questi problemi, e non è che abbia fatto chissà quali sofrzi per averlo funzionante quindi se ti chiedo delle ovvietà è perchè altro non saprei suggerirti.

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Non lo so. Non so neanche cosa sono.
Ho solo chiesto l'installazione di thunar e lasciato fare.
Openbox si avvia da solo. Cioè, ho l'avvio immediato tramite nodm.
Accendo il PC, aspetto che faccia le sue cose, ed ho la schermata grigia di Openbox nudo e crudo (per ora).
Era così anche con wheezy, ma non avevo mai avuto di questi problemi.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Cosa avvi di preciso con nodm per far partire openbox, /usr/bin/openbox o /usr/bin/openbox-session ?
Tieni presente che non conosco nodm quindi non so come va configurato.

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Non lo so.
Io ho solo editato il file di configurazione di nodm per cambiare NODM_ENABLED= da false a true e per mettere il nome dell'utente.
Il file è questo:

Citazione:

# nodm configuration

# Set NODM_ENABLED to something different than 'false' to enable nodm
NODM_ENABLED=true

# User to autologin for
NODM_USER=unknow

# First vt to try when looking for free VTs
NODM_FIRST_VT=7

# X session
NODM_XSESSION=/etc/X11/Xsession

# Options for the X server
NODM_X_OPTIONS='-nolisten tcp'

# If an X session will run for less than this time in seconds, nodm will wait an
# increasing bit of time before restarting the session.
NODM_MIN_SESSION_TIME=60

Suppongo che sia questa l'istruzione che fa partire anche Openbox:
NODM_XSESSION=/etc/X11/Xsession

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho trovato la soluzione al problema.
E' bastato installare usbmount ed ora ho il montaggio automatico anche per l'utente. Smile

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

No. Mi sono sbagliato. Il problema non si è affatto risolto.
Dev'essere successo che ho collegato un disco esterno prima di accendere il PC ed in questo modo viene montato.
Oppure, per qualche motivo ha smesso di funzionare, ma mi sembra troppo strano.
Ora ho appena provato a collegare un disco esterno, con il PC già acceso, ed il problema si è ripresentato.
Non sono autorizzato a montarlo. Sad

Ritratto di crashd
crashd
(Junior)
Offline
Junior
Iscritto: 12/10/2004
Messaggi: 26

A me non mi fa copiare i file nelle penne usb
Quindi do

Crashd $: su
Crashd #: thunar

Da root ho aperto thunar e posso fare qualsiasi cosa

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho provato ad usare thunar lanciandolo da root (anche se mi sembra una cosa sbagliata), ma non posso montarlo nemmeno da root.
Mi dice che è impossibile perchè: mount: special device /dev/sdb2 does not exist
La stessa cosa mi dice se tento di montarlo con il comndo mount.

In /etc/fstab lo vedo normalmente, ugualmente al primo:

/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
/dev/sdb2       /media/usb1     auto    rw,user,noauto  0       0

Se do il comando mount sul primo, giustamente, mi dice che è già montato.
Sul secondo mi dice che non esiste.