Errore, pkgProblemResolver::Resolve ha generato delle interruzioni

9 risposte [Ultimo contenuto]
Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

Salve! sto provando ad installare wine32 per far girare un programma solo per windows ma ottengo questo errore con messaggi:

root@nirvana:~# apt-get install wine32
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze... Fatto
Lettura informazioni sullo stato... Fatto   
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 libcurl3-gnutls : Dipende: libssh2-1 (>= 1.7.0) ma non è installabile
 libqt5location5 : Dipende: libqt5gui5 (>= 5.9.0~beta) ma non sta per essere installato oppure
                            libqt5gui5-gles (>= 5.9.0~beta) ma non sta per essere installato
 libqt5multimedia5 : Dipende: libqt5gui5 (>= 5.15.2+dfsg~) ma non sta per essere installato oppure
                              libqt5gui5-gles (>= 5.15.2+dfsg~) ma non sta per essere installato
 libqt5quick5-gles : Dipende: libqt5gui5 (>= 5.15.1) ma non sta per essere installato oppure
                              libqt5gui5-gles (>= 5.15.1) ma non sta per essere installato
 libqt5webenginecore5 : Dipende: libqt5gui5 (>= 5.15.2+dfsg~) ma non sta per essere installato oppure
                                 libqt5gui5-gles (>= 5.15.2+dfsg~) ma non sta per essere installato
 libqt5widgets5 : Dipende: libqt5gui5 (>= 5.15.1) ma non sta per essere installato oppure
                           libqt5gui5-gles (>= 5.15.1) ma non sta per essere installato
 libqt5x11extras5 : Dipende: libqt5gui5 (>= 5.15.2+dfsg~) ma non sta per essere installato oppure
                             libqt5gui5-gles (>= 5.15.2+dfsg~) ma non sta per essere installato
 qml-module-qtquick-layouts : Dipende: libqt5gui5 (>= 5.5.0) ma non sta per essere installato oppure
                                       libqt5gui5-gles (>= 5.5.0) ma non sta per essere installato
 qt5-gtk-platformtheme : Dipende: libqt5gui5 (>= 5.14.1) ma non sta per essere installato oppure
                                  libqt5gui5-gles (>= 5.14.1) ma non sta per essere installato
 transmission : Dipende: transmission-gtk (>= 3.00-1) ma non sta per essere installato oppure
                         transmission-qt (>= 3.00-1) ma non sta per essere installato oppure
                         transmission-cli (>= 3.00-1) ma non sta per essere installato
E: Errore, pkgProblemResolver::Resolve ha generato delle interruzioni. Questo potrebbe essere causato da pacchetti bloccati.

sources.list:

deb http://deb.debian.org/debian/ stable main contrib non-free
deb-src http://deb.debian.org/debian/ stable main contrib non-free
 
deb http://security.debian.org/debian-security bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security bullseye-security main contrib non-free
 
deb http://deb.debian.org/debian/ bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib non-free
 
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 
#backports
#deb http://deb.debian.org/debian bullseye-backports main
#fasttrack
#deb https://fasttrack.debian.net/debian-fasttrack/ bullseye-fasttrack main contrib
#deb https://fasttrack.debian.net/debian-fasttrack/ bullseye-backports-staging main contrib
#phpmyadmin
#deb http://ftp.debian.org/debian unstable main contrib
#visual studio code
#deb [arch=amd64 signed-by=/usr/share/keyrings/microsoft-archive-keyring.gpg] https://packages.microsoft.com/repos/vscode stable main

ora giro su debian stable ma precedentemente avevo la unstable di bullseye
come posso risolvere?
Grazie

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
dal tuo post non capisco se tu abbia seguito la procedura corretta per l'installazione di wine. Quindi mi permetto di segnalarti la guida dal wiki di Debian.

installazione di wine

Ti segnalo anche il wiki di WineHQ con le istruzioni per impostare il loro repository, se vuoi l'ultima versione disponibile.

winehq repository

Probabilmente ti manca l'abilitazione del multiarch.

Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

ciao, grazie dell'intervento. Ho seguito la wiki ma mi da lo stesso problema.
La wiki fa notare che è possibile incorrere nel mio problema se i pacchetti 32bit e 64bit non sono della stessa versione.
Forse ho qualche pacchetto non stable? come faccio a vedere se sia questa la situazione?
grazie

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
ma se esegui la classica sequenza :

sudo apt update
sudo apt upgrade

ti segnala qualche errore/problema ?
Per controllare se hai pacchetti da testing prova ;

sudo apt-show-versions | grep testing

magari anche :

sudo apt policy wine

per vedere da dove lo vuole scaricare/installare.

Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

apt-get update && apt-get upgrade
non da errori e non c'è niente da installare di nuovo.
apt-show-versions | grep unstable
apt-show-versions | grep testing
non riportano nulla.
per il resto:

root@nirvana:~# apt policy wine32
wine32:i386:
  Installato: (nessuno)
  Candidato:  5.0.3-3
  Tabella versione:
     5.0.3-3 500
        500 http://deb.debian.org/debian stable/main i386 Packages

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Strano .... sei sicuro di non avere abilitato qualche altro repository che magari va in conflitto ?
Il comando

ls -l /etc/apt/sources.list.d/

riporta qualcosa ?

Anche perché dal tuo primo post gli errori sembrano riferirsi a pacchetti che non mi pare abbiano nulla a che fare con wine ( libqt e compagni e anche transmission che è un client torrent ).

Per ora altro non mi viene in mente.
Ciao.

Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

andrea@nirvana:/$ ls -l /etc/apt/sources.list.d/
totale 12
-rw-r--r-- 1 root root 189  2 apr  2020 google-chrome.list
-rw-r--r-- 1 root root  86 29 set 10.57 metasploit-framework.list
-rw-r--r-- 1 root root 203 17 mar  2021 vscode.list

ho questo

eh infatto che c'azzecca transmission con wine? mah
comunque grazie dell' interessamento

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

andrea@nirvana:/$ ls -l /etc/apt/sources.list.d/
totale 12
-rw-r--r-- 1 root root 189  2 apr  2020 google-chrome.list
-rw-r--r-- 1 root root  86 29 set 10.57 metasploit-framework.list
-rw-r--r-- 1 root root 203 17 mar  2021 vscode.list

ho questo

eh infatto che c'azzecca transmission con wine? mah
comunque grazie per l'interesse

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
scusa se rispondo solo adesso ma non mi arrivano più le notifiche via mail dei messaggi relativi alle discussioni a cui partecipo sul forum.

Detto questo prova a controllare i repository di google e metasploit per vedere se vanno aggiornati a bullseye, oppure che siano effettivamente compatibili con la nuova versione di debian.

Ritratto di andrea0
andrea0
(Geek)
Offline
Geek
Iscritto: 17/07/2017
Messaggi: 72

badroot ha scritto:

Ciao,
scusa se rispondo solo adesso ma non mi arrivano più le notifiche via mail dei messaggi relativi alle discussioni a cui partecipo sul forum.

Detto questo prova a controllare i repository di google e metasploit per vedere se vanno aggiornati a bullseye, oppure che siano effettivamente compatibili con la nuova versione di debian.


neanche a me arrivavano, ora mi sono iscritto al thread :-p ora vedo se risolvo con questi ultimi suggerimenti, grazie ancora

Devi cercare di trovare il lato positivo in ogni situazione. cit Dalai Lama