Debian Muta

27 risposte [Ultimo contenuto]
Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ciao a tutti,
Mi sono accorto solo adesso che la mia Debian wheezy minimale è muta.
Ho provato ad avviarla con il kernel originale, caso mai avessi deselezionato io qualcosa di necessario per l'audio.
Ma è proprio muta anche con il kernel originale.
Non ho installato ancora nessun player multimediale. Mi riferisco solo a qualche prova fatta con la pantegana polare, ehm... cioè... con Iceweasel Big Grin , su youtub. Il video parte senza problemi, ma dalle casse collegate al PC non si sente una nota.
Potrebbe essere che gli manca un plug-in?
Ma io adesso vorrei accertare che l'audio sia a posto senza aggiunte particolari.
Quindi mi occorrerebbe un sito con qualcosa di audio che sicuramente non richieda plug-in aggiuntivi.

EDIT: Dimenticavo:
Ho solo OpenBox, niente DE.
lspci, dell'audio mi dice questo:

00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
	Subsystem: Micro-Star International Co., Ltd. Device 7731
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at feb44000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
 
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
	Subsystem: Micro-Star International Co., Ltd. Device 7731
	Flags: bus master, slow devsel, latency 32, IRQ 16
	Memory at feb40000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

Se occorrono altre informazioni, ditemi anche come chiederle al PC.

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Copia un file wav e riproducilo con aplay, vedi se esce il suono. Se senti l'audio sei ok e nel browser ti manca qualche plugin di vlc o totem:

esempio:

$ aplay "./.PlayOnLinux/wineprefix/AOE2_king/drive_c/Program Files/Microsoft Games/Age of Empires II/Sound/terrain/tf4.wav"
Playing WAVE './.PlayOnLinux/wineprefix/AOE2_king/drive_c/Program Files/Microsoft Games/Age of Empires II/Sound/terrain/tf4.wav' : Signed 16 bit Little Endian, Rate 22050 Hz, Mono

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho provato ed ho ottenuto questo:

$ aplay Oche.wav
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:682: audio open error: File o directory non esistente

Il file però è lì e si chiama Oche.wav

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

Vedi se risolvi con questo link.

Ciao, Franco

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho provato a creare il file /etc/asound.conf come suggerito dal link:

pcm.!default {
   type hw
   card 1
}
ctl.!default {
   type hw
   card 1
}

Ed ho riprovato.
Con i brani su youtube non è cambiato niente.
Con il file Oche.wav richiamato con aplay ho ottenuto un messaggio diverso:
$ aplay Oche.wav
Playing WAVE 'Oche.wav' : Unsigned 8 bit, Rate 11025 Hz, Mono
aplay: set_params:1081: Sample format non available
Available formats:
- S16_LE
- S32_LE

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

Io su Lxde e Openbox ho fatto:

sudo apt-get install alsa-base alsa-utils
alsactl init
aplay /usr/share/sounds/alsa/*

Se non funziona prova a farlo con il kernel originale.
Se ad un riavvio non funziona inseriscilo nell'autostart.
Certo devi essere stato parecchio impegnato per accorgertene solo ora, cosa hai fatto fino ad'ora? Hai compilato un kernel? Laughing
Hello! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

Cosa ti restituisce il comando:
~$ cat /proc/asound/cards
E' da questo output che devi scegliere la scheda da impostare come default.
Per provare una scheda audio, prima con alsamixer controlli quali canali sono muted nella tua scheda audio, che selezioni con F6, premi "m" e alzi il volume poi la provi con speaker-test:
~$ man speaker-test
Comunque penso che installando pulseaudio ti risparmierai un sacco di grattacapi, vedi tu.

Ciao, Franco

Ritratto di lollix01
lollix01
(Monster)
Offline
Monster
Iscritto: 22/02/2014
Messaggi: 411

frank67 ha scritto:


Cosa ti restituisce il comando:
~$ cat /proc/asound/cards
E' da questo output che devi scegliere la scheda da impostare come default.
Per provare una scheda audio, prima con alsamixer controlli quali canali sono muted nella tua scheda audio, che selezioni con F6, premi "m" e alzi il volume poi la provi con speaker-test:
~$ man speaker-test
Comunque penso che installando pulseaudio ti risparmierai un sacco di grattacapi, vedi tu.


Mai avuto problemi con Alsa. Quali grattacapi?
Hello! Smile

We are MicroSoft. You will be assimilated. Resistance is futile.
-- Attributed to B.G., Gill Bates

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

Ho ottenuto queste informazioni:

cat /proc/asound/cards
 0 [Loopback       ]: Loopback - Loopback
                      Loopback 1
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 19
 2 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfeb40000 irq 16 

 aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: Loopback [Loopback], device 1: Loopback PCM [Loopback PCM]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SB [HDA ATI SB], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SB [HDA ATI SB], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Quindi, ora, come dovrei procedere?

Aggiungo che, avviando alsamixer, mi propone:
Card: HD-Audio Generic
Nella schermata, sotto le voci di identificazione, non compare niente altro che un quadratino al centro,che posso passare da MM a 00, ma non c'è niente latro. Suppongo sia perchè non ho niente collegato all'uscita HDMI.
Clickando F6, posso passare a:
Card: HDA ATI SB
Con questa, nella schermata PLAYBACK ho le colonne di:
Master Headphone PCM tutte e tre attive (00) e colorate al massimo (100)
poi ho le colonne di MIc e Mic Boost azzerate
poi ho i quadretti attivi (00) di S/PDIF e S/PDIF Default ed infine l'indicazione di enabled per auto-mute mode.

Ho cambiato il numero della scheda di default nel file /etc/asound.conf passandolo da 1 a 2.
Ora, aprendo AlsaMixer mi compare direttamente la scheda giusta. Però il risultato non è cambiato nè su youtube, nè provando:
aplayer Oche.wav

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

  1. Il Kernel che utilizzi per le prove è quello di Debian?
  2. Il tuo utente appartiene al gruppo audio? Funziona il comando: ~$ sudo aplay /usr/share/sounds/alsa/Noise.wav
  3. Escludi un errato collegamento dell'uscita audio degli altoparlanti, il sistema lo hai funzionante ad esempio con una live?

Ciao, Franco

Ritratto di Zievatron
Zievatron
(Monster)
Offline
Monster
Iscritto: 16/03/2014
Messaggi: 338

frank67 ha scritto:

  1. Il Kernel che utilizzi per le prove è quello di Debian?
  2. Il tuo utente appartiene al gruppo audio? Funziona il comando: ~$ sudo aplay /usr/share/sounds/alsa/Noise.wav
  3. Escludi un errato collegamento dell'uscita audio degli altoparlanti, il sistema lo hai funzionante ad esempio con una live?

1. Sì.
2. Ottengo:
# aplay /usr/share/sounds/alsa/Noise.wav
aplay: main:682: audio open error: File o directory non esistente

Ma l'affermazione "File o directory non esistente" è falsa. Verificando, ottengo:
root@debian:/usr/share/sounds/alsa# ls -al
totale 1216
drwxr-xr-x 2 root root   4096 mag 12 13:40 .
drwxr-xr-x 3 root root     17 mag 12 13:40 ..
-rw-r--r-- 1 root root 137134 gen 10  2013 Front_Center.wav
-rw-r--r-- 1 root root 142128 gen 10  2013 Front_Left.wav
-rw-r--r-- 1 root root 146990 gen 10  2013 Front_Right.wav
-rw-r--r-- 1 root root 135202 gen 10  2013 Noise.wav
-rw-r--r-- 1 root root 130096 gen 10  2013 Rear_Center.wav
-rw-r--r-- 1 root root 126064 gen 10  2013 Rear_Left.wav
-rw-r--r-- 1 root root 146480 gen 10  2013 Rear_Right.wav
-rw-r--r-- 1 root root 134868 gen 10  2013 Side_Left.wav
-rw-r--r-- 1 root root 129966 gen 10  2013 Side_Right.wav

3. Ora provo.