Debian FDE

27 risposte [Ultimo contenuto]
Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

Buongiorno a tutti e grazie per eventuali interventi di aiuto.
Non riesco in nessun modo ad avviare normalmente il pc.
All'accensione dopo che mi fa decriptare il volume mi manda in shell
con richiesta login. Stessa cosa in recovery mode.

Volume group "DEBIAN-vg" not found
Skipping volume group DEBIAN -vg
Unable to find LVM volume DEBIAN.vg/root
Volume group "DEBIAN-vg" not found
Skipping volume group DEBIAN -vg
Unable to find LVM volume DEBIAN.vg/swap_1
Please unlock disk sda5_crypt:

Decripto il volume senza problemi e mi manda qui:

Debian GNU/Linux 9 DEBIAN tty1

DEBIAN login:

Mi loggo e mi scrive giorno-mese-anno ed orario di accesso e

Linux DEBIAN 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u5 (2017-09-19)

scrive inoltre che è un software libero, dove si trova il file usr/share/doc/*/copyright ecc..ecc..

e siamo qui:

klais@DEBIAN:~$
digito su

Password:
root@DEBIAN:/home/klais#

digito il comando cat /proc/version
e mi conferma:
L
inux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4.1) #1 SMP

digito il comando cat /etc/issue

e mi dice che la distribuzione installata è:
Debian GNU/Linux 9 \n \l

Sono arrivato qui dopo che ho smanettato un pò con Aptitude ma non mi sembra di aver fatto
qualche azione particolare. Sembrava come che non ci fosse più il Sistema Operativo.
Inutile provare con apt-get: Risoluzione di "ftp.it.debian.org" temporaneamente non riuscita
Mi domando come mai non si avvii normalmente.....
Avete qualche soluzione in merito?
E' da tre giorni che non riesco a venirne a capo.
Grazie a tutti....

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Ciao, benvenuto su forum. Quello che hai descritto rappresenta un normale e regolare avvio del sistema operativo in modalità testuale. Forse quello che ti lascia interdetto è la mancanza dell’interfaccia grafica, la quale evidentemente non si è avviata o perché la sezione grafica del sistema operativo non è correttamente configurata, oppure perché non hai installato i programmi necessari ad avviare l’interfaccia grafica. Se disponi di un collegamento di rete funzionante e riconosciuto dal sistema operativo, puoi installare i pacchetti dei programmi che contengono interfaccia grafica usando il comando apt-get. I pacchetti che vorrai installare sono diversi a seconda dell’interfaccia grafica che preferisci usare.

Segnalo che nel log che hai inviato c’è una incongruità tra la versione del sistema operativo Debian 9 e la versione del kernel installato: hai forse riportato una errata versione del sistema operativo? Stai forse accedendo ad un sistema operativo installato in remoto su un server?

Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

Ciao homeless, è molto probabile che io non sia molto chiaro nelle spiegazioni e me ne scuso
anticipatamente. Ti premetto che il sistema lo usavo quotidianamente senza problemi fino a quando
di punto in bianco non mi si è più avviato normalmente come faceva sempre. L'unico episodio che
mi viene in mente e che mi fa pensare a qualche errore da parte mia è quello che mi sono messo
a smanettare con Aptitude. Non l'ho mai utilizzato....mi ricordo anche che sono andato a finire
sull'editor Nano, ma non mi sembra che abbia fatto azioni particolari (almeno credo ) per il resto
è come ho descritto. Alla verifica mi dice che il SO presente è Debian 9 e il kernel che mi riporta
è quello.
Ora ho connesso direttamente via cavo il pc ad internet,
accendo e dopo che mi chiede la password per decriptare il volume (sia in modalità normale che in recovery mode)
avvia tutti i servizi ecc...ecc.... ed ecco dove mi porta:

Welcome to rescue mode! Type "systemctl default" or ^D to enter default mode.
Type "Journalctl -xb" to viev system logs.Type "systemctl reboot" to reboot.
Give root password for maintenance
(or type Control-D to continue): (ridigito la password ed entro come root e do il comando apt-get update)

root@DEBIAN:~#apt-get update
Err:1 http://ftp.it.debian.org/debian stretch InRelease
Risoluzione di "ftp.it.debian.org" temporaneamente non riuscita
Err2: http://security.debian.org stretch/updates InRelease
Risoluzione di "security.debian.org" temporaneamente non riuscita
Err3: http://ftp.it.debian.org/debian stretch-updates InRelease
Risoluzione di "ftp.it.debian.org" temporaneamente non riuscita
Err4: http://ftp.it.debian.org/debian stratch-backports InRelease
Risoluzione di "ftp.it.debian.org" temporaneamente non riuscita
Lettura elenco dei pacchetti.....Fatto
W: Impossibile recuperare http://ftp.it.debian.org/debian/stretch/InRelease Risoluzione di "ftp.it.debian.org" temporaneamente non riuscita
W: Impossibile recuperare http://security.debian.org/dists/stretch/updates/InRelease Risoluzione di "ftp.it.debian.org" temporaneamente non r
W: Impossibile recuperare http://ftp.it.debian.org/debian/dists/stretch-updates/InRelease Risoluzione di "ftp.it.debian.org" temporaneamente n
W: Impossibile recuperare http://ftp.it.debian.org/debian/dists/stretch-backports/InRelease Risoluzione di "ftp.it.debian.org".........
W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.
root@DEBIAN:~#

Questo è il risultato.Direttamente sul mio computer.Da niubbo personalmente penso che non ci sia ne una connessione ne tantomeno una interfaccia grafica che permetta perlomeno al sistema di avviarsi in modalità grafica.....mah....non so più cosa fare
Help me bro....grazie di cuore.

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Da quanto scrivi, sembra che il sottosistema di rete sia in parte o del tutto non funzionate. E' molto probabile che hai pasticciato in modo rilevante con il gestore dei pacchetti. Dai log che hai inviato, risultano varie incogruenze, di cui la principale è la non corrispondenza tra versione di Debian e versione del kernel. Inoltre, all'avvio il sistema operativo sembra non riconoscere un volume group, che forse contiene altre parti del sistema operativo, che quindi potrebbero non avviarsi. Ciò detto, potrebbe essere utile, come riferisce il sistema, prendere visione dei log, riversandoli su una penna USB che poi puoi inserire su un altro computer dove hai accesso ad internet. In ogni caso, mi sembra di capire che sei in una condizione dove lo sforzo di rendere il sistema rifunzionante (se possibile) è molto maggiore di quello necessario per una re-installazione. A te la scelta sulla strada da seguire: facci sapere.

Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

Si, effettivamente vorrei recuperare il sistema, se possibile. Come hai potuto vedere si tratta di un SO criptato
e quindi ogni dato sensibile, di conseguenza, lo cripto regolarmente. Da questo sistema ho criptato una microusb che
sblocco ogni volta che accedo al pc dove tengo tutti i miei documenti importanti...una sorta di cassaforte Smile.Non so
se magari c'è la possibilità di recuperare i file su questa microusb e poi potervi accedere dopo una reinstallazione,
l'istinto mi dice che è impossibile,quindi opterei per uno "sforzo" nel cercare un recupero del sistema operativo, ma
le mie conoscenze in materia non me lo permettono.....ho bisogno di un aiuto passo passo già anche dallo stesso consiglio
che mi hai dato e cioè quello di riversare su una pendrive i log. Forse sono troppo paranoico riguardo la sicurezza, ma fino
ad oggi con questo sistema mi ci sono trovato veramente bene e non ho mai avuto problemi di nessun tipo. Un unico errore che sembra mi sia costato molto caro.....eppure avevo acquisito una certa dimestichezza ( cosi credevo ). E' proprio quando si è troppo sicuri di se stessi che si prendono calci in c... (nel sedere) Smile.
Che dici...possiamo provarci?
Grazie mille homeless

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Invia il log.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2913

Prima di tentare alla cieca, cerca di capire cosa funziona e cosa no. Hai un sistema semifunzionante: è usabile o no? I file system sono stati montati (df)? Accedi a tutte le directory di sistema? E alla tua home? Puoi fare un backup dei tuoi dati su un supporto esterno? Hai a disposizione un cavo ethernet: se dall'altra parte c'è un router con DHCP, puoi metter su una connessione a mano, tipo:

echo "iface eth0 inet dhcp" >>/etc/network/interfaces
ifup eth0

Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

Ciao mcortese, grazie per l'interesse a riguardo. Purtroppo non sono in grado di fare un backup dei dati su un supporto esterno
utilizzando il terminale. Ho cercato in rete ma non ho trovato nulla. Intanto vediamo se le immagini che ho inserito possono aiutarci
intanto a capire qualcosa..... http://dropcanvas.com/newf6
Ho utilizzato dropcanvas perchè non saprei come fare visto che qui posso allegare solo file non oltre 1mb.

Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

http://dropcanvas.com/newf6

Ciao homeless, in queste immagini troviamo sia la distro in uso, il kernel e i moduli grafici
insieme ai log ed altre informazioni, spero che possano essere utili.

Ritratto di claid
claid
(Junior)
Offline
Junior
Iscritto: 25/01/2018
Messaggi: 15

Ciao mcortese, aggiungo questa immagine del risultato della prova di connessione che mi hai suggerito:

http://dropcanvas.com/1pi56

Cosa ne pensi? Non vorrei essere (s)cortese Smile, ma sembra che non vi interessi più aiutarmi a risolvere
questa situazione.....devo rassegnarmi?
Grazie di cuore...

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1254

Ciao Claid, qui siamo tutti desiderosi di aiutarti, ma personalmente da come hai inviato i log (schermate e non log completi di sistema) e a causa della quasi completa mancanza di indicazioni specifiche su come avevi configurato il sistema e su cosa hai fatto per condurlo al malfunzionamento, mancano molti elementi concreti per poterti dare un aiuto efficace. Peraltro, dai frammenti di log emergono incongruenze tra la capacità del sistema operativo di avviarsi in modalità di manutenzione con un’unica partizione (come ci hai descritto) e l’esistenza di partizioni LVM destinate ad ospitare parti fondamentali del sistema operativo (come /usr). Questo si aggiunge alla apparentemente inspiegabile incongruenza tra versione di Debian è versione del kernel. È quasi come se ci avessi descritto due diverse installazioni.

Ciò detto, senza volermi sostituire a mcortese, le sue indicazioni si sono dimostrate, dai log, efficaci nel ripristinare il collegamento di rete. Dopo aver ripristinato la rete, puoi tentare, dopo avere messo in salvo i file che non puoi permettermi di perdere e che risiedono sul disco rigido, di fare un aggiornamento via rete del sistema operativo. A tal fine, puoi impartire i comandi:

script log.txt
apt-get update
apt-get upgrade
apt-get dist-upgrade 
exit

Il log di queste operazioni sarà in log.txt