Come installare su un disco secondario

13 risposte [Ultimo contenuto]
Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

Buongiorno; mi piacerebbe provare Linux, però da solo ho delle difficoltà;

Ho provato con altri OS (p.e. ubuntu, opensuse);
riesco ad installarli sul disco principale, però mi piacerebbe lasciare windows su un disco e Linux su un'altro completamente (per poter provare)

Ho fatto qualche prova, ma mi trovo sempre con la partenza sul I disco oppure a volte installa sul II disco, però mi dice grub error;
Da quello che ho capito ubuntu deriva da Debian;

Allora ho pensato di chiedere "alla base" cioè voi.

ora ho scaricato il 1 dvd di Debian 4.4 a 32 bit e il secondo dvd dovrebbe arrivare tra poco.

se c'è una guida o qualche idea su come potrei fare, sarà un piacere.
Grazie

Ritratto di linuxnic
linuxnic
(Monster)
Offline
Monster
Iscritto: 10/07/2005
Messaggi: 241

Quote:

ciro64 ha scritto:
Buongiorno; mi piacerebbe provare Linux, però da solo ho delle difficoltà;

Ho provato con altri OS (p.e. ubuntu, opensuse);
riesco ad installarli sul disco principale, però mi piacerebbe lasciare windows su un disco e Linux su un'altro completamente (per poter provare)

Ho fatto qualche prova, ma mi trovo sempre con la partenza sul I disco oppure a volte installa sul II disco, però mi dice grub error;
Da quello che ho capito ubuntu deriva da Debian;

Allora ho pensato di chiedere "alla base" cioè voi.

ora ho scaricato il 1 dvd di Debian 4.4 a 32 bit e il secondo dvd dovrebbe arrivare tra poco.

se c'è una guida o qualche idea su come potrei fare, sarà un piacere.
Grazie

Quando avevo il fisso installavo le distro Linux sul secondo hd cioè quello secondario dove non risiedeva win.
Per fare ciò usavo Gag ma comunque secondo me se Debian o qualsiasi distro Linux riconosce(e ormai lo dovrebbero fare tutte)il secondo hd installando Grub nell'MBR non dovresti avere problemi.
Ciao

-= Nic =-
Amico di Emergency_2009
Linux registered user # 380338
Linux registered machine # 283289

Ritratto di Stemby
Stemby
(Guru)
Offline
Guru
Iscritto: 05/10/2006
Messaggi: 776

Proprio ieri ho dovuto fare un'installazione di quel tipo.

L'installer trova windows automaticamente, ti genera un /boot/grub/menu.lst già configurato correttamente.

Ti consiglio (non è l'unica soluzione!):
1) Installare Debian su primary master (se il disco è IDE, per SATA non so bene perché ho meno esperienza). Per far questo devi partizionare il disco hda (in pratica tutto quello che ti propone di default in fase d'installazione)
2) Avere winzozz già installato su un altro disco, collegato e alimentato correttamente
3) Installare GRUB sul MBR (quello che viene proposto di default)

A questo punto sarà già tutto funzionante: GRUB avviando win ingannerà il sistema_molto_stupido facendogli credere di essere lui il primo disco (infatti win deve essere installato in teoria sul primo disco).

Registered Linux User #443882
Registered Debian User #9

Ritratto di bricke
bricke
(Guru)
Offline
Guru
Iscritto: 17/08/2005
Messaggi: 650

Quote:

ciro64 ha scritto:
Buongiorno; mi piacerebbe provare Linux, però da solo ho delle difficoltà;

Buonasera
E chi non le ha!

Quote:

Ho provato con altri OS (p.e. ubuntu, opensuse);
riesco ad installarli sul disco principale, però mi piacerebbe lasciare windows su un disco e Linux su un'altro completamente (per poter provare)

Mi pare sensato, procedi.

Quote:

Ho fatto qualche prova, ma mi trovo sempre con la partenza sul I disco oppure a volte installa sul II disco, però mi dice grub error;

Se installi sul secondo hd non c'è nessun problema e l'installazione procede liscia, quando però arriva il momento di installare Grub (quello che all'avvio ti permette di scegliere cosa far partire) questo può essere installato in molte parti, il mio consiglio è installarlo nel MBR (default) così facendo sovrascrive il master boot record di windows (non perdi nulla) e ti permette poi di avviare o win o lin, altrimenti puoi installare grub nella prima partizione del hd dove hai messo debian e poi tramite un programma come GAG (che va installato comunque nel MBR e quindi lo sovrascrive) avvii grub che si trova nel secondo hd, che a sua volta avvia debian.

Consiglio metti grub nel MBR.
Quote:

Da quello che ho capito ubuntu deriva da Debian;

Si

Quote:

Allora ho pensato di chiedere "alla base" cioè voi.

Hai fatto bene.

Quote:

ora ho scaricato il 1 dvd di Debian 4.4 a 32 bit e il secondo dvd dovrebbe arrivare tra poco.

Sei sicuro che ti servano i due dvd?
Io solitamente una installazione di base la faccio con il primo CD solamente, gli altri cd/dvd contengono solo pacchetti aggiuntivi che probabilmente non ti serviranno.

Quote:

se c'è una guida o qualche idea su come potrei fare, sarà un piacere.
Grazie

Sicuramente c'è una guida, ma oramai ho scritto un poema e non voglio cancellarlo Laughing

Benvenuto in famiglia

ps.: MA con ubuntu grub che errore ti dava? Non mi pare che le ultime versioni di ubuntu lascino scegliere all'utente dove installare grub, almeno non nell'installazione canonica.

ps2.: ti faccio notare che stai installando debian 4, ossia la versione stabile, che come pacchetti software non è aggiornatissima (appunto perchè deve essere stabile), non ti meravigliare se a confronto con opensuse o ubuntu senbra uscita dal secolo scorso, si può sempre aggiornare/customizzare!

Questo è Unix. Ti dà abbastanza corda per impiccarti da solo. --Miquel van Smoorenburg

Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

Innanzitutto voglio ringraziare per le risposte e per il 'Poema' e mi scuso del ritardo....

Dunque:

avendo un disco sata interno ed uno usb esterno (che vorrei usare per provare ben sapendo che potrei fare molti pasticci, ma fa niente Laughing, vorrei almeno per ora lasciare i duo OS separati in tutto e per tutto; (a far installazione col boot loader su I disco, ubuntu funzionava ma poi vista andava in modalità provvisoria (boh... mah.... devo aver fatto qualche altro casino)

l'errore con ubuntu e Suse e sabayon era grub error 17 (cannot mount.. ecc);

quindi significa che almeno l'ho installato sul disco (ho testualmente scritto /dev/sdc... non so se dovevo specificare in modo diverso);

con un po' di tempo, guardo 'gag'

Un'altro problemino è che Debian 4 r 4 (per 32 bit) non mi trova la scheda di rete (nel mio caso ho una asus p5k e la scheda integrata dovrebbe essere Atltansic L1 gigabit)

sul sito di asus ho trovato i drivers per Linux per questa LAN;
però, al momento non so come preparare un supporto (cd o floppy?) da aggiungere in fase di installazione (intendo come scompattare l'archivio e preparare correttamente il supporto)

Il fatto di usare l'installazione in modo testo, è sicuramnente più complessa, anche se questo alla fine potrà dar più soddisfazione e capire di più.

spero di non sembrare logorroico.

in sintesi mi cheido:

invece di /dev/sdc (che non va), dovevo scrivere diversamente?

se non ricordo male l'installazione proponeva di mettere bootloader anche in secondo momento.

2 come potrei fare per i drivers LAN.

Vi ringrazio davvero molto ......

(ho paura di scrivere in modo poco chiaro... spero sia 'accettabile')

Ciao

ciro64

ps: la parola 'stabile' mi piace... altrimenti farò fatica a capire se eventuali cose strane dipendono da me o da un sistema meno stabile.

aggiornare dopo? ok (ma le fondamenta solide penso siano 'fondamentali' Big Grin

ancora grazie ciao a tutti Voi.

Ritratto di bricke
bricke
(Guru)
Offline
Guru
Iscritto: 17/08/2005
Messaggi: 650

Cavolo avevo scritto un'altro poema, ma me lo sono mangiato chiudendo FF...

In sintesi:
Non ci avevi detto che il secondo HD è un HD USB!!!
Il tuo pc fa il boot da USB? Grub parte poichè è installato nel primo hd, ma i suoi dati sono nel hd usb e se questo non è montato in avvio (quando serve a grub) grub ti da un errore.

Se il tuo pc fa il boot da usb, ci sono moltissime guide su come installare linux su hd usb, altrimenti hai due soluzioni:

1. DIfficile: Crei un cd di boot che a sua volta ti permette di fare il boot da hd esterno usb.

2. Liberi un pochino di spazio nel primo hd (salvando prima tutto ecc...) e installi linux li, direi che se liberassi 10GB in totale, sarebbe magnifico.

Ciao

Questo è Unix. Ti dà abbastanza corda per impiccarti da solo. --Miquel van Smoorenburg

Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

mi spiace se commetto errori a scriver (purtroppo non sono un informatico... anzi, recentemente ho scoperto un nuovo termine ('niubbo' Sad) che penso mi si addica.

Quando ho provato ubuntu (ma stesso risultato con Suse o sabyon), con l'installazione da live CD o live DVD, mettendo il bootloader (Grub) sul I disco (SATA), la cosa andava;

Però poi vista (qualcuno lo chiama svista), non so come mai, ripartiva solo in modalità provvisoria oppure vedevo errori che non capivo all avvio (??? boh ???)

oggi ho trovato questa discussione (purtroppo l'inglese lo mastico poco): http://ubuntuforums.org/showthread.php?t=244788

quindi da quel poco che posso capire, qualche aggiornamento può "rovinare" il bootloader?

Per evitare tutto questo ho pensato di lasciare separati i due sistemi operativi, bootloader compreso.

Tornando alle prove con sabayon o suse o ubuntu, in modo grafico avevo scelto di far fare tutto sul disco secondario.usando impostazioni automatiche.

però al riavvio (bootando da HDD usb), ecco l'errore;

Tornando a Debian 4 r 4, sono arrivato in modo testuale ad installare il sistema operativo;

il punto cruciale forse è dove mettere il bootloader:
di default vede che c'è longhorn di vista e lo propone come scelta primaria;

però leggendo un po l'aiuto, dice che posso installare boot loader anche su un floppy (fd0) oppure su altro disco.

allora ho scelto /dev/sdc (che sarebbe appunto il mio disco usb esterno). e qui forse avrei dovuto specificare la giusta partizione (non so) perchè dice che potrei anche scriver hd e allora avevo provato anche con (hd 1,0) ma dovrebbe essere la stessa cosa.

Penso quindi di averlo messo sul disco giusto ma al riavvio ecco l'errore 17.

Oggi ho fatto un'altra prova (usando l'opzione 'installgui' per vedere se in modo grafico poteva semplificarmi un po' le cose.) ma ... come prima;

(((devo però dire che come installer ha tantissime opzioni... incredibile... mai visto niente di simile!!!)))
quindi penso sia possibile fare molto; di certo sbaglio qualcosa, ma non capisco dove)

ho provato anche a modificare in bios boot device priority, ma questo non riesce ad ingannare l'installer in qunto poi vede i dischi sempre nello stesso modo.

sempre tornando alla discussione di ubuntuforum, ho intuito che arrivato all' errore 17 , potrei "aggiustarlo" in qualche modo ....

Ma forse sto pretendendo di partire con soluzioni un po' troppo sofisticate;

Mi spiace, ho anche un po' paura di 'scocciarVi';

comunque sono un po' "zuccone", e farò un po' di tentativi;

quanto meno adesso riesco a lasciare in pace win (non vorrei ritrovarmi a telefonare per farlo riattivare anche se originale)!!!

mi scuso se scrivo tanto e magari di render poco chiara la discussione (spero di non violare la netiquette)
comunque vi ringrazio molto perchè vi prestate ad aiutarmi.

buona cotinuazione.

Ritratto di bricke
bricke
(Guru)
Offline
Guru
Iscritto: 17/08/2005
Messaggi: 650

Ma riesce a fare il boot da usb il tuo pc?
Nel bios c'è questa opzione?

Questo è Unix. Ti dà abbastanza corda per impiccarti da solo. --Miquel van Smoorenburg

Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

Quote:

bricke ha scritto:
Ma riesce a fare il boot da usb il tuo pc?
Nel bios c'è questa opzione?

si, ho una asus p5k;

in bios posso configurare il boot priority device,
ma anche scegliere quale disco diventa di boot;

oppure, all'avvio premendo F8 (Boot Selection popup), mi compare la lista delle periferiche avviabili (tutti i dischi, i cd-rom ed eventuali altri dispositivi usb come per esempio una usb key).

edit: potevo pensarci forse prima....
prendo un live cd e vedo se riesco a descrivere come ho partizionato il disco (penso che Gparted) mi potrà aiutare.

se non lo trovo lo scarico ex-novo....

farò sapere qualcosa;

grazie.

Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

noooo....
cioè ... Siiiii !!!!
non ci credo, forse ci sono riuscito......

ho messo il grub su /dev/sdc

all'avvio ecco l'errore 17;
allora ho cambiato cone e (edit) di grub il valore da (1,0) a (0,0).... eh già, deve vederlo come fosse il primo disco Big Grin

quindi si è avviato....

adesso però dovrò vedere come rendere definitiva questa impostazione per non doverla sempre reinserire all'avvio.

e poi dovrò capire come mettere i drivers LAN.

sono davvero contento
grazie!!!!

Ritratto di ciro64
ciro64
(Junior)
Offline
Junior
Iscritto: 20/08/2008
Messaggi: 14

ri salve a Tutti;
dopo aver capito di e come modificare grub.conf per ottenere l'avvio corretto, mi resta il problema della LAN:
il driver l'ho scaricato da Asus; però ci sono informazioni su come 'pacchettizzare' come '.rpm', riferndosi a RedHat packages;

per altre distribuzioni Linux, il consiglio è quello di riferirsi a..... (in questo caso, ancora Voi)

Qui però, davvero non so come fare;
Se qualcuno ha una motherboard simile alla mia (asus P5k con LAN Atlansic L1 Gigabit Ethternet) magari mi sa consigliare;

Nel caso fosse un 'tentativo' magari complesso, sarei anche contento di sapere se c'è una versione di Debian che supporta già questo tipo di hardware;

del resto, senza poter usare l'Adsl, sarei un po' "tagliato fuori" (beh, ho un vecchio modem esterno pstn che funziona... però ci impiegherei un' eternità per aggiornare il sistema:-)

se c'è un'idea Vi ringrazi davvero tantisssimo..

ciro64