Come aggiornare MATE?

20 risposte [Ultimo contenuto]
Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Tanto per aggiornarvi:
sto procedendo con installazione Mate 1.8 su nuovo pc di un amico. La cosa è divenuta un thriller: da nessun repo si riesce ad nstallare Mate!!!
Possibile che o stesso Karapetsas ancora parli dei vecchi repo e keyring? E come è possibile che i pacchetti nuovi esistano in Debian se non esiste un repo specifico dal quale scaricare? Ora mi trovo con Lightdm, ma senza desktop... roba da chiodi!!! Ne ho provati vari, compresi quelli che a me funzionano, ma nulla da fare. Questo accade se si vuoe la versione 1.8 perché per la vecchia sembra tutto sia regolare, infatti mi spinge verso quella...

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
scusa una cosa ma tu sei ancora su Wheezy immagino, perchè con Jessie e i repo di debian MATE si installa e aggiorna tranquillamente, mi pare versione 1.8.1 ... e a meno di problemi di questi giorni non ho notato nulla di strano, è anche vero che il PC dove ho MATE è una settimana che è spento.
Ora non so con Wheezy e i backports se sia tutto regolare, magari in questa situazione ci sono problemi ?
Quindi, ricapitolando, con Jessie non servono repository di terzi per avere MATE, e mi pare che la 1.8.1 sia proprio l'ultima quindi è aggiornata.

Ho provato a installare MATE su una VM partendo da Wheezy solo console, aggiunto repository backports e poi :

sudo apt-get update
sudo apt-get install mate-desktop-environment lightdm xorg

al termine riavvio e ho MATE alla versione 1.8.1 anche su Wheezy, quindi per quel poco che ne capisco e conosco di MATE mi pare che sia andato tutto liscio come l'olio senza il benchè minimo problema, il tutto senza dover abilitare altri repositoru se non i backports di debian.
Certo partendo da zero ho ben poche applicazioni ma non credo sia questo il problema, basterà poi installare ciò che serve come al solito.

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Sono su wheezy in quanto varie info dicono che Sid è ancora sperimentale e non osso permetteri di corere ogni volta che l'utente non sa come uscire dai problemi
Il punto è che ci sono i repo anche per wheey, però sono tutti sballati o non esiste più il link, pur comparendo in rete. Ho usato i iei, ma come detto non danno risutato, mentre quando installai su mio pc (stessa modalità) funzionarono alla grande. Ora non so più quali repo inserire per poter aggiornare a mate 1.8. Stranamente per lightdm tutto è andato bene al primo colpo...

Che repo hai usato? Di quelli provati continua a dirmi che non esistono... eppure li ho presi dal wiki e da siti debian.

(Scusate la mancanza di qualche lettera, ma ho la tastiera sporca...).

Ad esempio: http://guide.debianizzati.org/index.php/Il_repository_Backports)
Backports wheezy --> (visti su

# Backports
deb http://ftp.it.debian.org/debian/ wheezy-backports main
deb-src http://ftp.it.debian.org/debian/ wheezy-backports main
risposta della ricerca
Could not resolve ftp.it.debian.org

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
questo il mio sources.list, come vedi Debian nudo e crudo.

deb http://ftp.it.debian.org/debian/ wheezy main contrib non-free
deb-src http://ftp.it.debian.org/debian/ wheezy main contrib non-free
 
deb http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main contrib non-free
 
deb http://security.debian.org/ wheezy/updates main contrib non-free
deb-src http://security.debian.org/ wheezy/updates main contrib non-free
 
deb http://ftp.it.debian.org/debian/ wheezy-backports main contrib non-free

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

A me pinga ....

ping ftp.it.debian.org
 
PING debian.ftp.bofh.it (213.92.8.5) 56(84) bytes of data.
64 bytes from vlad-tepes.bofh.it (213.92.8.5): icmp_req=1 ttl=63 time=53.8 ms
64 bytes from vlad-tepes.bofh.it (213.92.8.5): icmp_req=2 ttl=63 time=54.3 ms
.
.
.

prova a togliere deb-src per i backports .... non credo che serva, ma provare .......

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Volendo scaricare Mate intero e in .deb sapete da dove sia possibile? Ho finito ora di installarlo usando i pacchetti .deb, ma ci sono troppe dipendenze mancanti.

I repo sono come quelli che ho anche io, però a te come mai mancano quelle dei backports, necessarie per avere Mate?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

fareyes ha scritto:

I repo sono come quelli che ho anche io, però a te come mai mancano quelle dei backports, necessarie per avere Mate?

Non capisco cosa intendi dire ? I backports di wheezy in debian sono indicati nel sources.list, non esistono altri backports per wheezy, ne tanto meno di specifici per Mate, non gestiti da Debian almeno per quanto ne sappia io.

Ma giusto per capire tu che repository usi per installare MATE ? e perchè non ti vanno bene quelli propri di debian standard ora che finalmente ci sono, da fine giugno più o meno ?

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Scusa, ma nella fretta non avevo visto l'utima riga che avevi messo. Perònon mi prende l'ftp. Ora devo uscire, ma riprendo appena torno e conto di rasae il pc e cominciare da zero. Poi vi farò sapere.
A più tardi e per ora grazie

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 425

Bene. Ho quasi finito con l'installazione di ogni programnma che potrà servire, però, c'è sempre qualcosina che non quandra. Logicamente ho riformattato tutto per evitare che saltassero fuori problemi in seguito. Ora Debian ha la sua MATE 1.8, ma purtroppo non ci sono suoni e sto cercando di capire perché, visto che ALSA è installato (non uso Pulse); manca anche il pannello Utenti e gruppi che solitamente è in Sistema --> Amministrazione.
Devo dire grazie a Badroot che ha postato il suo sources.list perché mi ha salvato.

Durante l'installazione ho notato che il DVD (solo lettore) non si apriva premendo il pulsante e ogni volta dovevo usare una graffetta; appena dopo installato Lightdm si è messo a funzionare correttamente. Possibile che ci sia un bug? Ho controllato il checksum delle 2 iso e sono a posto; idem per il lettore perché ha sempre funzionato ed inoltre è nuovo.
Tanto per provarlo sto scrivendo dal pc appena preparato e funziona bene.

Penso che in Debian dovrebbero inserire MATE come alternativa a Gnome, da scegliere quando si seleziona "installazione desktop" perché per un utente alle prime armi può essere deludente dover fare i giri che ho fatto io oggi...

Ritratto di gennargiu
gennargiu
(Guru)
Offline
Guru
Iscritto: 23/11/2011
Messaggi: 622

il lettore di dvd/cd se non si apre manualmente usi il terminale e scrivi eject e si apre,ciao

gennaro

HP ELite 8200 i3 quad core 3,1 Ghz 16 Giga Ram - Hd 2 terabyte - Debian Buster RC1-64 bit desktop mate-xfce-Lxde-lxqt-E22