Audio, da root funziona!alsa

7 risposte [Ultimo contenuto]
Ritratto di marcopresti
marcopresti
(Junior)
Offline
Junior
Iscritto: 14/03/2006
Messaggi: 11

prima di postare ho cercato bene sia con il cerca del portale, sia con google...la mia etch fa le bizze con l'audio, la cosa strana è questa: il mio user marcuz, dopo vari smadonnamenti ero riuscito a fargli andare l'audio, ho cancellato l'utente, e l'ho rimesso con adduser, ed ora l'audio non va. Gnome non mi fa aprire il mixer ( gstreamer ), però da root funziona. gstreamer-properties da user normale non funziona ( mi da un errore ), alsamixer idem mi dice
alsamixer: function snd_ctl_open failed for default: No such device
naturalmente con root tutto questo funziona alla grande...che fare?

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 424

Sei sicuro che ti tuo utente appartenga al gruppo 'audio'?

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di marcopresti
marcopresti
(Junior)
Offline
Junior
Iscritto: 14/03/2006
Messaggi: 11

e come faccio a vederlo? io ho messo uso dei dispositivi audio tramite il tool grafico di gnome. come faccio a vedere se è realmente così la cosa?

P.S.: grazie per la risposta

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 424

Quote:

marcopresti ha scritto:
e come faccio a vederlo? io ho messo uso dei dispositivi audio tramite il tool grafico di gnome. come faccio a vedere se è realmente così la cosa?

Lo strumento di solito funziona...
Dopo essere entrato da console, il comando e`:

groups

Quote:

P.S.: grazie per la risposta

Figurati!!!
Puoi provare anche da root il comando

alsaconfig

Buona fortuna! Smile

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di marcopresti
marcopresti
(Junior)
Offline
Junior
Iscritto: 14/03/2006
Messaggi: 11

con groups ottengo che sono nel group marcuz ( ?? ) con alsaconf io configuro correttamente la mia scheda audio, infatti da root funziona, mi sa che è proprio un problema di permessi, mi sapresti indicare come fare ad aggiungere il mio user marcuz al group audio?

Ritratto di marcopresti
marcopresti
(Junior)
Offline
Junior
Iscritto: 14/03/2006
Messaggi: 11

se faccio adduser marcuz audio
lui mi dice "L'utente «marcuz» fa già parte del gruppo «audio»."

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 424

Quote:

marcopresti ha scritto:
con groups ottengo che sono nel group marcuz ( ?? ) con alsaconf io configuro correttamente la mia scheda audio, infatti da root funziona, mi sa che è proprio un problema di permessi, mi sapresti indicare come fare ad aggiungere il mio user marcuz al group audio?

Se l'unico gruppo che ti esce e` quello del tuo utente, allora hai trovato il problema.
Per aggiungere l'utente al gruppo, da root:

man useradd Wink

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di marcopresti
marcopresti
(Junior)
Offline
Junior
Iscritto: 14/03/2006
Messaggi: 11

oki thanks per la dritta ho risolto con
useradd -m -G users,audio,wheel marcuz
grazie ancora!