Aggiornamento da Debian 6.0.4 a 7.6

5 risposte [Ultimo contenuto]
Ritratto di Oktober
Oktober
(Junior)
Offline
Junior
Iscritto: 10/09/2014
Messaggi: 8

Buongiorno ragazzi,
volevo aggiornare la mia distro solo che ho un po' di problemi coi pacchetti e relativi orfani o file danneggiati ed in conflitto.

Vi posto magari il mio file source.list:

 # See sources.list(5) for more information, especially
     # Remember that you can only use http, ftp or file URIs
     # CDROMs are managed through the apt-cdrom tool.
     deb http://http.us.debian.org/debian stable main contrib non-free
     deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
     deb http://security.debian.org stable/updates main contrib non-free
 
     # Uncomment if you want the apt-get source function to work
     #deb-src http://http.us.debian.org/debian stable main contrib non-free
     #deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
 
deb http://archive.debian.org/debian oldstable main non-free
 
deb http://ftp.debian.org/debian/ squeeze-updates main non-free
 
deb http://security.debian.org/ squeeze/updates main non-free

e gli errori che ottengo quando cerco di aggiornare il sistema:

I seguenti pacchetti parzialmente installati saranno configurati:
  google-chrome-stable{b} 
I seguenti pacchetti sono RACCOMANDATI ma NON verranno installati:
  aptitude-doc-cs aptitude-doc-en aptitude-doc-es aptitude-doc-fi 
  aptitude-doc-fr aptitude-doc-it aptitude-doc-ja gnupg-curl libatm1 
  libparse-debianchangelog-perl uuid-runtime 
1052 pacchetti aggiornati, 642 installati, 0 da rimuovere e 0 non aggiornati.
È necessario prelevare 80,3 MB/1043 MB di archivi. Dopo l'estrazione, verranno occupati 948 MB.
impossibile trovare una soluzione per queste dipendenze. È possibile risolverle manualmente o inserire «n» per uscire.
I seguenti pacchetti hanno dipendenze non soddisfatte:
  gnome-keyring: Rompe: seahorse-plugins (< 3.0) ma 2.30.1-3 è installato.
  libmetacity-private0a: Rompe: libmetacity-private0 ma 1:2.30.1-3 è installato.
  libsdl1.2debian: Va in conflitto: libsdl1.2debian-alsa ma 1.2.14-6.1 è installato.
  libpolkit-gobject-1-0: Rompe: libpolkit-gtk-1-0 (< 0.99) ma 0.96-3 è installato.
  gir1.2-json-1.0: Va in conflitto: gir1.0-json-glib-1.0 ma 0.10.2-2squeeze1 è installato.
  libepc-1.0-2: Dipende: libepc-common (= 0.3.11-1) ma 0.4.4-1 sta per essere installato.
  gcc-4.7-base: Rompe: gcj-4.4-base (< 4.4.6-9~) ma 4.4.5-2 è installato.
  libbrasero-media0: Dipende: brasero-common (< 2.31) ma 3.4.1-4 sta per essere installato.
  openoffice.org-gcj: Dipende: openoffice.org-java-common (= 1:3.2.1-11+squeeze8) ma 1:3.4.0~ooo340m1-7 sta per essere installato.
  gir1.2-gstreamer-0.10: Va in conflitto: gir1.0-gstreamer-0.10 ma 0.10.30-1 è installato.
  gir1.2-clutter-1.0: Va in conflitto: gir1.0-clutter-1.0 ma 1.2.12-3 è installato.
  librpm1: Dipende: rpm-common (= 4.8.1-6+squeeze1) ma 4.10.0-5+deb7u1 sta per essere installato.
  perl-base: Va in conflitto: defoma (< 0.11.12) ma 0.11.11 è installato.
  libgtkhtml-editor0: Dipende: libgtkhtml3.14-19 (< 3.31) ma 3.32.2-2.1 sta per essere installato.
  gir1.2-atk-1.0: Va in conflitto: gir1.0-atk-1.0 che è un pacchetto virtuale.
  gnome-font-viewer: Rompe: capplets-data (< 1:3.0.0) ma 1:2.30.1-2 è installato.
  xserver-xorg-video-nv: Dipende: xorg-video-abi-6.0 che è un pacchetto virtuale.
  libgd2-noxpm: Va in conflitto: libgd2 che è un pacchetto virtuale.
                Va in conflitto: libgd2-xpm ma 2.0.36~rc1~dfsg-6.1 sta per essere installato.
  xserver-xorg-core: Rompe: xserver-xorg-video-6 che è un pacchetto virtuale.
  totem-coherence: Dipende: totem-common (< 2.31) ma 3.0.1-8 sta per essere installato.
  libmtp-common: Rompe: libmtp8 (<= 1.0.6-6) ma 1.0.3-1+squeeze2 è installato.
  gir1.2-freedesktop: Va in conflitto: gir1.0-freedesktop ma 0.6.14-1+b1 è installato.
  gnome-about: Dipende: gnome-desktop-data (= 2.30.2-2) ma 2.32.1-2 sta per essere installato.
  remmina-common: Rompe: remmina-plugin-data ma 0.8.3-2 è installato.
  libept1: Dipende: libapt-pkg4.10 che è un pacchetto virtuale.
  gir1.2-glib-2.0: Va in conflitto: gir1.0-glib-2.0 ma 0.6.14-1+b1 è installato.
  libdrm-nouveau1a: Va in conflitto: libdrm-nouveau1 ma 2.4.21-1~squeeze3 è installato.
  gir1.2-pango-1.0: Va in conflitto: gir1.0-pango-1.0 che è un pacchetto virtuale.
  libgdict-common: Rompe: gnome-utils-common (< 3.3) ma 2.30.0-2 è installato.
  gcc-4.4-base: Rompe: gcj-4.4-base (< 4.4.6-9~) ma 4.4.5-2 è installato.
  python-gnomeapplet: Dipende: python (< 2.7) ma 2.7.3-4+deb7u1 sta per essere installato.
  libnautilus-extension1a: Va in conflitto: libnautilus-extension1 ma 2.30.1-2squeeze2 è installato.
  evolution-data-server: Rompe: libebook1.2-9 (< 2.32) ma 2.30.3-2+squeeze1 è installato.
                         Rompe: libecal1.2-7 (< 2.32) ma 2.30.3-2+squeeze1 è installato.
  libgd2-xpm: Va in conflitto: libgd2 che è un pacchetto virtuale.
              Va in conflitto: libgd2-noxpm ma 2.0.36~rc1~dfsg-6.1 sta per essere installato.
  perl-modules: Va in conflitto: defoma (< 0.11.12) ma 0.11.11 è installato.
  ure: Rompe: openoffice.org-core (< 1:3.3~) ma 1:3.2.1-11+squeeze8 è installato.
  gstreamer0.10-nice: Rompe: libgstfarsight0.10-0 (< 0.0.23) ma 0.0.20-2 è installato.
  libatk-adaptor: Va in conflitto: at-spi ma 1.32.0-2 sta per essere installato.
  libperl5.10: Dipende: perl-base (= 5.10.1-17squeeze6) ma 5.14.2-21+deb7u1 sta per essere installato.
  rpcbind: Va in conflitto: portmap ma 6.0.0-2 è installato.
  libdb4.7-java: Va in conflitto: libdb-java ma 5.1.6 sta per essere installato.
  alsa-base: Rompe: linux-sound-base ma 1.0.23+dfsg-2 è installato.
  gir1.2-cogl-1.0: Va in conflitto: gir1.0-clutter-1.0 ma 1.2.12-3 è installato.
  console-setup-linux: Rompe: console-terminus ma 4.30-2 è installato.
  gnome-control-center-data: Va in conflitto: capplets-data ma 1:2.30.1-2 è installato.
  google-chrome-stable: Dipende: libappindicator1 but it is not going to be installed.
                        Dipende: libcurl3 but it is not going to be installed.
  gnome-panel: Rompe: libpanel-applet2-0 ma 2.30.2-2 è installato.
  deskbar-applet: Dipende: python (< 2.7) ma 2.7.3-4+deb7u1 sta per essere installato.
  libfarstream-0.1-0: Va in conflitto: libgstfarsight0.10-0 ma 0.0.20-2 è installato.
  ntfs-3g: Va in conflitto: libntfs-3g75 ma 1:2010.3.6-1 è installato.
  remmina: Rompe: remmina-plugin-data (<= 0.9) ma 0.8.3-2 è installato.
  libmetacity-private0: Dipende: metacity-common (< 1:2.31) ma 1:2.34.3-4 sta per essere installato.
Risolvere manualmente queste dipendenze? [N/+/-/_/:/?] n
Uscita.

Grazie

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 424

Ciao.
Aggiornare da una versione all'altra non e` un'operazione da poco...
Prova a commentre le righe con squeeze e oldstable perche` quella e` la vecchia stable che vuoi aggiornare.
Non e` detto che tutto fili liscio al primo colpo, comunque!
Ti consiglio una lettura delle Note di rilascio di wheezy per la tua architettura, in particolare il capitolo 4. Wink
HTH

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di Oktober
Oktober
(Junior)
Offline
Junior
Iscritto: 10/09/2014
Messaggi: 8

Molte grazie Franz, faccio subito una prova.

Altrimenti scarico direttamente la nuova versione e reinstallo da zero, che forse è la cosa migliore.

Ritratto di Oktober
Oktober
(Junior)
Offline
Junior
Iscritto: 10/09/2014
Messaggi: 8

Ok risolto reinstallando la nuova versione.

Essendo alla mia prima installazione di debian, volevo chiedere se la configurazione di source.list dei repo è così corretta o va rieditata:

# 
 
# deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official i386 NETINST Binary-1 20140712-13:01]/ wheezy main
 
#deb cdrom:[Debian GNU/Linux 7.6.0 _Wheezy_ - Official i386 NETINST Binary-1 20140712-13:01]/ wheezy main
 
deb http://ftp.it.debian.org/debian/ wheezy main
deb-src http://ftp.it.debian.org/debian/ wheezy main
 
deb http://security.debian.org/ wheezy/updates main
deb-src http://security.debian.org/ wheezy/updates main
 
# wheezy-updates, previously known as 'volatile'
deb http://ftp.it.debian.org/debian/ wheezy-updates main
deb-src http://ftp.it.debian.org/debian/ wheezy-updates main

Grazie

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 16/05/2011
Messaggi: 129

A meno che tu non abbia bisogno dei pacchetti sorgenti, le righe che cominciano con deb-src ti conviene commentarle.

ciao,
mandian

Ritratto di Oktober
Oktober
(Junior)
Offline
Junior
Iscritto: 10/09/2014
Messaggi: 8

mandian ha scritto:

A meno che tu non abbia bisogno dei pacchetti sorgenti, le righe che cominciano con deb-src ti conviene commentarle.

ciao,
mandian

Grazie per la dritta.

Buona serata,
Oktober.