Aggiornamenti dai backports??

4 risposte [Ultimo contenuto]
Ritratto di Black Bart
Black Bart
(Monster)
Offline
Monster
Iscritto: 18/10/2011
Messaggi: 308

Salve a tutti,ho una cosetta che non riesco a capire...allora,ho aggiornato libreoffice su jessie attraverso i backports,cosa che ho fatto altre volte con wheezy,però mi sono accorto che mi dava dei pacchetti non aggiornati:

0 aggiornati, 0 installati, 0 da rimuovere e 4 non aggiornati.

Questo succede dando il comando:

apt-get -t jessie-backports install "pacchetto"

Mentre non succede se il comando è:

apt-get install "pacchetto"

Non avevo mai fatto caso a questa cosa,è normale?

I pacchetti sono comunque da aggiornare con il comando:

apt-get -t jessie-backports upgrade (oppure dist-upgrade)

Grazie dell'aiuto.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non ho capito qual è il problema. Cosa ti aspetti che invece non ottieni?

Ritratto di Black Bart
Black Bart
(Monster)
Offline
Monster
Iscritto: 18/10/2011
Messaggi: 308

In effetti rileggendo non ho capito bene nemmeno io...

In ogni caso,mi sono reso conto che inserendo i backports in jessie,quando scarico un qualsiasi pacchetto dai backports,apt mi avvisa che ci sono dei pacchetti da aggiornare e non capisco il perchè.

Quando installo un pacchetto con:

apt-get -t jessie-backports install "pacchetto"

alla fine della procedura di installazione mi ritrovo con:

0 aggiornati, 4 installati, 0 da rimuovere e 2 non aggiornati.

La voce 2 non aggiornati,non si presenta se installo un qualsiasi pacchetto con:

apt-get install "pacchetto"

Volevo solo capire se quei 2 pacchetti come non aggiornati,che si presentano solo installando dai backports,sia meglio lasciarli stare oppure sia meglio aggiornarli.

Grazie

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Evidentemente ci sono due pacchetti installati dai backports di cui esiste una versione più recente. Ma i pacchetti backports non sono mai aggiornati automaticamente, quindi apt-get si limita a segnalarti la cosa senza procedere. Se vuoi aggiornarli devi indicarli esplicitamente.

Ritratto di Black Bart
Black Bart
(Monster)
Offline
Monster
Iscritto: 18/10/2011
Messaggi: 308

Capito...grazie!