Volume su scheda audio 5.1 non funziona correttamente

Nessuna risposta
Ritratto di emanuele_989
emanuele_989
(Junior)
Offline
Junior
Iscritto: 20/11/2013
Messaggi: 7

Salve,
Premetto che ho dato un'occhiata in giro ma non ho trovato nulla di efficace per risolvere il seguente problema.
Ho installato sul pc fisso una scheda audio 5.1 con chiptest C-Media (vedere sotto per i dettagli). La scheda è stata subito riconosciuta da Debian, ho risolto per quanto riguarda il non funzionamento del subwoofer ma c'è ancora un problema: il controllo volume Master e PCM non ha effetto su tutti i canali. Il Master controlla solo le frontali sx-dx, il PCM frontali e posteriori sx-dx; subwoofer e diffusore centrale non si controllano in nessun modo.
Seguendo alcune guide ho provato a fare delle modifiche al file daemon.conf ma senza risultati.

Questa è la scheda audio da lspci:

01:0a.0 Multimedia audio controller: C-Media Electronics Inc CMI8738/CMI8768 PCI Audio (rev 10)

daemon.conf con le modifiche apportate:

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.
 
## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.
 
; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no
 
; high-priority = yes
; nice-level = -11
 
; realtime-scheduling = yes
; realtime-priority = 5
 
; exit-idle-time = 20
; scache-idle-time = 20
 
; dl-search-path = (depends on architecture)
 
; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa
 
; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0
 
; resample-method = speex-float-3
; enable-remixing = yes
enable-lfe-remixing = yes
 
; flat-volumes = yes
 
; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000
 
default-sample-format = s16le
default-sample-rate = 44100
; alternate-sample-rate = 48000
default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe
 
; default-fragments = 4
; default-fragment-size-msec = 25
 
; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0

Ringrazio in anticipo per l'auito Smile