Problemi Con Scheda Audio

18 risposte [Ultimo contenuto]
Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Salve a tutti,prima di postare quì ho navigato per ora su google per cercare la soluzione.Il mio problema è che ho cancellato in /tmp la cartella .esd con tutto il suo contenuto.
Ora non mi funziona + l'audio!L'altoparlante che stà vicino all'orologio se provo ad alzare il volume lo riabbassa automaticamente.Ho provato a fare apt-get remove esound e poi install esound.Ho scaricato alsa-driver ho fatto alsaconf alsamixer alsactl store restore insomma le ho provate tutto.Riavvio...ma niente.Poi se vado su controllo volume mi dà questo errore:
Sorry, no mixer elements and/or devices found
Come posso risolvere?Premetto che sono con gnome in debian!
Grazie!
Sad

Ritratto di franz
franz
(Collaboratore)
Offline
Collaboratore
Iscritto: 21/12/2005
Messaggi: 423

Ciao.
E` capitato anche a me, e se non ricordo male, l'ho risolto installando gstreamer, ma non ricordo esattamente quali pacchetti... l'unica cosa che ti posso consigliare e` quindi di 'provare' a installare qualcuno dei pacchetti gstreamer finche` non funziona.
A me rimane il problema che il sistema parte ma con il suono disabilitato; devo *sempre* utilizzare l'applet del volume per riabilitarlo... Sad

There are only 10 types of people in the world: those who understand binary and those who don't.

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Ciao,grazie per la risposta...ma io penso sia un problema legato al fatto che ho cancellato .esd in /tmp infatti ora non me lo ricrea +.
Cmq ora provo!Grazie mille!
Se c'è qualcuno che ha altre cose da potermi suggerire prego di farlo.....Sono disperato!Ho provato ad andare in tutte le comunity in irc ma nessuno ha saputo aiutarmi!

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 944

Non sono esperto dell'applicazione in questione, ma perchè non provare a riconfigurare il tutto, con un dpkg-reconfigure?
Se proprio non va, prima rimuovi tutti i pacchetti in maniera drastica e poi li re-installi con:
apt-get remove --purge pacchetti_esd<br />apt-get install pacchetti_esd
eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Ciao grazie già l'ho fatto...ora però ho provato a fare una cosa...lanciare il comando H3yB0y:/tmp# esd
fà un sacco di suoni strani per circa 4 secondi poi però si blocca e non dà segni di vita!

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Bene bene ragazzi forse e dico forse funziona....dico forse perchè ancora devo riavviare...però ho lanciato il comando esd e mi ha ricreato la dir /tmp/.esd/socket
Ora Riavvio e poi vi dico!

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Cari ragazzi ho riavviato e.....Non funziona!!!!!
Ma xkè?vi prego aiutatemi...mi manca tantissimo la mia bella musica!

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

Scusate Se posto tutte queste volte...ma ho scoperto un altra cosa se faccio
H3yB0y:/tmp# esd

rimane lampeggiante xò se avvio la musica senza chiuderlo funziona...sento le mie canzoni...Per caso non c'è un comando per farlo rimanere avviato anche se chiudo?premetto che ho fatto esd --help e non ho trovato nulla di interessante!

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 944

Come già detto, non sono ferrati in ambito demoni canterini, ma per fare quello di cui tu hai bisogno, probabilmente c'è una coppia di scrippete da piazzare/attivare/imprecare nella cartella /etc/init.d, sotto il nome di S55esd e K99esd ((numeri fittizio).

Probabilmente con la reinstallazione sono andati a farsi benedire. Prova a riaggiornare per l'appunto la situazione degli script, con# update-rc.d

eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-

Ritratto di H3yB0y
H3yB0y
(Junior)
Offline
Junior
Iscritto: 24/03/2006
Messaggi: 11

update-rc.d: /etc/init.d/esd: file does not exist
mi dice ciò....ho provato con tutti i comandi dell'help
Nada....

Ritratto di ntropia
ntropia
(Collaboratore)
Offline
Collaboratore
Iscritto: 18/09/2004
Messaggi: 944

il dpkg-reconfigure credo avrebbe dovuto rigenerarti il file esd (che pare sia scomparso).
A questo punto ti è sfuggito qualche pacchetto dalla riconfigurazione.

Taglia la testa al toro, re-installa con apt-get usando<br />apt-get install  --reinstall pacchetti_esd
eNjoy

Chi ha intendimento conti il numero della Bestia, perché è un numero d'uomo; e il suo numero è... rw-rw-rw-