Problema riconoscimento monitor con Debian testing 6

18 risposte [Ultimo contenuto]
Ritratto di magsas
magsas
(Junior)
Offline
Junior
Iscritto: 08/05/2009
Messaggi: 9

Salve community,
sono nuovo del forum perché ho appena installato Debian ed ho subito avuto un problemino. Subito dopo l'avvio mi compare lo schermo nero con la scritta frequenza non supportata.
Il monitor è un Acer al1715 sm.

Mi aiutate a risolvere questo inconveniente?

Se può essere utile, già due-tre anni fa avevo Debian installato su questo pc e il monitor funzionava. Una cosa simile mi è capitata con Ubuntu: le vecchie versioni funzionavano, mentre con le nuove si vedono le cose in formato gigante.
Grazie a tutti. Ciao

Ritratto di kiko23
kiko23
(Junior)
Offline
Junior
Iscritto: 23/12/2008
Messaggi: 9

La mia ragazza ha anche lei un acer 17 pollici, non ricordo esattamente il modello.

Da qualche versione di Ubuntu, prima non accadeva, dal grub al gdm appare la scritta "frequenza non supportata". Quindi quando carica il kernel, comunque poi funziona tutto correttamente, non ho capito se questo è anche il tuo caso, oppure se te non arrivi al gdm.
Comunque nel mio caso ho risolto mettendo vga=791,non so magari te dovrai mettere un altro numero, nelle impostazioni di caricamento del kernel in /boot/grub/menu.lst ed ora è ok.

Ritratto di magsas
magsas
(Junior)
Offline
Junior
Iscritto: 08/05/2009
Messaggi: 9

Ciao kiko23 grazie per la risposta.
Ho provato ad inserire vga=791 che mi ha portato a modificare solo la grandezza delle scritte di avvio (adesso si vedono meglio), ma il risultato non cambia.
Comunque io non arrivo nemmeno al gdm, si blocca subito dopo qualche scritta di avvio.

Aggiungo che durante l'avvio mi compare due volte questa scritta: "Starting NFS common utilities:statd failed".

Grazie. Ciao.

Ritratto di luxtux
luxtux
(Geek)
Offline
Geek
Iscritto: 30/04/2009
Messaggi: 57

Avvia in modalita' single user (la seconda delle opzioni che ti vengono proposte all'avvio) e, una volta loggato come root, dai il comando
dpkg-reconfigure xserver-xorg
e segui le istruzioni, poi, da user,
su <nomeutente>
dai
startx
e vedi se funziona, altrimenti prova a postare l'output di
cat /etc/X11/xorg.conf

ciao

L.

| (o> |
| //\ | Debian 5.0.1 [Lenny]
| V_/_| Registered Linux user #158396

Ritratto di magsas
magsas
(Junior)
Offline
Junior
Iscritto: 08/05/2009
Messaggi: 9

Premettendo che non sono consapevole al 100% di quello che ho fatto, dopo il comando startx la situazione è rimasta comunque la stessa.

Il file xorg.conf è questo:
Section &quot;InputDevice&quot;<br />Identifier &quot;Generic Keyboard&quot;<br />Driver &quot;kbd&quot;<br />Option &quot;XkbRules&quot; &quot;xorg&quot;<br />Option &quot;XbkModel&quot; &quot;pc105&quot;<br />Option &quot;XkbLayout&quot; &quot;it&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br />Identifier &quot;Configured Mouse&quot;<br />Driver &quot;mouse&quot;<br />EndSection<br /><br />Section &quot;Device&quot;<br />Identifier &quot;Configured Video Device&quot;<br />Driver &quot;UseFBDev&quot; &quot;true&quot;<br />EndSection<br /><br />Section &quot;Monitor&quot;<br />Identifier &quot;Configured Monitor&quot;<br />EndSection<br /><br />Section &quot;Screen&quot;<br />Identifier &quot;Default Screen&quot;<br />Monitor &quot;Configured Monitor&quot;<br />EndSection<br />

Vorrei chiedere un'altra cosa. Visto che ho installato la versione base dell'so, cioè solo un cd perché il resto volevo scaricarlo successivamente, non è che questo possa essere la fonte dei problemi?

Ciao e grazie dell'aiuto.

Ritratto di sette70
sette70
(Geek)
Offline
Geek
Iscritto: 14/01/2005
Messaggi: 116

Ciao,la cosa strana che si vede net tuo "xorg.conf" è che viene usato il framebuffer come driver.Che scheda video hai ?

Ritratto di gio14
gio14
(Geek)
Offline
Geek
Iscritto: 05/03/2009
Messaggi: 56

Potresti usare il CD di una vecchia versione di Ubuntu che avevi installato, la usi in modo live e se funziona correttamente ti salvi xorg.conf e poi lo usi per sostituire quello di Debian (il tuo xorg di Debian che hai postato oltre che usare il framebuffer mi sembra che manchi parecchia roba, ad esempio frequenze, risoluzione e altro)

Ritratto di magsas
magsas
(Junior)
Offline
Junior
Iscritto: 08/05/2009
Messaggi: 9

Quote:

Che scheda video hai ?

Ho una nVidia, ma ora non ricordo il modello.

Quote:

gio14 ha scritto:
Potresti usare il CD di una vecchia versione di Ubuntu che avevi installato, la usi in modo live e se funziona correttamente ti salvi xorg.conf e poi lo usi per sostituire quello di Debian (il tuo xorg di Debian che hai postato oltre che usare il framebuffer mi sembra che manchi parecchia roba, ad esempio frequenze, risoluzione e altro)

Un cd live che mi funziona è Ubuntu 7.10. Avevo provato a fare la stessa operazione copiandolo nella 9.04, ma non era servito a niente. Posso riprovarci, ma ci credo poco che si metta a posto.

Ritratto di luxtux
luxtux
(Geek)
Offline
Geek
Iscritto: 30/04/2009
Messaggi: 57

Quote:

magsas ha scritto:
Ho una nVidia, ma ora non ricordo il modello.

Per saperlo:
lspci | grep VGA
Posta qui l'output e vediamo che si puo' fare (anch'io ho una nVidia). Inoltre dai un po' di informazioni anche sul monitor.

Ciao

L.

| (o> |
| //\ | Debian 5.0.1 [Lenny]
| V_/_| Registered Linux user #158396

Ritratto di magsas
magsas
(Junior)
Offline
Junior
Iscritto: 08/05/2009
Messaggi: 9

Quel comando restituisce questo:
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6100 nForce 405 (rev a2)

Per le info sul monitor sono riuscito a trovare solo questo che c'è scritto dietro:
power ac 100-240v 50-60 Hz 1.35A
Inoltre ha una risoluzione 1280x1024.

Grazie per l'aiuto. Ciao.

Ritratto di gio14
gio14
(Geek)
Offline
Geek
Iscritto: 05/03/2009
Messaggi: 56

Prova ha rinominare il tuo /etc/X11/xorg.conf e sostituirlo con questo e vedi se funziona(se il monitor è un lcd la frequenza dovrebbe andare bene o al limite la modifichi) poi l'ideale è installare il driver nvidia al posto di vesa

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/type1"
FontPath "/usr/share/fonts/type1/gsfonts"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/truetype/freefont"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/truetype/latex-ttf-fonts"
FontPath "/usr/share/fonts/truetype/ttf-dejavu"
FontPath "/usr/share/fonts/truetype/ttf-xfree86-nonfree"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
# Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
# Option "NoLogo" "True"
Identifier "Scheda video generica"
Driver "vesa"
# BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor Generico"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Scheda video generica"
Monitor "Monitor Generico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection