Problema: la CPU è spesso al massimo!

6 risposte [Ultimo contenuto]
Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Salve a tutti,
come da titolo la mia CPU sembra che vada sempre al massimo anche con poco utilizzo e la cosa mi preoccupa visto che il portatile è nuovo. Sul laptop ho installato Debian Strech e come DE utilizzo xfce 4.12.Qui di seguito le caratteristiche del processore:

root@dhcppc1davenz:/home/davenz# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 76
Model name:            Intel(R) Celeron(R) CPU  N3060  @ 1.60GHz
Stepping:              4
CPU MHz:               479.980
CPU max MHz:           2480,0000
CPU min MHz:           480,0000
BogoMIPS:              3200.00
Virtualization:        VT-x
L1d cache:             24K
L1i cache:             32K
L2 cache:              1024K
NUMA node0 CPU(s):     0,1
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes rdrand lahf_lm 3dnowprefetch epb kaiser tpr_shadow vnmi flexpriority ept vpid tsc_adjust smep erms dtherm ida arat

E' possibile fare un test per valutare se la cpu sta lavorando in maniera anomala?

Ritratto di compact
compact
(Geek)
Offline
Geek
Iscritto: 11/12/2004
Messaggi: 160

Prova ad installare questo pacchetto

apt-get install htop

poi lancia il comando

htop

e riesci ad ottenere un elenco dei processi che stanno consumando le tue risorse (ram, cpu, ecc)

vedi:

https://en.wikipedia.org/wiki/Htop
https://www.lffl.org/2012/11/htop-come-monitorare-i-processi-ed-le.html

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

Buongiorno compact, htop è molto simile a "top" che ho già nel SO.
Ho fatto diverse prove ieri e ho visto che applicazioni del tipo office le apro e le uso senza problemi di consumi eccessivi, ma tutto cambia quando apro anche solo una finestra web; entrambi i core vanno subito oltre 90% e ovviamente partono le ventole. Se poi chiudo tutto e lascio anche solo la finestra (1) web aperta il consumo rimane alto, e se poi muovo il mouse o uso anche la tastiera, allora schizza di nuovo oltre 100%.

Ritratto di compact
compact
(Geek)
Offline
Geek
Iscritto: 11/12/2004
Messaggi: 160

Quale browser web ?
"quando apro anche solo una finestra web"

se hai firefox prova delle sue alternative e vedi se migliora.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

In tutti i computer che ho installo sempre almeno 2 browser web, e ti posso dire che anche con Chromium non cambia nulla, il problema non è in quel software.

Ritratto di David73
David73
(Monster)
Offline
Monster
Iscritto: 21/03/2014
Messaggi: 220

In questo momento sto usando il vecchio laptop che è sempre a 64 bit e le differenze ci sono, nel senso che pur essendo anche questo un computer con basse prestazioni, posso avere anche molte finestre aperte contemporaneamente di diverse applicazioni e regge tutto; se poi apro "anche" firefox ho inizialmente un picco vicino al 100%, ma dopo 2 o 3 secondi immediatamente si riduce il consumo di cpu e si stabilizza al di sotto del 50% (più o meno). E anche se cambio SO (ne ho 2 anche in questo vecchio), la situazione cambia di poco, aumenta di poco il consumo totale di cpu ma è ugualmente ben gestito dalla macchina.
Invece con il nuovo portatile che si tratti di Debian o Lubuntu, e che io usi firefox o Chromium non cambia nulla, la cpu è sempre a palla!! Nail Biting

Ritratto di compact
compact
(Geek)
Offline
Geek
Iscritto: 11/12/2004
Messaggi: 160

prova a disabilitare tutti i componenti aggiuntivi del browser web se cambia qualcosa ...

https://support.mozilla.org/it/kb/Utilizzo%20eccessivo%20della%20CPU

prova ad eseguire questo comando (sposta solo i profili di firefox e di adobe in altra directory):

mv .mozilla .backup-mozilla
mv .adobe .backup-adobe

rilancia il browser web firefox

se il consumo di ram è basso hai trovato il colpevole

per farti capire attualmente la mia cpu è utilizzata solo al 10% con firefox
ma se abilito il flash-plugin può arrivare anche lei al 100% dipende da cosa stai
visualizzando all'interno del browser web.

per tornare alla con tutte le impostazioni precedenti:

rm -fr .mozilla
rm .adobe
mv .backup-mozilla .mozilla
mv  .backup-adobe .adobe

La mia differenza rispetto alla tua è che ho un 4 core quindi non ne risento in maniera esagerata.