Problema audio con Debian Sid

1 risposta [Ultimo contenuto]
Ritratto di Bytec0d3
Bytec0d3
(Newbie)
Offline
Newbie
Iscritto: 30/08/2008
Messaggi: 2

Ciao a tutti, sto avendo problemi a configurare l'audio del mio HTPC: se attacco le cuffie e provo a far partire un mp3 sento solo rumore, invece con l'HDMI non si sente proprio nulla Sad

Ecco un po di info.

Motherboard: ASUS AT5IONT-I

lspci | grep Audio
 
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
03:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

SO: Debian Sid

uname -a
 
Linux alpha 2.6.38-2-amd64 #1 SMP Thu Apr 7 04:28:07 UTC 2011 x86_64 GNU/Linux

ALSA:

aplay -l
 
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887 Analog [ALC887 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887 Digital [ALC887 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

come consigliato in un forum ho provato ad aggiungere la seguente stringa al file /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel probe_mask=0xffff,0xfff2

e, inoltre, creato il file ~/.asoundrc:

pcm.!default {
    type plug
    slave.pcm {
        type hw
        card 0
        device 1
    }
}

ma il problema persiste Sad

io e ALSA non andiamo molto d'accordo Big Grin Qualche consiglio?

Grazie in anticipo

Ritratto di fareyes
fareyes
(Monster)
Online
Monster
Iscritto: 14/03/2011
Messaggi: 405

Ci sono 2 files nascosti: uno è .asoundrc e l'altro .pulse. Se non usi Pulseaudio esegui backup di entrambi e fai reboot del pc. (Backup: su --> mv nomefile nomefileback)

Se poi devi impostare i suoni di login e logout vedi i files in /home/utente

libcanberra-login-sound.desktop
libcanberra-logout-sound.desktop

li puoi aprire solo da root e con comando a mano (es. su --> nano libcanberra-login-sound.desktop), poi li modifichi a seconda di cosa hai.
Io ho impostato così

[Desktop Entry]
Type=Application
Name=GNOME Login Sound
Comment=Plays a sound whenever you log in
Exec=/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login" -f /usr/share/sounds/login.wav
OnlyShowIn=GNOME;
AutostartCondition=GNOME /desktop/gnome/sound/event_sounds
X-GNOME-Autostart-Phase=Application
X-GNOME-Provides=login-sound

Stessa cosa puoi fare per il logout sostituendo logout a login...logicamente ricordati di cambiare i valori (da Login a Logout e da Autostart a Shutdown)