Permessi HD

12 risposte [Ultimo contenuto]
Ritratto di namless
namless
(Junior)
Offline
Junior
Iscritto: 11/04/2014
Messaggi: 35

Ciao a tutti,

ho un problema con l'utilizzo di un HD che credo che sia legato ai permessi.
Utilizzo Debian Wheezy con Gnome e sul PC ho montato 3 HD, tutti sata. A Parte quello dove sono installati i SO (Debian, Win e Ubuntu), ho un HD con file system NTFS ed uno EXT4.
Quello con file system NTFS riesco ad utilizzarlo ma mi richiede sempre i permessi di root.
Invece quello EXT4 mi chiede sempre i permessi di root per montarlo, ma poi non mi fa creare cartelle, copiare file ed altro. Il disco l'ho appena formattato ed è quindi vuoto, a parte la cartella lost+found.
Il proprietario risulta essere root e credo che sia per questo che non riesco ad utilizzarlo. Qui l'output del comando ls -l:

totale 16
drwx------ 2 root root 16384 lug 29 08:02 lost+found

La procedura esatta per poter utilizzare il disco quale sarebbe? Cambiare il proprietario mettendo l'utente e poi assegnandoli tutti i permessi del caso?
Devo in qualche modo modificare anche il file fstab?
Grazie in anticipo per le risposte.

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

In attesa di qualcuno più esperto di me, ho provato a seguire il tuo ragionamento:
direi che, per trovarteli montati entrambi dovrai agire in fstab e
successivamente con i comandi chown e chmod settare i giusti permessi per gli utenti desiderati e farli accedere in scrittura e/o lettura.
Sempre se non sbaglio, nell'esempio che hai riportato

totale 16
drwx------ 2 root root 16384 lug 29 08:02 lost+found

il proprietario ed il gruppo è root. Quindi in quel caso, se stai tentando di copiare o scrivere come utente pippo è giusto che non te lo faccia fare.

Io partirei da qui:

http://wiki.ubuntu-it.org/Hardware/DispositiviPartizioni/MontarePartizioni
https://wiki.debian.org/NTFS
https://wiki.debian.org/it/fstab

Un saluto, Andrea

Ritratto di namless
namless
(Junior)
Offline
Junior
Iscritto: 11/04/2014
Messaggi: 35

Ciao andr3a,
grazie per la risposta.
Con il file fstab mi ci sono già "scornato", devo aver sbagliato qualcosa con la sintassi così ho ripristinato tutto come era. Però lo vedrò successivamente perchè adesso il problema è riuscire a scrivere su questo disco, non è un problema se lo devo montare manualmente.
Se non ho capito male attraverso il file fstab posso fare in modo che il disco venga montato automaticamente, decidere dove deve essere montato ed tante altre opzioni, ma non mi risolverebbe il problema dell'accesso in scrittura da utente. Quindi credo che prima si debbano cambiare il proprietario e successivamente i permessi. Poi, una volta fatto questo, posso intervenire sul file fstab e far montare il disco in automatico.
Sbaglio qualcosa?

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

Citazione:

ma non mi risolverebbe il problema dell'accesso in scrittura da utente. Quindi credo che prima si debbano cambiare il proprietario e successivamente i permessi.


ho trovato questo
http://maurizio.mavida.com/2005/10/15/chmod-chown-permessi-e-proprietari-sotto-linux/

dove se non ho capito male sarebbe

chwown -R utente:gruppo /directory-dove-viene-montata-la-partizione

Non posso testarlo qui dove sono, però...vediamo se qualcuno ci conferma. Smile

Ritratto di namless
namless
(Junior)
Offline
Junior
Iscritto: 11/04/2014
Messaggi: 35

Giusto. La sintassi l'avevo trovata e mi corrisponde a quella che hai messo tu. Quindi: in primis chown per cambiare proprietario e poi chmod per cambiare i permessi.
Vediamo se qualcuno conferma Smile
Avrei anche due domandine, sicuramente stupide, ma delle quali non ne sono sicuro:
1) questi due comandi (chown e chmod) si applicano a file e directory. Ma è possibile applicarli all'intero disco? E' vero che il disco viene montato e visto come una directory, ma è possibile farlo in questo modo?
2) visto che il disco è vuoto (a parte lost+found che ovviamente non tocco), una volta modificati proprietari e permessi i file che andrò a scrivere dentro erediteranno gli stessi permessi? Inoltre lost+found, da quello che ho letto in giro, dovrebbe rimanere proprietario ed accessibile solo a root, vero? Quindi se cambio proprietari e permessi al disco, devo assicurarmi che quelli di lost+found rimangano a root. Sbaglio?

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

Citazione:

1) questi due comandi (chown e chmod) si applicano a file e directory. Ma è possibile applicarli all'intero disco?

il -R dovrebbe cambiare i permessi/proprietario a tutto quello che è sotto alla directory alla quale hai assegnato/cambiato i permessi/proprietario.

Oddio quanto l'ho scritta contorta.

Ritratto di namless
namless
(Junior)
Offline
Junior
Iscritto: 11/04/2014
Messaggi: 35

Si, -R se non mi sbaglio dovrebbe essere che applica in modo ricorsivo, quindi anche a tutte le sotto-directory.
Ma se non ci sono sotto-directory bisogna farlo comunque?
Scusate la niubbaggine... Worried

Ritratto di putbraininside
putbraininside
(Junior)
Offline
Junior
Iscritto: 05/12/2013
Messaggi: 21

ciao nameless puoi postare il tuo /etc/fstab per poterci dare una sbirciatina? Smile

function(a,b,c,d){d+=c;return[d<0|a&b<

Ritratto di namless
namless
(Junior)
Offline
Junior
Iscritto: 11/04/2014
Messaggi: 35

Ciao,

certamente. Eccolo qui:

stefano@debian:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc7 during installation
UUID=dea02a04-f109-448e-90fa-4e82b4c9ac94 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc5 during installation
UUID=6f4022fc-ae96-4a21-b809-3b06d0dc2430 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
stefano@debian:~$ 

Se ti serve vedere la situazione dei dischi, eccola:

root@debian:/home/stefano# fdisk -l
 
Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00035c4c
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   976768064   488384001    7  HPFS/NTFS/exFAT
 
Disk /dev/sdb: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000294c1
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   625141759   312569856   83  Linux
 
Disk /dev/sdc: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x40c81ba8
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        2048   102561791    51279872    7  HPFS/NTFS/exFAT
/dev/sdc2       305238016   312578047     3670016   12  Compaq diagnostics
/dev/sdc3       102563838   305238015   101337089    5  Extended
/dev/sdc5       301066240   305238015     2085888   82  Linux swap / Solaris
/dev/sdc6       102563840   200220089    48828125   83  Linux
/dev/sdc7       200220672   301058047    50418688   83  Linux
 
Partition table entries are not in disk order
root@debian:/home/stefano# 

Idee? Worried

Ritratto di andr3a
andr3a
(Geek)
Offline
Geek
Iscritto: 31/07/2014
Messaggi: 97

mi sono imbattuto in queso
http://forum.debianizzati.org/viewtopic.php?t=46016

Sembra affrontare tutte le tematiche del caso, non so se lo avevi già letto.

Ritratto di putbraininside
putbraininside
(Junior)
Offline
Junior
Iscritto: 05/12/2013
Messaggi: 21

prova ancora coi permessi, ma questa volta mettendo solo le opzioni o+w a chmod ed applicandole al punto di mount...
invece per il disco ntfs prova a mettere le opzioni
rw,users,umask=000 ad fstab

Al momento e' l'unica cosa che mi viene in mente Raised Eyebrow

function(a,b,c,d){d+=c;return[d<0|a&b<