Installazione Lexmark MX 310 dn

3 risposte [Ultimo contenuto]
Ritratto di IlGiaco
IlGiaco
(Newbie)
Offline
Newbie
Iscritto: 07/08/2013
Messaggi: 2

Salve a tutti ragazzi, questo è il mio primo post su questo forum e spero di aver azzeccato la sezione Smile

Sul pc di un mio amico hanno installato Debian 6 (32 bit) un po' di tempo fa. Qualche settimana fa ha acquistato la suddetta stampante, certificata anche per Linux, e mi ha chiesto di assisterlo durante l'installazione. Una volta configurata per connettersi nella LAN ho installato i driver del sito Lexmark, l'ho configurata sul pc (rileva stampante di rete -> avanti -> avanti -> avanti...), e ho lanciato una stampa di prova. Tutto ok.

Tuttavia quando provo a stampare delle immagini ne stampa un pezzetto e poi stampa un errore del tipo Rangecheck error.
Avendo a portata di mano il mio pc con installato Ubuntu 12.04 (64 bit) ho provato ad installare la stampante seguendo la stessa procedura e... magia! Ha stampato senza problemi le stesse immagini!

Cercando un po' su internet mi pare di capire che il problema sia relativo a ghostscript (ma potrei anche sbagliarmi), ed in effetti Ubuntu e Debian hanno due versioni diverse del medesimo pacchetto (9.05 vs 8.71).

Il mio amico mi ha già chiesto di piallargli tutto ed installargli Ubuntu (o derivata), ma francamente mi sentirei più sicuro lasciandogli su Debian e vorrei provare qualsiasi tentativo possibile prima del gesto estremo Smile

Secondo voi è possibile che aggiornando ghostscript il problema svanisca? Se si come posso scaricare una versione più avanzata senza fare l'avanzamento a Debian 7? Avete in mente altre idee per tentare di risolvere il problema?

Grazie mille per l'aiuto

P.S. Purtroppo è passata qualche settimana da quando ho avuto questo problema e non ricordo esattamente tutti i dettagli. Inoltre non ho sotto mano il pc del mio amico, ma se aveve bisogno di qualche info chiedete pure Wink

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Le installazioni ibride sono sempre problematiche. Puoi provare, ma non è sicuro che funzioni, ad aggiungere al file /etc/apt/sources.list una riga con la stable (anche detta wheezy), poi:

# aptitude update
# aptitude install ghostscript/stable

Dovrebbe aggiornarti gs e le sue dipendenze alla versione stable senza toccare il resto. Certo potrebbero venir fuori conflitti, oppure la catena di dipendenze potrebbe essere talmente lunga da diventare un vero e proprio aggiornamento a Wheezy dell'intero sistema... In ogni caso aptitude ti chiede conferma prima di continuare.

Ritratto di IlGiaco
IlGiaco
(Newbie)
Offline
Newbie
Iscritto: 07/08/2013
Messaggi: 2

Grazie mille mcortese, farò un tentativo appena avrò il pc sotto mano Smile

Pensi che l'aggiornamento possa risolvere il problema o che possa essere dovuto da altro?

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non ne ho proprio idea. È difficile fare ipotesi su hardware che non si possiede... Wink