Installazione Driver ATI Radeon 7500

4 risposte [Ultimo contenuto]
Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1100

Salve,
sto cercando di installare i driver ati per vedere se riesco a migliorare in qualche modo alcune prestazioni del pc.
Ho cercato di seguire la seguenteguida tentando di installare i driver dai repository. Tuttavia, quando do il comando
<br /># apt-get install fglrx-control fglrx-driver fglrx-driver-dev fglrx-kernel-src<br />
mi esce il seguente output
<br />Lettura della lista dei pacchetti in corso... Fatto<br />Generazione dell&#039;albero delle dipendenze in corso<br />Lettura informazioni sullo stato... Fatto<br />Alcuni pacchetti non possono essere installati. Questo può voler<br />dire che è stata richiesta una situazione impossibile oppure, se<br />si sta usando la distribuzione &quot;unstable&quot;, che alcuni pacchetti<br />richiesti non sono ancora stati creati o rimossi da incoming.<br />Le seguenti informazioni possono aiutare a risolvere la situazione:<br /><br />I seguenti pacchetti hanno dipendenze non soddisfatte:<br />  fglrx-driver-dev: Dipende: fglrx-driver (= 8.28.8-4) ma 1:8-12-4 sta per essere installato<br />E: Pacchetto non integro

Ho provato anche a cercare i driver sul sito della ATI ma non ci sono i driver per linux. Che fare?
Grazie

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di BrotherSister
BrotherSister
(Junior)
Offline
Junior
Iscritto: 23/12/2008
Messaggi: 11

Ciao purtroppo per te, e anche per me, la tua scheda non è supportata dai driver proprietari fglrx
se vai nel Wiki trovi tutto al riguardo.
Perciò ti toccherà disinstallare tutto ciò che hai installato che riguarda fglrx
e poi installare questi:
 apt-get install libgl1-mesa-dri libgl1-mesa-glx mesa-utils xserver-xorg-video-ati
poi editare il file xorg.conf
gedit /etc/X11/xorg.conf
nella sezione "Device" inserire questi dati al posto di quelli esistenti:
Section &quot;Device&quot;<br />        Identifier      &quot;ATI Technologies Inc Radeon RV200 QW [Radeon 7500]&quot; # questa è la mia scheda<br />  Driver          &quot;ati&quot;<br />   BusID           &quot;PCI:1:0:0&quot;<br />EndSection<br />
aggiungi se non le hai queste 2 sezioni in fondo al file:
Section &quot;DRI&quot;<br />   Mode    0666<br />EndSection<br /><br />Section &quot;Extensions&quot;<br />        Option &quot;Composite&quot; &quot;Enable&quot;<br />EndSection<br />
Poi nella sezione "ServerLayout" purtroppo devi aggiungere:
<br />        Option          &quot;AIGLX&quot;         &quot;false&quot;<br />
e questo disabilita gli effetti AIGLX
Se vuoi puoi provare con:
<br />        Option          &quot;AIGLX&quot;         &quot;true&quot;<br />
ma la CPU, almeno a me, si impalla troppo.
Altro problema con la CPU lo provoca il modulo radeonfb:
gedit /etc/modules
aggiungi il modulo radeonfb se non lo hai già caricato fai una prova e se ti crea problemi con la CPU lo commenti con un #.
Ci sono alcune Option da provare nella section device per migliorare le prestazioni, le puoi vedere nel man.radeon
da terminale dai:
man radeon
Ciao
Io ho una radeon 7500
e questo è il mio file xorg.conf
<br /># xorg.conf (X.Org X Window System server configuration file)<br />#<br /># This file was generated by dexconf, the Debian X Configuration tool, using<br /># values from the debconf database.<br />#<br /># Edit this file with caution, and see the xorg.conf manual page.<br /># (Type &quot;man xorg.conf&quot; at the shell prompt.)<br />#<br /># This file is automatically updated on xserver-xorg package upgrades *only*<br /># if it has not been modified since the last upgrade of the xserver-xorg<br /># package.<br />#<br /># If you have edited this file but would like it to be automatically updated<br /># again, run the following command:<br />#   sudo dpkg-reconfigure -phigh xserver-xorg<br /><br />Section &quot;Files&quot;<br /> FontPath        &quot;/usr/share/fonts/X11/misc&quot;<br />     FontPath        &quot;/usr/X11R6/lib/X11/fonts/misc&quot;<br /> FontPath        &quot;/usr/share/fonts/X11/100dpi/:unscaled&quot;<br /> FontPath        &quot;/usr/X11R6/lib/X11/fonts/100dpi/:unscaled&quot;<br />     FontPath        &quot;/usr/share/fonts/X11/75dpi/:unscaled&quot;<br />  FontPath        &quot;/usr/X11R6/lib/X11/fonts/75dpi/:unscaled&quot;<br />      FontPath        &quot;/usr/share/fonts/X11/Type1&quot;<br />    FontPath        &quot;/usr/X11R6/lib/X11/fonts/Type1&quot;<br />        FontPath        &quot;/usr/share/fonts/X11/100dpi&quot;<br />   FontPath        &quot;/usr/X11R6/lib/X11/fonts/100dpi&quot;<br />       FontPath        &quot;/usr/share/fonts/X11/75dpi&quot;<br />    FontPath        &quot;/usr/X11R6/lib/X11/fonts/75dpi&quot;<br />        # path to defoma fonts<br />    FontPath        &quot;/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType&quot;<br />EndSection<br /><br />Section &quot;Module&quot;<br />        Load    &quot;i2c&quot;<br />   Load    &quot;bitmap&quot;<br />        Load    &quot;ddc&quot;<br />   Load    &quot;dri&quot;<br />   Load    &quot;extmod&quot;<br />        Load    &quot;freetype&quot;<br />      Load    &quot;glx&quot;<br />   Load    &quot;int10&quot;<br /> Load    &quot;vbe&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br />        Identifier      &quot;Generic Keyboard&quot;<br />      Driver          &quot;kbd&quot;<br />   Option          &quot;CoreKeyboard&quot;<br />  Option          &quot;XkbRules&quot;    &quot;xorg&quot;<br />  Option          &quot;XkbModel&quot;    &quot;pc105&quot;<br /> Option          &quot;XkbLayout&quot;   &quot;it&quot;<br />EndSection<br /><br />Section &quot;InputDevice&quot;<br /> Identifier      &quot;Configured Mouse&quot;<br />      Driver          &quot;mouse&quot;<br /> Option          &quot;CorePointer&quot;<br />   Option          &quot;Device&quot;              &quot;/dev/input/mice&quot;<br />       Option          &quot;Protocol&quot;            &quot;ImPS/2&quot;<br />        Option          &quot;Emulate3Buttons&quot;     &quot;true&quot;<br />EndSection<br /><br />Section &quot;Device&quot;<br />    Identifier      &quot;ATI Technologies Inc Radeon RV200 QW [Radeon 7500]&quot;<br />    Driver          &quot;ati&quot;<br />   BusID           &quot;PCI:1:0:0&quot;<br />EndSection<br /><br />Section &quot;Monitor&quot;<br />      Identifier      &quot;SyncMaster&quot;<br />    Option          &quot;DPMS&quot;<br />EndSection<br /><br />Section &quot;Screen&quot;<br />    Identifier      &quot;Default Screen&quot;<br />        Device          &quot;ATI Technologies Inc Radeon RV200 QW [Radeon 7500]&quot;<br />    Monitor         &quot;SyncMaster&quot;<br />    DefaultDepth    24<br />        SubSection &quot;Display&quot;<br />            Depth           1<br />         Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth           4<br />         Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth           8<br />         Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth           15<br />                Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth           16<br />                Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />     SubSection &quot;Display&quot;<br />            Depth           24<br />                Modes           &quot;1024x768&quot; &quot;832x624&quot; &quot;800x600&quot; &quot;720x400&quot; &quot;640x480&quot;<br />      EndSubSection<br />EndSection<br /><br />Section &quot;ServerLayout&quot;<br />        Option          &quot;AIGLX&quot;         &quot;false&quot;<br />        Identifier      &quot;Default Layout&quot;<br />        Screen          &quot;Default Screen&quot;<br />        InputDevice     &quot;Generic Keyboard&quot;<br />      InputDevice     &quot;Configured Mouse&quot;<br />EndSection<br /><br />Section &quot;DRI&quot;<br />   Mode    0666<br />EndSection<br /><br />Section &quot;Extensions&quot;<br />        Option &quot;Composite&quot; &quot;Enable&quot;<br />EndSection<br />

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1100

Ok, cercherò di attuare i cambi quanto prima e ti farò sapere. Grazie

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1100

Scusa, mi è venuto un dubbio.
Quando nella sezione device scrivi questo:
<br />Identifier        &quot;ATI Technologies Inc Radeon RV200 QW [Radeon 7500]&quot; # questa è la mia scheda<br />

Intendi dire che quello è l'identificativo della tua scheda audio che sarebbe diverso dalla mia? Ed io, come faccio ad sapere qual è l'identificatore della mia scheda?

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di BrotherSister
BrotherSister
(Junior)
Offline
Junior
Iscritto: 23/12/2008
Messaggi: 11

Intendo dire che quello è l'identificativo della mia scheda VIDEO.
Comunque la sezione Identifier è ininfluente, puoi lasciarla così oppure se vuoi sapere con precisione qual'è la tua dai da terminale:
lspci | grep VGA
Ciao