Il mio hardware è compatibile?

6 risposte [Ultimo contenuto]
Ritratto di 8brusco8
8brusco8
(Geek)
Offline
Geek
Iscritto: 30/05/2014
Messaggi: 69

ciao a tutti. Ho da poco comprato un pc fisso con tali caratteristiche:

processore: Intel BX80646 i5 4440
scheda video: Asus GeForce GTX 660
scheda madre: Gigabyte GA-H87-HD3

la mia architettura dovrebbe essere Haswell ma nel sito debian non l'ho trovata nei download delle iso, quindi ho scaricato una iso per liveCD per pc da 64 bit da qui https://www.debian.org/distrib/. Ho sbagliato? dovevo cercare una iso per Multiarch?

comunque sia la sessione Live, sia dopo l'installazione, gnome 3 non parte e sotto applications (è in inglese sto provando a risolvere chiedendo al forum Sad ) si svilupano dei menu a tendina decisamente spartani.

perchè non funziona gnome3 ? avrò lo stesso problema di malfunzionamento se dovessi provare a mettere la CairoDock e relativi effetti?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Ciao,
per quanto riguarda la ISO se hai scaricato quella per PC a 64 bit ( nel nome file c'è amd64 ) allora è quella giusta.
Probabilmente per sfruttare la scheda video devi installare i driver proprietari di NVIDIA, leggi il wiki per procedere all'installazione.

Ritratto di 8brusco8
8brusco8
(Geek)
Offline
Geek
Iscritto: 30/05/2014
Messaggi: 69

grazie! ora provo, ma prima due delucidazioni, 1) se nelle guide non è indicato nulla, i comandi vanno inseriti in terminale di root o in quello semplice? 2) il dollaro sta solo ad indicare l'inizio della riga di comando?

edit: sono fermo al primo passaggio dell'installazione ahahah:

Aggiungere le componenti "contrib" e "non-free" a /etc/apt/sources.list, per esempio:

# Debian 7 "Wheezy"
deb http://http.debian.net/debian/ wheezy main contrib non-free

come devo materialmente scriverlo nel terminale senza dare l'input quando cerco di andare a capo con Invio? Smile sono niubbo

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

Normalmente se l'esempio di come imputare un comando inizia con $ questo sta a indicare che sei in un terminale come utente normale, se invece inizia con # allora il terminale è quello di root.
Per esempio se ti viene indicato un comando come :

# /sbin/ifconfig eth0 down

il comando da digitare è /sbin/ifconfig eth0 down e il cancelletto indica che sei come root.
Ma se hai configurato sudo puoi digitare semplicemente :

sudo /sbin/ifconfig eth0 down

dal terminale con il tuo utente e ti verrà richiesta la tua password per eseguire il comando che segue sudo con i privilegi di root.
In ogni caso se un comando necessità dei privilegi di root e viene eseguito come utente normale ti darà errore di permessi o ti avvisa che devi essere root, quindi è ben difficile sbagliarsi.

Ritratto di 8brusco8
8brusco8
(Geek)
Offline
Geek
Iscritto: 30/05/2014
Messaggi: 69

ecco, grazie della precisazione! molto chiaro.
però ora ti devo stressare anche su un'altro aspetto basilare: nella guida dice

Aggiungere le componenti "contrib" e "non-free" a /etc/apt/sources.list, per esempio:

# Debian 7 "Wheezy"
deb http://http.debian.net/debian/ wheezy main contrib non-free

come devo materialmente scriverlo nel terminale senza dare l'input quando cerco di andare a capo con Invio? Smile sono niubbo

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2068

No devi editare il file /etc/apt/sources.list e aggiungere / modificare la riga come indicato nella guida.
Quindi da terminale, come root o con sudo, devi usare un editor di testi.
Visto che sei, come dici tu, niubbo non ti consiglio certo vi, che è l'editor per antonomasia in UNIX ( scherzo è che è l'unico che so usare ).
Prova a vedere se digitando :

# gedit /etc/apt/sources.list

parte l'editor di testo grafico di Gnome, che avendo menù e fronzoli vari forse ti è più comodo da usare.

Ritratto di 8brusco8
8brusco8
(Geek)
Offline
Geek
Iscritto: 30/05/2014
Messaggi: 69

mm non sono molto sicuro di cosa scrivere e dove:

dove scrivo esattamente?

EDIT: credo di aver risolto ho scritto paro paro giusto sotto e i comandi seguenti su terminale pare stiano andando

EDIT2: perfetto, gnome3 funziona perfettamente dopo la procedura Smile segno come risolto. grazie mille!