driver alsa di rme essendo occupato da un'altra applicazione non fa partire jack

Nessuna risposta
Ritratto di croppolo
croppolo
(Newbie)
Offline
Newbie
Iscritto: 11/04/2011
Messaggi: 1

Salve a tutti

sto cercando di usare ardour ma jack non ne vuole sapere di partire sembra che il suo driver sia impegnato da un'altra applicazione che non lo rilascia, ma questa è solo una mia interpretazione, qualcuno può darmi qualche consiglio su come risolvere ?

allego di seguito l'ouptut di jack:

------------------------------------------------------------------------
17:12:07.252 Patchbay deactivated.
17:12:07.292 Statistics reset.
Cannot connect to server socket err = File o directory non esistente
Cannot connect to server socket
jack server is not running or cannot be started
17:12:07.333 ALSA connection graph change.
17:12:07.544 ALSA connection change.
17:12:07.546 ALSA connection graph change.
17:12:37.936 Startup script...
17:12:37.936 artsshell -q terminate
Cannot connect to server socket err = File o directory non esistente
Cannot connect to server socket
jack server is not running or cannot be started
sh: artsshell: not found
17:12:38.341 Startup script terminated with exit status=32512.
17:12:38.341 JACK is starting...
17:12:38.342 /usr/bin/jackd -v -m -dalsa -dhw:0 -r44100 -p2048 -n2 -H -M
17:12:38.384 JACK was started with PID=1951.
no message buffer overruns
no message buffer overruns
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
Jack: Create non RT thread
Jack: ThreadHandler: start
Jack: JackSocketServerChannel::Open
Jack: Bind: addr.sun_path /dev/shm/jack_default_1000_0
Jack: JackSocketServerChannel::BuildPoolTable size = 1
Jack: JackEngine::Open
Jack: Connect: addr.sun_path /dev/shm/jack_default_1000_0
Jack: playback device hw:0
Jack: capture device hw:0
Jack: apparent rate = 44100
Jack: frames per period = 2048
Jack: JackDriver::Open capture_driver_name = hw:0
Jack: JackDriver::Open playback_driver_name = hw:0
Jack: JackEngine::ClientInternalOpen: name = system
Jack: JackEngine::AllocateRefNum ref = 0
Jack: JackPosixSemaphore::Allocate name = jack_sem.1000_default_system val = 0
Jack: JackEngine::NotifyAddClient: name = system
Jack: JackGraphManager::SetBufferSize size = 2048
Jack: JackConnectionManager::DirectConnect first: ref1 = 0 ref2 = 0
Jack: JackGraphManager::ConnectRefNum cur_index = 0 ref1 = 0 ref2 = 0
Jack: JackDriver::SetupDriverSync driver sem in flush mode
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|2048|2|44100|0|0|hwmon|hwmeter|-|32bit
Using ALSA driver Digi32 running on card 0 - RME Digi32 PRO (Rev. 150) at 0xfd000000, irq 18
the capture device "hw:0" is already in use. Please stop the application using it and run JACK again
Jack: JackDriver::Close
Jack: JackConnectionManager::DirectDisconnect last: ref1 = 0 ref2 = 0
Jack: JackGraphManager::DisconnectRefNum cur_index = 0 ref1 = 0 ref2 = 0
Jack: JackEngine::ClientCloseAux ref = 0
Jack: JackGraphManager::RemoveAllPorts ref = 0
Jack: JackPosixSemaphore::Destroy
Jack: ~JackDriver
Cannot initialize driver
Jack: JackEngine::Close
Jack: JackClientSocket::Close
Jack: JackServerSocket::Close /dev/shm/jack_default_1000_0
Jack: no message buffer overruns
Jack: JackPosixThread::Stop
Jack: ThreadHandler: exit
JackServer::Open() failed with -1
Jack: Succeeded in unlocking 82208666 byte memory area
Jack: JackShmMem::delete size = 0 index = 0
Jack: ~JackDriver
Jack: JackEngine::~JackEngine
Jack: Succeeded in unlocking 994 byte memory area
Jack: JackShmMem::delete size = 0 index = 1
Jack: cleaning up shared memory
Jack: cleaning up files
Jack: unregistering server `default'
Failed to start server
17:12:38.936 JACK was stopped with exit status=255.
17:12:38.937 Post-shutdown script...
17:12:38.937 killall jackd
jackd: nessun processo trovato
17:12:39.365 Post-shutdown script terminated with exit status=256.
17:12:40.452 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = File o directory non esistente
Cannot connect to server socket
jack server is not running or cannot be started
17:12:47.343 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = File o directory non esistente
Cannot connect to server socket
jack server is not running or cannot be started
17:12:57.721 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = File o directory non esistente
Cannot connect to server socket
jack server is not running or cannot be started

------------------------------------------------

... dimenticavo ...

la scheda funziona perchè ho provato ad ascoltare un mp3 da disco e dall'uscita cuffie della stessa e quello sopra è l'output di sopra è relativo a hw:0

saluti e grazie

Paolo