cpufreq ...

7 risposte [Ultimo contenuto]
Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Ciao.

E' caldo. Maledettamente caldo.
Stò cercando di salvare il portatile che ha su una kubuntu breezy (magari fosse "breezy" anche la temperatura ...) .

Allora :

<br />marco@macho-note:~$ lsmod cpufreq<br />Usage: lsmod<br />marco@macho-note:~$ lsmod | grep cpu<br />cpufreq_userspace       4316  0<br />cpufreq_stats           5252  0<br />freq_table              4388  1 cpufreq_stats<br />cpufreq_powersave       1696  0<br />cpufreq_ondemand        6044  0<br />cpufreq_conservative     6948  0<br />

quindi il modulo del kernel è caricato.

ma se faccio

<br />marco@macho-note:~$ cpufreq-info<br />cpufrequtils 0.3: cpufreq-info (C) Dominik Brodowski 2004<br />Report errors and bugs to linux@brodo.de, please.<br />analyzing CPU 0:<br />  no or unknown cpufreq driver is active on this CPU<br />

mi dice che non ci sono driver attivi sulla cpu .

ora, come configuro cpufreq ?

ho provato la ricerca nel sito e ho provato a googlare ma non sono riuscito a trovare le keywords giuste.

Qualche hint ?

TIA

Marco

apt-get -a beer

Ritratto di Moreno
Moreno
(Geek)
Offline
Geek
Iscritto: 16/06/2005
Messaggi: 94

Ciao

He He vedo che la mia guidina stà mietendo vittime!!

Sei certo che il kernel che usi contenga la patch cpufreq ??

Che CPU hai ??

Hai verificato che sia nella lista delle CPU Compatibili ??

Ciao Ciao Moreno

Ebbene sì confesso sono un infiltrato di http://www.mandrakeitalia.org ma mi piace girare il Mondo.
Profilo

Ritratto di ferretti75
ferretti75
(Guru)
Offline
Guru
Iscritto: 08/07/2005
Messaggi: 526

Ciao Moreno !
Quote:

Moreno ha scritto:
Ciao

He He vedo che la mia guidina stà mietendo vittime!!

Big Grin
Quote:

Sei certo che il kernel che usi contenga la patch cpufreq ??

No; come faccio a controllare ??
Quote:

Che CPU hai ??

P IV :
<br />marco@macho-note:~$ cat /proc/cpuinfo<br />processor       : 0<br />vendor_id       : GenuineIntel<br />cpu family      : 15<br />model           : 2<br />model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz<br />stepping        : 7<br />cpu MHz         : 2391.296<br />cache size      : 512 KB<br />fdiv_bug        : no<br />hlt_bug         : no<br />f00f_bug        : no<br />coma_bug        : no<br />fpu             : yes<br />fpu_exception   : yes<br />cpuid level     : 2<br />wp              : yes<br />flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe<br />bogomips        : 4734.97<br />

TIA

Marco

apt-get -a beer

Ritratto di calimero
calimero
(Junior)
Offline
Junior
Iscritto: 17/08/2007
Messaggi: 36

riporto alla luce questo topic dai meandri del forum: ho caricato il modulo centrino-speedstep e i vari driver, ma usando il comando cpufreq-set non riesco a modificare il range di frequenze su cui fare lo scaling:

debianbox:/usr/bin# cpufreq-info
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Per favore, comunicare errori e malfunzionamenti a linux@brodo.de.
analisi della CPU 0:
modulo centrino
CPU per le quali e` necessario cambiare la frequenza contemporaneamente: 0
limiti hardware: 600 MHz - 1.30 GHz
frequenze disponibili: 1.30 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
gestori disponibili: powersave, ondemand, conservative, userspace, performance
gestore corrente: la frequenza deve mantenersi tra 600 MHz e 600 MHz.
Il gestore "ondemand" puo` decidere quale velocita` usare
in questo intervallo.
la frequenza attuale della CPU e` 600 MHz (ottenuta da una chiamata diretta all'hardware).

come si può vedere mi dice che la frequenza può variare tra 600 e 600MHz...e lo stesso succede se passo ad un qualsiasi altro gestore con cpufreq-set -g "gestore".....

Ritratto di calimero
calimero
(Junior)
Offline
Junior
Iscritto: 17/08/2007
Messaggi: 36

...aggiornamento: ho disabilitato il modulo speedstep-centrino e caricato l'acpi-cpufreq dal momento che durate il boot il sistema mi diceva qualcosa del tipo: speedstep è obsoleto sostituiscilo con acpi-cpufreq (non proprio così,,,ma credo che il significato fosse quello!)...la situazione haimè non è cambiata di una virgola...con cpufreq-info ho lo stesso risultato di prima Sad
ho inoltre scoperto un nuovo comando: "cpufreq -D" Laughing che a questo punto credo che abbia svelato i miei problemi:
apm_init : /proc/apm: No such file or directory
pmu_init : /proc/pmu/info: No such file or directory
nforce2_post_conf : Unconfigured, exiting.
plugins_post_conf : Unable to configure plugin nforce2_atxp1, removing
sensors_post_conf : no sensors.conf found, sensors disabled!
plugins_post_conf : Unable to configure plugin sensors_plugin, removing
write_cpufreqd_pid : the daemon is already running.
main : Unable to write pid file: /var/run/cpufreqd.pid

ora però non so proprio dove sbattere la testa! Sad

Ritratto di calimero
calimero
(Junior)
Offline
Junior
Iscritto: 17/08/2007
Messaggi: 36

mi rispondo da solo: Laughing
ho eliminato cpufreqd, mantenuto il modulo del kernel di prima,installato il pacchetto sysfsutils(non so se servisse realmente...ma in giro qualcuno ne parlava :-P ), riavviato e magicamente :

#cpufreq-info
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Per favore, comunicare errori e malfunzionamenti a linux@brodo.de.
analisi della CPU 0:
modulo acpi-cpufreq
CPU per le quali e` necessario cambiare la frequenza contemporaneamente: 0
limiti hardware: 600 MHz - 1.30 GHz
frequenze disponibili: 1.30 GHz, 1.20 GHz, 1000 MHz, 800 MHz, 600 MHz
gestori disponibili: powersave, ondemand, conservative, userspace, performance
gestore corrente: la frequenza deve mantenersi tra 600 MHz e 1.30 GHz.
Il gestore "ondemand" puo` decidere quale velocita` usare
in questo intervallo.
la frequenza attuale della CPU e` 600 MHz (ottenuta da una chiamata diretta all'hardware).

...qualcuno sa consigliarmi come fare a vedere se tutto funziona correttamente o è solo una mia illusione?
Big Grin

Ritratto di -kio-
-kio-
(Junior)
Offline
Junior
Iscritto: 23/12/2004
Messaggi: 14

Avete provato ad installare powernowd?

Su debian mi ha permesso di risolvere il problema dello scaling.

Ritratto di skyy86
skyy86
(Newbie)
Offline
Newbie
Iscritto: 09/04/2009
Messaggi: 2

grazie al vostro thread sn riuscito a far funzionare lo scaling anch'io...
FANTASTICI!
una piccola domanda però...Tongue
come posso fare per mettere la stessa frequenza a entrambi i processori.
cioè quando seleziono 800Mhz dalla gnome-applet m mette solo la cpu0 a 800 mentra la cpu1 rimane in ondemand,
si può fare che con un click imposto la stessa frequenza ad entrambe??
grazie ancora per avermi aiutato nella risoluzione..stavo impazzendo.
e grazie per l'attenzione!