Attivare Scheda WIFI

17 risposte [Ultimo contenuto]
Ritratto di Pythoning
Pythoning
(Newbie)
Offline
Newbie
Iscritto: 25/09/2011
Messaggi: 3

Ciao ho una Atheros AR 9285 ma non riesco a farla funzionare su un pc configurato senza grafica con Debian squeezy sopra, avete qualche suggerimento da darmi?

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Hai installato il pacchetto "firmware-atheros"? Vedi qui.

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di gala_00
gala_00
(Geek)
Offline
Geek
Iscritto: 14/06/2012
Messaggi: 70

Anche io ho lo stesso problema, se configuro da terminale riesco a fare tutto ma poi non riesco a connettermi se chiedo uno scan ho come risposta Network in down.
aggiungo che il led del pulsante di on-off del wifi è sempre su off , anche se viene digitato più volte, questo non si attiva.
La mia sensazione è che debian permetta la configurazione a livello software ma non rieche a dire all'hardware di attivarsi.
Cosa si può fare???

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1393

gala_00 ha scritto:

Cosa si può fare???


Verificare di aver seguito le istruzioni di installazione indicate in http://wiki.debian.org/ath9k

Quindi, verificare dai log di sistema cosa sta accadendo per applicare eventuali misure correttive.

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

gala_00 ha scritto:

Anche io ho lo stesso problema, se configuro da terminale riesco a fare tutto ma poi non riesco a connettermi se chiedo uno scan ho come risposta Network in down.

Potresti riportare esattamente che comandi dai e che output ricevi?

gala_00 ha scritto:

aggiungo che il led del pulsante di on-off del wifi è sempre su off , anche se viene digitato più volte, questo non si attiva.

Di solito i pulsanti che disattivano il wifi scollegano la scheda di rete dal bus PCI. Se davvero fosse off, la scheda non comparirebbe neanche tra l'hardware presente. Mi sembra più probabile che il LED non sia correttamente gestito (problema BIOS o ACPI).

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1100

Io ho la 9287 e questa mi causa ancora crash di sistema. Sono riuscito a stabilizzare molto il tutto utilizzando i driver di windows tramite il pacchetto NDISwrapper

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di gala_00
gala_00
(Geek)
Offline
Geek
Iscritto: 14/06/2012
Messaggi: 70

ciao a tutti, la mia scheda wifi continua ad non andare. Vi posto quello che mi dice:

# lspci

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)

# ifconfig
eth0 Link encap:Ethernet HWaddr 00:21:cc:40:02:64
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 Cool TX bytes:0 (0.0 Cool
Interrupt:27 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1008 (1008.0 Cool TX bytes:1008 (1008.0 Cool

(qui non la vede)

# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

pan0 no wireless extensions.

ppp0 no wireless extensions.

(qui la vede ma Tx-Power e' off )

# ifconfig wlan0 up
SIOCSIFFLAGS: Unknown error 132

(cosa che non capisco)
(e poi)

iwlist wlan0 scan
wlan0 Interface doesn't support scanning : Network is down

questo è il vero problema "Network is down" non c'è verso di tirarla su
chi mi sa aiutare???
ciao
_00

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1100

Claudio ha scritto:

Io ho la 9287 e questa mi causa ancora crash di sistema. Sono riuscito a stabilizzare molto il tutto utilizzando i driver di windows tramite il pacchetto NDISwrapper

Mi cito da solo

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Nei tuoi post, potresti usare i tag "code" (magari con lang=cmdline) per marcare le parti che riporti dalla shell? Così capiamo meglio quali sono output e quali i tuoi commenti. E magari non appaiono faccine spurie! Cool

Tornando al tuo problema, hai guardato se /var/log/dmesg contiene qualche segnalazione o messaggio "sospetto"? Il modulo ath9 è caricato (lsmod lo elenca)? Che versione del kernel hai (uname -a)? Potresti anche dare un "lspci -nn" in modo da vedere vendorId e productId della tua scheda?

Infine, visto che il problema potrebbe essere nello switch, vedi se "rfkill list" ti dà qualche indizio...

Ritratto di gala_00
gala_00
(Geek)
Offline
Geek
Iscritto: 14/06/2012
Messaggi: 70

Per il momento non sono riuscito a fare nulla di concreto. e sto perdendo le speranze.....

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1393

gala_00 ha scritto:

Per il momento non sono riuscito a fare nulla di concreto [..]


Infatti, è proprio questo il punto: non hai dato riscontro a (quasi) nessuno dei consigli che ti sono stati suggeriti.