Gestione Energetica HD (non montato ma in continua lettura!)

3 risposte [Ultimo contenuto]
Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 71

Ho riscontrato un'anomalia strana sulla gestione della sospensione di un mio HD.

Ho due HD:
/dev/sda (HDD): dati (molto raramente verrà montato da Linux)
/dev/sdb (SDD): Partizione Linux + /home + swap

Finché non apro Thunar, non gira e rimane regolarmente in "standby", ma appena apro thunar non si quieta più. Rimane lì a girare nonostante non viene montato. Oltre al rumore mi preoccupa la sua salute, essendoci un backup.

Note: facendo logout dal server grafico smette di girare.

Idee?

Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 71

Installando una copia "pulita" di Jessie ...pare che ogni problema sia stato risolto.
Peccato. Brutta esperienza col comando "dist-upgrade" da Wheezy a Jessie.

Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 71

Il problema è ritornato! ... non capisco davvero.

Qualcuno ha suggerimenti? Vi posto l'output di hdparm:

# hdparm -I /dev/sda

/dev/sda:
 
ATA device, with non-removable media
	Model Number:       STM3250318AS                            
	Serial Number:      9VMA3L9P
	Firmware Revision:  CC38    
	Transport:          Serial
Standards:
	Used: unknown (minor revision code 0x0029) 
	Supported: 8 7 6 5 
	Likely used: 8
Configuration:
	Logical		max	current
	cylinders	16383	16383
	heads		16	16
	sectors/track	63	63
	--
	CHS current addressable sectors:   16514064
	LBA    user addressable sectors:  268435455
	LBA48  user addressable sectors:  488397168
	Logical/Physical Sector size:           512 bytes
	device size with M = 1024*1024:      238475 MBytes
	device size with M = 1000*1000:      250059 MBytes (250 GB)
	cache/buffer size  = 8192 KBytes
	Nominal Media Rotation Rate: 7200
Capabilities:
	LBA, IORDY(can be disabled)
	Queue depth: 32
	Standby timer values: spec'd by Standard, no device specific minimum
	R/W multiple sector transfer: Max = 16	Current = 16
	Recommended acoustic management value: 254, current value: 0
	DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4 
	     Cycle time: no flow control=120ns  IORDY flow control=120ns
Commands/features:
	Enabled	Supported:
	   *	SMART feature set
	    	Security Mode feature set
	   *	Power Management feature set
	   *	Write cache
	   *	Look-ahead
	   *	Host Protected Area feature set
	   *	WRITE_BUFFER command
	   *	READ_BUFFER command
	   *	DOWNLOAD_MICROCODE
	    	SET_MAX security extension
	   *	Automatic Acoustic Management feature set
	   *	48-bit Address feature set
	   *	Device Configuration Overlay feature set
	   *	Mandatory FLUSH_CACHE
	   *	FLUSH_CACHE_EXT
	   *	SMART error logging
	   *	SMART self-test
	   *	General Purpose Logging feature set
	   *	WRITE_{DMA|MULTIPLE}_FUA_EXT
	   *	64-bit World wide name
	    	Write-Read-Verify feature set
	   *	WRITE_UNCORRECTABLE_EXT command
	   *	{READ,WRITE}_DMA_EXT_GPL commands
	   *	Segmented DOWNLOAD_MICROCODE
	   *	Gen1 signaling speed (1.5Gb/s)
	   *	Gen2 signaling speed (3.0Gb/s)
	   *	Native Command Queueing (NCQ)
	   *	Phy event counters
	    	Device-initiated interface power management
	   *	Software settings preservation
	   *	SMART Command Transport (SCT) feature set
	   *	SCT Read/Write Long (AC1), obsolete
	   *	SCT Write Same (AC2)
	   *	SCT Error Recovery Control (AC3)
	   *	SCT Features Control (AC4)
	   *	SCT Data Tables (AC5)
	    	unknown 206[12] (vendor specific)
Security: 
	Master password revision code = 65534
		supported
	not	enabled
	not	locked
		frozen
	not	expired: security count
		supported: enhanced erase
	46min for SECURITY ERASE UNIT. 46min for ENHANCED SECURITY ERASE UNIT. 
Logical Unit WWN Device Identifier: 5000c5001f89334f
	NAA		: 5
	IEEE OUI	: 000c50
	Unique ID	: 01f89334f
Checksum: correct

Pensavo: ma un comando per non attivare gli hd non montati all'avvio?

Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 71

Ufficialmente risolto e vi spiego anche da cosa era dato:
Su conky con 'hddtemp' rilevavo le temperature sia dell'HDD che dell'SSD: quindi l'HD mi rimaneva continuamente attivo. Così la prima parte della soluzione è stata rimuove hddtemp ed il suo demone all'avvio.
Successivamente al mio file di autostart in /home/user/.config/ ho aggiunto il comando "hdparm -S 1 /dev/sda", così che dopo 5sec di inattività vada in stand-by. Anche montandolo e rismontandolo, dopo quei 5sec di inattività , va in stand-by.

Alla prossima.