xserver

3 risposte [Ultimo contenuto]
Ritratto di frippe12573
frippe12573
(Junior)
Offline
Junior
Iscritto: 24/01/2007
Messaggi: 35

Buonasera,
sono stato occupato in quest'ultimo periodo, percui non sono riuscito ancora a sistemare Xserver.
Ricapitolando:
- notebook toshiba satellite m60-162, debian 4.0 sid
- ormai 20 gg fa mentre lavoravo feci un dselect per aggiornare il sistema
- al seguente riavvio nonmi è più andato xserver per i motivi che stanno all'oggetto di questo topic "fglrx dice che ho xorg 1.3"
- penso e pensavo che il pacchetto aggiornato di xserver-xorg sia non venga supportato dal driver proprietario che avevo installato, versione 8.33 circa
- dato che la ati non ha rilasciato altri driver dal 18 aprile
- ho disinstallato i driver proprietari e ho provato a far partire x con i driver vesa, risultato....nisba
- al che ho rimosso anche il file di conf xorg.conf, rimosso tutto il metapacchetto xserver-xorg e riavviato
- poi ho riscaricato apt-get install xserver-xorg
- configurato con dpkg-reconfigure xserver-xorg
- mettendo driver vesa
- niente.....accidenti...
- mi da il seguente messaggio di errore:
(II) Module already built-in
(EE) VESA (0): No matching modes
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screen found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 request (0 known processed) with 0 events remaining.

- a questo punto allego anche il mio file xorg.conf

Vi prego aiuto........
Grazie

Ecco il file xorg.conf:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor Generico"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility X700 (PCIE)"
Monitor "Monitor Generico"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Ritratto di Giampy86
Giampy86
(Monster)
Offline
Monster
Iscritto: 22/09/2005
Messaggi: 243

controlla le frequenze di refresh vert e orizzontali e se sono diverse modificale con quelle specifiche del tuo monitor. poi metti i driver ati invece di quelli vesa.
non so se può essere d'aiuto
ciao

Ritratto di RobertoVanto
RobertoVanto
(Junior)
Offline
Junior
Iscritto: 04/05/2007
Messaggi: 9

Ti consiglio di rimuovere ogni file che riguardi i driver fglrx. Poi li reinstalli seguendo questa guida:http://www.debianclan.org/index.php?option=com_content&task=view&id=52&Itemid=38 , usando i driver presenti nei repository(anche se non sono aggiornatissimi):

Alla fine, nel caso fosse necessario, riconfigura xserver-xorg con:

% dpkg-reconfigure xserver-xorg

Ama e fa' ciò che vuoi. (Sant'Agostino d'Ippona) - robertovanto.blogspot.com

Ritratto di filoa86
filoa86
(Newbie)
Offline
Newbie
Iscritto: 12/09/2007
Messaggi: 1

Ciao invece io ho un problema:

quando faccio dpkg-reconfigure xserver-xorg non mi da la possibilità di configurare il tipo di driver che voglio usare e nemmeno la risoluzione del monitor. Mi dice solamente se attivare il supporto framebuffer e selezionare il tipo di tastiera e la lingua.
Come posso fare?
Grazie