apt-build - "Package kde does not need to be rebuilt"

5 risposte [Ultimo contenuto]
Ritratto di deglans
deglans
(Monster)
Offline
Monster
Iscritto: 05/01/2005
Messaggi: 252

Ciao

Sto tentando di usare apt-build per la prima volta.
Come da titolo l'errore è questo:
# apt-build --reinstall install kde<br />Package kde does not need to be rebuilt<br /># apt-build --reinstall install kdebase<br />Package kdebase does not need to be rebuilt
il mio apt-build.conf è questo:
build-dir = /var/cache/apt-build/build
repository-dir = /var/cache/apt-build/repository
Olevel = -O2
march = -march=athlon-xp
mcpu = -mcpu=athlon-xp
options = " "
make_options = " "

Qualcuno mi può aiutare?

ciao deglans
Big Grin :-D Big Grin

Linux registered user #383755

justfuckinggoogleit.com

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Ciao,
la butto lì:
sicuro che nella tua sources.list ci sia il percorso dei sorgenti kde?

Non ricordo di aver mai usato apt-build, anche perche' con un P3 1ghz e 128 mb/ram mi servirebbero settimane :-P

Cmq. qui ho trovato una guida.
http://julien.danjou.info/article-apt-build.html

Ciao
Fabio

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di deglans
deglans
(Monster)
Offline
Monster
Iscritto: 05/01/2005
Messaggi: 252

Grazie per l'aiuto, ma penso che il problema sia un'altro...
Il mio /etc/apt/sources.list è questo:

<br />deb file:/var/cache/apt-build/repository apt-build main<br /><br />deb ftp://ftp.it.debian.org/debian/ sarge main non-free contrib<br />deb ftp://ftp.it.debian.org/debian-non-US/ sarge/non-US main non-free contrib<br />deb http://security.debian.org/ sarge/updates main non-free contrib<br /><br />deb-src ftp://ftp.it.debian.org/debian/ sarge main non-free contrib<br />deb-src ftp://ftp.it.debian.org/debian-non-US/ sarge/non-US main non-free contrib<br />deb-src http://security.debian.org/ sarge/updates main non-free contrib<br />
Io ho seguito questa guida
http://www.debianitalia.org/modules/wfsection/article.php?articleid=51

ciao deglans
Big Grin :-D Big Grin

Linux registered user #383755

justfuckinggoogleit.com

Ritratto di fabiog367
fabiog367
(Monster)
Offline
Monster
Iscritto: 07/09/2004
Messaggi: 207

Sicuro che e' questo?
# apt-build --reinstall install kde

Perche' la guida e' stata corretta...
# apt-get --reinstall install kdebase

Ciao
Fabio

edit: a titolo informativo che velocita' e' il tuo processore? E quanto ci mette a compilare tutto?

Registered User #366480
Kubuntu 7.10 on Sony Vaio PCG-FR215S and PCG-Z1RSP ('na belva!)

Ritratto di deglans
deglans
(Monster)
Offline
Monster
Iscritto: 05/01/2005
Messaggi: 252

Leggi bene:
Quote:

Bella guida!

Segnalo un banale errore tipografico, il secondo comando è
<br /># apt-get --reinstall install kdebase<br />
invece di
<br /># apt-build --reinstall install kdebase<br />

Proverò ad usare debuild ...

Io ho un Athlon XP 2200+ (aka 1,8GHz) e 256M di RAM e ho ricompilato il kernel in circa 40 min

ciao deglans
Big Grin :-D Big Grin

Linux registered user #383755

justfuckinggoogleit.com

Ritratto di deglans
deglans
(Monster)
Offline
Monster
Iscritto: 05/01/2005
Messaggi: 252

Dunque il problema dovrebbe dipendere da questo bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=176649

In ogni caso ho provato con
apt-build --reinstall install katee non ho avuto nessun problema.

Comunque un grazie a fabiog367 e a chiunque potesse aiutarmi.

ciao deglans
Big Grin :-D Big Grin

Linux registered user #383755

justfuckinggoogleit.com