Video verdi con totem

5 risposte [Ultimo contenuto]
Ritratto di Taita
Taita
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 15

Da una settimana a questa parte se inserisco un dvd o cerco di vedere un video totem me li visualizza in un colore tendente al verde. Tutto questo non succede con altri video-player. Solo che, essendo totem il predefinito, quando inserisco un dvd parte in automatico e successivamente anche utilizzando xine o vlc continuo a vederlo in quel bel tono di colore. In questo caso devo sloggarmi dall'utente e ricollegarmi e questi applicativi rifunzionano correttamente.

2 domande:

l'associazione applicazione-tipo di file si fa facilmente ma come si impedisce a totem di avviarsi in automatico all'inserimento di un dvd?, quale file gestisce le associazioni di questo tipo?

come posso capire ciò che succede quando totem si avvia?, nei log di sistema non mi sembra ci sia nulla di relativo al problema e, a meno di disinstallare totem, non mi viene in mente nulla per risolvere il problema.

Grazie

Ritratto di linuxnic
linuxnic
(Monster)
Offline
Monster
Iscritto: 10/07/2005
Messaggi: 241

Vai sopra il file e clicchi con il destro,ti dovrebbe dare le varie opzioni presenti sul tuo sistema altrimenti vai con "apri con altra applicazione".
Hai provato a lanciarlo da shell,per vedere se ti manca un qualche codec?
Poi altra cosa che scheda video hai?A me succedeva una cosa analoga con certi driver...........
Ciao

-= Nic =-
Amico di Emergency_2009
Linux registered user # 380338
Linux registered machine # 283289

Ritratto di luxtux
luxtux
(Geek)
Offline
Geek
Iscritto: 30/04/2009
Messaggi: 57

Quote:

Taita ha scritto:
Da una settimana a questa parte se inserisco un dvd o cerco di vedere un video totem me li visualizza in un colore tendente al verde. Tutto questo non succede con altri video-player. Solo che, essendo totem il predefinito, quando inserisco un dvd parte in automatico e successivamente anche utilizzando xine o vlc continuo a vederlo in quel bel tono di colore. In questo caso devo sloggarmi dall'utente e ricollegarmi e questi applicativi rifunzionano correttamente.

probabilmente hai installato gstreamer dai repository di Marillat (debian-multimedia). Disinstallalo e installa la versione dai repository ufficiali.
Quote:

2 domande:

l'associazione applicazione-tipo di file si fa facilmente ma come si impedisce a totem di avviarsi in automatico all'inserimento di un dvd?, quale file gestisce le associazioni di questo tipo?

Dipende dal tuo DE. Io, per esempio ho Xfce4 che l'autorun non ce l'ha. Vai nel pannello di controllo e senz'altro troverai l'opzione adatta.
Quote:

come posso capire ciò che succede quando totem si avvia?, nei log di sistema non mi sembra ci sia nulla di relativo al problema e, a meno di disinstallare totem, non mi viene in mente nulla per risolvere il problema.

Grazie

Avvia l'applicazione da console.

ciao

L.

| (o> |
| //\ | Debian 5.0.1 [Lenny]
| V_/_| Registered Linux user #158396

Ritratto di Taita
Taita
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 15

Dunque, ho trovato il modo per bloccare l'autorun, è l'ultima voce del menu preferenze (non ricordo con esattezza come si chiama e non sono a casa ora), da lì si può settare il programma per aprire un dvd o altro. Quello che dici, luxtux, su gstreamer mi incuriosisce ma è anche vero che gstreamer l'ho installato da un bel pezzo e i repo di marillat erano attivi già all'epoca ..... Gstreamer non dovrebbe essere uno "strato" comune utilizzato da tutte le applicazioni multimediali per risolvere il problema dei plug-in?. Se così perché alcune funzionano correttamente e altre no?, mi aspetto esattamente il contrario. Comunque appena a casa vedo di capire da dove l'ho installato e, nel caso marillat, seguirò il tuo consiglio e vedremo.

Grazie

Ritratto di Taita
Taita
(Junior)
Offline
Junior
Iscritto: 05/12/2008
Messaggi: 15

Dimenticavo, ho una Nvidia FX5500

Ritratto di teracruzer
teracruzer
(Newbie)
Offline
Newbie
Iscritto: 22/11/2007
Messaggi: 4

Io ho avuto lo stesso problema sulla mia xubuntu 8.10 con i driver nividia 177.xx e una 8600GT, ora sulla 9.04 e driver 180.53 il problema non si presenta più. Ho sempre usato totem-gstreamer.
Spero ti possa servire anche se non penso tu possa installare gli ultimi driver sulla tua geforce. Thinking