squeeze e driver intel video(855GM)

11 risposte [Ultimo contenuto]
Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

Ciao a tutti, ho installato debian squeeze sul vecchio portatile e sto diventando matto per fargli riconoscere correttamente la scheda video integrata.
Il file xorg.conf non esiste, evidentemente xorg si configura da solo all'avvio e non riesco a farglielo creare nemmeno con "X -configure" .

l'output di lspci | grep Graphic é

00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics Device (rev 02)

invece glxinfo | grep render:

direct rendering: Yes
OpenGL renderer string: Mesa X11

con "X -configure" mi dice che manca il modulo fbcon e inoltre che i monitore creati non corrispondono a quelli trovati... come posso fare per abilitare il supporto 3D e installare i driver pa la scheda ???

Inoltre, se cerco di rimuovere ad esempio epiphany, apt-get vuole rimuovere anche tutto gnome... come mai?

Ritratto di marcolnx
marcolnx
(Junior)
Offline
Junior
Iscritto: 14/01/2011
Messaggi: 8

Ciao, in squeeze il kernel utilizza il KMS (Kernel Mode Setting).
Prova creando manualmente da root il file xorg.conf e inserisci all'interno il driver per la tua scheda video, dovrebbe essere Driver "intel" nella sezione "Device".
Io non ho aggiornato a squeeze perche' questo mi procurava diversi problemi sulla mia vecchia scheda ati M6 LY (tipo schermo nero dopo sospensione su ram, ecc.).
Magari con google trovi approfondimenti riguardo i nuovi kernel e KMS, oltre alla risoluzione di problemi.
Saluti.

Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

innanzi tutto grazie per la risposta.
Ho provato a creare lo xorg.conf da root, purtroppo però questo non viene creato. Ho anche cercato molto su google ed effettivamente ho notato che 2/3 utenti hanno segnalato lo stesso bug(non ancora risolto).
Non capisco però come mai su ubuntu 10.04, che usa KMS, la scheda video funziona perfettamente(passando come parametro i915.modeset=1). Con debian squeeze invece non viene creato nemmeno lo xorg.conf...

Ritratto di marcolnx
marcolnx
(Junior)
Offline
Junior
Iscritto: 14/01/2011
Messaggi: 8

Ciao,prova a leggere questa guida: http://www.gentoo.org/doc/it/xorg-config.xml
Come vedi xorg.conf viene creato nella directory /root con nome xorg.conf.new
Puoi sempre provare a crearlo manualmente con touch:
#touch /etc/X11/xorg.conf
e successivamente inserire le opzioni per la tua scheda video.
Fai dei tentativi e facci sapere.
Saluti.

Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

ho provato con "touch" ma non succede nulla...
allora ho preso lo xorg.conf.new e l'ho messo in /etc/X11/xorg.conf, cancellando alcune cose doppie(tipo avevo configurato 2 monitor ma ne ho solo 1... aveva anche messo 2 schede grafiche identiche chiamandole card0 e card1. vabbè.. Confused ).
lo xorg.conf ora è così:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath     "built-ins"
EndSection
 
Section "Module"
	Load  "dri2"
	Load  "dbe"
	Load  "dri"
	Load  "extmod"
	Load  "glx"
	Load  "record"
EndSection
 
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection
 
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection
 
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection
 
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "AccelMethod"        	# [<str>]
        #Option      "DRI"                	True
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "Tiling"             	# [<bool>]
        #Option     "Shadow"             	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82852/855GM Integrated Graphics Device"
	BusID       "PCI:0:2:0"
	Option 	    "XAANoOffscreenPixmaps"     "True"
 
EndSection
Section "Extensions"
        Option "Composite" "enable"
EndSection
 
 
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Section "Extensions"
   Option      "Composite"   "Enable"
EndSection

purtroppo però, anche così, non ne vuole sapere di attivare l'accelerazione 3D.. infatti il risultato di glxinfo | grep render è:

direct rendering: Yes
OpenGL renderer string: Software Rasterizer

sto diventando matto! e pensare che su ubuntu 10.04 funziona

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Una volta anch'io pensavo che "Software Rasterizer" fosse sinonimo di accelerazione 3D non funzionante, ma ho dovuto ricredermi. Sospetto si riferisca solo ad una parte del 3D (texture tiling?). Quanti fps ottieni con glxgears?

Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

con glxgears ottengo circa 120fps... se installo il pacchetto libgl1-mesa-swx11 si attiva una sorta di accelerazione 3D, infatti raggiungo i 600 fps e al posto di "softare rasterizer" appare "mesa"... il problema è che se faccio partire compiz mi dice che è in uso un "software rasterizer". In effetti questi mesa swx11 penso che siano proprio l'emulazione 3D software. Invece dovrei attivare il direct rendering hardware ma non riesco

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

A me succede una cosa simile.

Lancio X con startx e do questo comando:

$ glxinfo | grep -i render
direct rendering: Yes 
OpenGL renderer string: Mesa DRI R200 (RV280 5964) 20090101 x86/MMX/SSE2 TCL DRI2

Chiudo, faccio partire GDM, mi loggo e:

$ glxinfo | grep -i render
direct rendering: Yes 
OpenGL renderer string: Software Rasterizer 

Poi, senza uscire da X, lancio Compiz. Da Compiz apro un nuovo xterm, e di nuovo:

$ glxinfo | grep -i render
direct rendering: No (LIBGL_ALWAYS_INDIRECT set)
OpenGL renderer string: Mesa DRI R200 (RV280 5964) 20090101 x86/MMX/SSE2 TCL DRI2 

Come vedi, tre risultati diversissimi nell'arco della stessa sessione. Inizio a sospettare che glxinfo non sia affidabile. Adesso per capire se davvero il 3D funziona cerco la stringa "DRI2" nel log di X.

Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

bè ma compiz ti funziona?
a me nonostante mi dica che il rendering è attivo, poi compiz non parte perchè rileva il software rasterizer..

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Sì. Sei sicuro di lanciare l'eseguibile Compiz e non uno script wrapper che interroga glxinfo e poi lancia Compiz di conseguenza (mi sembra che su Ubuntu funzioni così)?

Ritratto di stedrum
stedrum
(Junior)
Offline
Junior
Iscritto: 02/02/2010
Messaggi: 25

uso debian squeeze.
lancio compiz facendo: compiz --replace
Credo si tratti di un bug perchè con la debian lenny funzionava tutto e anche su ubuntu 10.04. Su quest'ultima per farlo partire dovevo abilitare il kms dando come parametro i915.modeset=1 al kernel.
Ho provato a passare lo stesso parametro a debian squeeze ma non cambia nulla..

alla fine ho rimesso ubuntu 10.04 sul portatile... la squeeze per ora la tengo solo sul desktop che li funziona tutto