Scheda Video ATI: fglrx conflicts with the free radeon module

Ritratto di nu4mb4
nu4mb4
(Junior)
Offline
Junior
Iscritto: 16/01/2015
Messaggi: 27

Ciao a tutti,
inizio ragionevolmente a pensare che il driver proprietario fglrx 14.9 richieda il kernel precedente al 3.16 (di xorg?)
Volendo retromigrare a wheezy posso installare il driver 14.9 da backports?

Ciao
Dario

Ritratto di nu4mb4
nu4mb4
(Junior)
Offline
Junior
Iscritto: 16/01/2015
Messaggi: 27

ERRATA CORRIGE

E' esattamente l'opposto.
Il driver 14.9 (il primo che supporta la GPU serie RX 2XX supporta fino al kernel 3.15 mentre in jessie mi ritrovo il 3.16
Quindi immagino che o avanzo il driver all'ultima versione o retromigro il kernel.
Certo non immaginavo di incontrare questo inconveniente installando da repository.

Prima di procedere resto in attesa di vostre considerazioni al riguardo.
Ciao
Dario

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Sei sicuro? I pacchetti in testing sono sempre coerenti tra di loro, quindi se testing contiene il kernel 3.16 e fglrx 14.9 vuol dire che sono compatibili tra di loro.

Non è che hai fatto qualche pasticcio installando e disinstallando versioni diverse del kernel? Sta usando testing, stable, o un misto?

Consiglierei di disinstallare (purge) tutti i pacchetti legati a fglrx, fare pulizia dei kernel finché non ne resta solo uno e infine reinstallare fglrx-driver, controllando che tutto vada a buon fine e che il modulo fglrx.ko sia installato sotto /lib/modules/VERSION/update/...

Ritratto di nu4mb4
nu4mb4
(Junior)
Offline
Junior
Iscritto: 16/01/2015
Messaggi: 27

Ciao MCortese,

figurati ho reistallato la macchina diverse volte (le sto provando tutte...)
Comunque si, sono certo.
Ti indico i System Requirements:

Before attempting to install the AMD Catalyst™ Linux Graphics Driver, the following software must be installed:

Xorg/Xserver 7.4 and above (up to 1.15)
Linux kernel 2.6 or above (up to 3.15)
glibc version 2.2 or 2.3
POSIX Shared Memory (/dev/shm) support is required for 3D applications

Fonte: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9LINReleaseNotes.aspx

Vorrei segnalare la cosa in Debian ma non so come fare.
Ciao
Dario

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Ho visto che hai segnalato il baco e che ti hanno risposto: il pacchteto 14.9 in realtà contiene il driver 14.6! Ora la domanda fatidica: il driver 14.6 gestisce la tua scheda?

Ritratto di nu4mb4
nu4mb4
(Junior)
Offline
Junior
Iscritto: 16/01/2015
Messaggi: 27

Ciao Mcortese!
inizi a diventare il mio mito!
Si ho segnalato la cosa e mi hanno risposto che il driver è in realta' il 14.6
Il bello è che la scheda è supportata dalla versione 13.12 del driver, quindi teoricamente dovrebbe andare.
Approfondendo... il driver 14.9 presente in jessie è lo stesso presente in wheezy-backports ma anche qui' l'installazione fallisce.
Girando un po tra i vari forum lo stesso errore lo si aveva in ubuntu 12.04 ed il workaround prevedeva di patchare il driver creando un link simbolico.
Non ho capito ancora come cio' viene fatto.
Per il momento sono fermo qui.

Grazie per il continuo supporto Smile
Ciao
Dario

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Dovresti dire qual è la discussione Ubuntu che citi o almeno dettagliare il workaround: di link simbolici se ne possono fare a iosa...

Piuttosto ci dev'essere qualcosa che non funziona nella compilazione del modulo, perrché alla fine non te lo ritrovi. Puoi provare a riconfigurare fglrx-driver salvando l'output da qualche parte? Tipo:

# script mio_file
# dpkg-reconfigure fglrx-driver
# find /lib/modules -name fglrx.ko -print
# exit

Ritratto di nu4mb4
nu4mb4
(Junior)
Offline
Junior
Iscritto: 16/01/2015
Messaggi: 27

Ciao MCortese,
scusami... ecco uno dei link a cui facevo riferimento:
http://www.xfce-italia.it/index.php?topic=2344.0
Ma con jessie ho letto che anche xorg (forse) dovrebbe essere downgradato perche' fuori requirementes del driver (appena trovo il post ti indico anche questo).
Ora, da quanto ho avuto modo di intendere dalle conversazioni con te, i driver presenti nei repository sono comunque preparati perche' siano coerenti con la versione quindi credo che il punto sia la scarsa diffusione ad oggi della scheda R7 2XX probabilmente perche' troppo recente anche perche' con la serie HD di ATI non ci sono problemi.
Appena posso ti allego l'output richiesto.
Fammi sapere cosa ne pensi.
A presto
Dario

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Leggendo il link che hai segnalato, sembrerebbe che la versione 14.6 dei driver AMD abbia un problema di compatibilità con i kernel 3.14. Il problema si manifesta con un messaggio di errore già in fase di installazione-compilazione e poi con il mancato caricamento del modulo al successivo riavvio (sfido: il modulo non è stato compilato, come potrebbe caricarlo?).

Esiste una patch da applicare ai sorgenti prima della compilazione che risolve il problema. Ovviamente quando si installano i driver "alla Debian", non c'è modo di fermare un attimo l'installazione, applicare la patch e poi continuare con la compilazione come se niente fosse. Quindi l'unico modo per sfruttare la patch è compilarsi i driver alla vecchia maniera: scaricarli dal sito AMD, scompattarli, applicare la patch, far partire la compilazione e infine aggiustare la configurazione di X. Sembra complicato, ma i singoli passi sono ben spiegati nel link.

Non ti resta che provare e farci sapere! Smile

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Un'altra cosa, anzi due!

In quest'altro post dicono che il problema non c'è più con la versione 14.9. Però attenzione: la 14.9 va bene con X 1.12 presente in Wheezy, ma è incompatibile con X 1.16 presente da Jessie in su. Quindi installare la 14.9 su Wheezy funzionerebbe, ma poi non potresti aggiornare a Jessie una volta che questo diventa stabile (tra qualche mese).

La seconda cosa è che GNOME 3.14, quello che c'è in Jessie, fa a cazzotti con i driver fglrx per via di Wayland. Quindi aggiornare a Jessie è comunque fuori discussione se hai installato i driver proprietari e usi GNOME. Nessun problema (noto) con gli altri ambienti desktop.

Purtroppo questo è quello che succede quando il software non è open.