Ripristino debian dopo errato aggiornamento a unstable

2 risposte [Ultimo contenuto]
Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1071

Salve,
possiedo un pc con debian testing con una scheda video nvidia funzionante con i driver proprietari nvidia-legacy-304.
Oggi, per errore, ho fatto aggiornamento a debian unstable e non si avvia più il server x.
Cosa posso fare per ripristinare il sistema?
Di seguito i pacchetti che sono stati installati e aggiornati

Start-Date: 2018-06-12  13:55:29
Commandline: apt dist-upgrade
Install: libx265-151:amd64 (2.7-3, automatic), mysql-client-5.7:amd64 (5.7.22-1, automatic), libgegl-0.4-0:amd64 (0.4.2-1, automatic), libpython2-stdlib:amd64 (2.7.15-3, automatic), libgegl-common:amd64 (0.4.2-1, automatic), python2:amd64 (2.7.15-3, automatic), libpython2-dev:amd64 (2.7.15-3, automatic), libgexiv2-2:amd64 (0.10.8-1, automatic), mysql-client-core-5.7:amd64 (5.7.22-1, automatic), ruby-xmlrpc:amd64 (0.3.0-1, automatic), libmypaint-1.3-0:amd64 (1.3.0-2, automatic), python2-dev:amd64 (2.7.15-3, automatic), python2-minimal:amd64 (2.7.15-3, automatic), fluid-soundfont-gm:amd64 (3.1-5.1, automatic), libheif1:amd64 (1.2.0-1, automatic), libde265-0:amd64 (1.0.3-1, automatic), libmypaint-common:amd64 (1.3.0-2, automatic)
Upgrade: debconf:amd64 (1.5.66, 1.5.67), perl-base:amd64 (5.26.2-5, 5.26.2-6), libmpx0:amd64 (5.4.1-4, 5.5.0-12), libsane-extras:amd64 (1.0.22.5, 1.0.22.6), libsane-extras:i386 (1.0.22.5, 1.0.22.6), libsoup-gnome2.4-1:amd64 (2.62.1-1, 2.62.2-1), exim4-base:amd64 (4.91-4, 4.91-5), gnome-keyring:amd64 (3.28.0.2-1, 3.28.2-1), libmagickcore-6.q16-5-extra:amd64 (8:6.9.9.34+dfsg-3+b1, 8:6.9.9.39+dfsg-1), xserver-xorg-video-vesa:amd64 (1:2.3.4-1+b2, 1:2.3.4-1+b3), timidity-daemon:amd64 (2.13.2-41, 2.14.0-3), libatlas3-base:amd64 (3.10.3-6, 3.10.3-7), libpython3.6-minimal:amd64 (3.6.5-9, 3.6.5-10), libgcc-5-dev:amd64 (5.4.1-4, 5.5.0-12), libpangoft2-1.0-0:amd64 (1.42.0-1, 1.42.1-1), libpangoft2-1.0-0:i386 (1.42.0-1, 1.42.1-1), dbus-x11:amd64 (1.12.8-2, 1.12.8-3), python-twisted-core:amd64 (17.9.0-2, 18.4.0-1), libvte-2.91-0:amd64 (0.52.0-1, 0.52.2-1), libcups2:amd64 (2.2.8-2, 2.2.8-3), libdbus-1-3:amd64 (1.12.8-2, 1.12.8-3), libdbus-1-3:i386 (1.12.8-2, 1.12.8-3), xserver-xorg-video-nouveau:amd64 (1:1.0.15-2, 1:1.0.15-2+b1), python-openssl:amd64 (17.5.0-1.1, 18.0.0-1), libpkcs11-helper1:amd64 (1.22-4, 1.23-1), gir1.2-gtk-3.0:amd64 (3.22.29-3, 3.22.30-1), gnupg-utils:amd64 (2.2.7-1, 2.2.8-1), xserver-common:amd64 (2:1.19.6-1, 2:1.20.0-2), ifupdown:amd64 (0.8.32, 0.8.34), gir1.2-secret-1:amd64 (0.18.6-1, 0.18.6-2), gnupg-agent:amd64 (2.2.7-1, 2.2.8-1), gir1.2-soup-2.4:amd64 (2.62.1-1, 2.62.2-1), gpg-wks-client:amd64 (2.2.7-1, 2.2.8-1), scdaemon:amd64 (2.2.7-1, 2.2.8-1), ruby2.5:amd64 (2.5.1-1+b1, 2.5.1-3), xserver-xorg-core:amd64 (2:1.19.6-1, 2:1.20.0-2), libvncclient1:amd64 (0.9.11+dfsg-1, 0.9.11+dfsg-1.1), gnupg-l10n:amd64 (2.2.7-1, 2.2.8-1), libibverbs1:amd64 (17.1-2, 18.0-1), appstream:amd64 (0.12.0-3, 0.12.1-1), libssh-4:amd64 (0.8.0~20170825.94fa1e38-1, 0.8.0~20170825.94fa1e38-2), liblcms2-2:amd64 (2.9-1, 2.9-2), liblcms2-2:i386 (2.9-1, 2.9-2), libpython3.6-dev:amd64 (3.6.5-9, 3.6.5-10), imagemagick:amd64 (8:6.9.9.34+dfsg-3+b1, 8:6.9.9.39+dfsg-1), libgtk-3-common:amd64 (3.22.29-3, 3.22.30-1), xserver-xorg-video-cirrus:amd64 (1:1.5.3-1+b2, 1:1.5.3-1+b3), libgtk-3-0:amd64 (3.22.29-3, 3.22.30-1), libpango1.0-0:amd64 (1.42.0-1, 1.42.1-1), libpango1.0-0:i386 (1.42.0-1, 1.42.1-1), cpp-5:amd64 (5.4.1-4, 5.5.0-12), python-twisted-bin:amd64 (17.9.0-2, 18.4.0-1), dbus:amd64 (1.12.8-2, 1.12.8-3), debconf-i18n:amd64 (1.5.66, 1.5.67), libcups2-dev:amd64 (2.2.8-2, 2.2.8-3), libsecret-1-0:amd64 (0.18.6-1, 0.18.6-2), libsqlite3-0:amd64 (3.23.1-1, 3.24.0-1), libsqlite3-0:i386 (3.23.1-1, 3.24.0-1), libpython3.6-stdlib:amd64 (3.6.5-9, 3.6.5-10), libcupsimage2-dev:amd64 (2.2.8-2, 2.2.8-3), giblib1:amd64 (1.2.4-11, 1.2.4-12), libmagickwand-6.q16-5:amd64 (8:6.9.9.34+dfsg-3+b1, 8:6.9.9.39+dfsg-1), mysql-client:amd64 (5.6.30-1, 5.7.22-1), liblouis14:amd64 (3.5.0-3, 3.5.0-4), amule:amd64 (1:2.3.2-2, 1:2.3.2-3), p11-kit:amd64 (0.23.10-2, 0.23.12-2), xserver-xorg-video-fbdev:amd64 (1:0.4.4-1+b5, 1:0.5.0-1), apt-config-icons-large:amd64 (0.12.0-3, 0.12.1-1), ibverbs-providers:amd64 (17.1-2, 18.0-1), perl-modules-5.26:amd64 (5.26.2-5, 5.26.2-6), python3-pil:amd64 (4.3.0-2, 5.1.0-1), nano:amd64 (2.9.7-1, 2.9.8-1), gpg-wks-server:amd64 (2.2.7-1, 2.2.8-1), gimp-data:amd64 (2.8.22-1, 2.10.2-1), libpython3.6:amd64 (3.6.5-9, 3.6.5-10), python3.6:amd64 (3.6.5-9, 3.6.5-10), xserver-xorg-legacy:amd64 (2:1.19.6-1, 2:1.20.0-2), exim4-daemon-light:amd64 (4.91-4, 4.91-5), gpg:amd64 (2.2.7-1, 2.2.8-1), gir1.2-pango-1.0:amd64 (1.42.0-1, 1.42.1-1), python-regex:amd64 (0.1.20171212-2, 0.1.20180609-1), cups-server-common:amd64 (2.2.8-2, 2.2.8-3), libsecret-common:amd64 (0.18.6-1, 0.18.6-2), libasan2:amd64 (5.4.1-4, 5.5.0-12), network-manager-gnome:amd64 (1.8.10-5, 1.8.12-2), librdmacm1:amd64 (17.1-2, 18.0-1), cups-common:amd64 (2.2.8-2, 2.2.8-3), libmagic1:amd64 (1:5.33-2, 1:5.33-3), python:amd64 (2.7.15~rc1-1, 2.7.15-3), libsane-extras-common:amd64 (1.0.22.5, 1.0.22.6), p11-kit-modules:amd64 (0.23.10-2, 0.23.12-2), libvpx4:amd64 (1.6.1-3, 1.6.1-3+deb9u1), libvpx4:i386 (1.6.1-3, 1.6.1-3+deb9u1), rsyslog:amd64 (8.34.0-1, 8.35.0-1), libsoup2.4-1:amd64 (2.62.1-1, 2.62.2-1), libvncserver1:amd64 (0.9.11+dfsg-1, 0.9.11+dfsg-1.1), libpam-gnome-keyring:amd64 (3.28.0.2-1, 3.28.2-1), geoclue-2.0:amd64 (2.4.7-1, 2.4.10-1), libxkbcommon-x11-0:amd64 (0.8.0-1, 0.8.0-2), libgeoclue-2-0:amd64 (2.4.7-1, 2.4.10-1), dirmngr:amd64 (2.2.7-1, 2.2.8-1), libperl5.26:amd64 (5.26.2-5, 5.26.2-6), python3.6-minimal:amd64 (3.6.5-9, 3.6.5-10), python-cryptography:amd64 (2.1.4-1, 2.2.2-1), gcc-5-base:amd64 (5.4.1-4, 5.5.0-12), gcc-5-base:i386 (5.4.1-4, 5.5.0-12), libpangoxft-1.0-0:amd64 (1.42.0-1, 1.42.1-1), libpangoxft-1.0-0:i386 (1.42.0-1, 1.42.1-1), libpython-stdlib:amd64 (2.7.15~rc1-1, 2.7.15-3), gimp:amd64 (2.8.22-1, 2.10.2-1), amule-common:amd64 (1:2.3.2-2, 1:2.3.2-3), libvte9:amd64 (1:0.28.2-5+b2, 1:0.28.2-5+b3), imagemagick-6.q16:amd64 (8:6.9.9.34+dfsg-3+b1, 8:6.9.9.39+dfsg-1), xserver-xorg-video-mach64:amd64 (6.9.5-1+b2, 6.9.6-1), libgtk-3-bin:amd64 (3.22.29-3, 3.22.30-1), libmagic-mgc:amd64 (1:5.33-2, 1:5.33-3), libpangocairo-1.0-0:amd64 (1.42.0-1, 1.42.1-1), libpangocairo-1.0-0:i386 (1.42.0-1, 1.42.1-1), python3-debconf:amd64 (1.5.66, 1.5.67), cups-ppdc:amd64 (2.2.8-2, 2.2.8-3), libcupsmime1:amd64 (2.2.8-2, 2.2.8-3), libruby2.5:amd64 (2.5.1-1+b1, 2.5.1-3), exim4-config:amd64 (4.91-4, 4.91-5), amule-utils-gui:amd64 (1:2.3.2-2, 1:2.3.2-3), xserver-xorg-video-sisusb:amd64 (1:0.9.7-1, 1:0.9.7-1+b1), libpython-dev:amd64 (2.7.15~rc1-1, 2.7.15-3), python-pygame:amd64 (1.9.1release+dfsg-10+b2, 1.9.3+dfsg2-2), libxdo3:amd64 (1:3.20160805.1-3, 1:3.20160805.1-4), make:amd64 (4.1-9.1, 4.2.1-1), xserver-xorg-video-tdfx:amd64 (1:1.4.7-1, 1:1.4.7-1+b1), gcc-5:amd64 (5.4.1-4, 5.5.0-12), libdbus-1-dev:amd64 (1.12.8-2, 1.12.8-3), gpgv:amd64 (2.2.7-1, 2.2.8-1), libappstreamqt2:amd64 (0.12.0-3, 0.12.1-1), xserver-xorg-video-vmware:amd64 (1:13.2.1-1+b1, 1:13.3.0-2), libgail-3-0:amd64 (3.22.29-3, 3.22.30-1), xwayland:amd64 (2:1.19.6-1, 2:1.20.0-2), libjpeg9:amd64 (1:9a-2, 1:9b-2), libnma0:amd64 (1.8.10-5, 1.8.12-2), wpasupplicant:amd64 (2:2.6-16, 2:2.6-17), mkvtoolnix:amd64 (23.0.0-2, 24.0.0-1), libssh-gcrypt-4:amd64 (0.8.0~20170825.94fa1e38-1, 0.8.0~20170825.94fa1e38-2), python-dev:amd64 (2.7.15~rc1-1, 2.7.15-3), xdotool:amd64 (1:3.20160805.1-3, 1:3.20160805.1-4), libmagickcore-6.q16-5:amd64 (8:6.9.9.34+dfsg-3+b1, 8:6.9.9.39+dfsg-1), exim4:amd64 (4.91-4, 4.91-5), amule-utils:amd64 (1:2.3.2-2, 1:2.3.2-3), gnupg2:amd64 (2.2.7-1, 2.2.8-1), libgimp2.0:amd64 (2.8.22-1, 2.10.2-1), file:amd64 (1:5.33-2, 1:5.33-3), libvte-2.91-common:amd64 (0.52.0-1, 0.52.2-1), libsane-extras-dev:amd64 (1.0.22.5, 1.0.22.6), libcupsppdc1:amd64 (2.2.8-2, 2.2.8-3), timidity:amd64 (2.13.2-41+b1, 2.14.0-3), ca-certificates:amd64 (20170717, 20180409), xserver-xorg-video-neomagic:amd64 (1:1.2.9-1+b2, 1:1.2.9-1+b3), liblouis-data:amd64 (3.5.0-3, 3.5.0-4), perl:amd64 (5.26.2-5, 5.26.2-6), imagemagick-common:amd64 (8:6.9.9.34+dfsg-3, 8:6.9.9.39+dfsg-1), libp11-kit0:amd64 (0.23.10-2, 0.23.12-2), libp11-kit0:i386 (0.23.10-2, 0.23.12-2), gnome-keyring-pkcs11:amd64 (3.28.0.2-1, 3.28.2-1), cups-bsd:amd64 (2.2.8-2, 2.2.8-3), libappstream4:amd64 (0.12.0-3, 0.12.1-1), gtk-update-icon-cache:amd64 (3.22.29-3, 3.22.30-1), dbus-user-session:amd64 (1.12.8-2, 1.12.8-3), cups-core-drivers:amd64 (2.2.8-2, 2.2.8-3), cups-daemon:amd64 (2.2.8-2, 2.2.8-3), gnupg:amd64 (2.2.7-1, 2.2.8-1), python3.6-dev:amd64 (3.6.5-9, 3.6.5-10), libcupsimage2:amd64 (2.2.8-2, 2.2.8-3), cups:amd64 (2.2.8-2, 2.2.8-3), libpango-1.0-0:amd64 (1.42.0-1, 1.42.1-1), libpango-1.0-0:i386 (1.42.0-1, 1.42.1-1), apt-config-icons:amd64 (0.12.0-3, 0.12.1-1), libcupscgi1:amd64 (2.2.8-2, 2.2.8-3), libxkbcommon0:amd64 (0.8.0-1, 0.8.0-2), cups-client:amd64 (2.2.8-2, 2.2.8-3), cups-ipp-utils:amd64 (2.2.8-2, 2.2.8-3), gpg-agent:amd64 (2.2.7-1, 2.2.8-1), libgit2-26:amd64 (0.26.0+dfsg.1-1.1+b2, 0.26.0+dfsg.1-1.2), python-minimal:amd64 (2.7.15~rc1-1, 2.7.15-3), xserver-xorg-video-mga:amd64 (1:1.6.5-1, 1:1.6.5-1+b1), python-pil:amd64 (4.3.0-2, 5.1.0-1), gpgconf:amd64 (2.2.7-1, 2.2.8-1), gpgsm:amd64 (2.2.7-1, 2.2.8-1), xserver-xorg-video-openchrome:amd64 (1:0.6.0-3, 1:0.6.0-3+b1), imagemagick-6-common:amd64 (8:6.9.9.34+dfsg-3, 8:6.9.9.39+dfsg-1)
Remove: xserver-xorg-video-r128:amd64 (6.10.2-1), mysql-client-5.6:amd64 (5.6.30-1), xserver-xorg-video-nvidia-legacy-340xx:amd64 (340.106-2), xserver-xorg-video-savage:amd64 (1:2.3.9-1), mysql-client-core-5.6:amd64 (5.6.30-1), nvidia-legacy-340xx-driver:amd64 (340.106-2)
End-Date: 2018-06-12  14:03:29

Successivamente debian mi diceva che c'erano pacchetti non più utili al che ho provato a rimuoverli

Start-Date: 2018-06-12  21:03:58
Commandline: apt autoremove
Remove: linux-headers-4.14.0-3-common-rt:amd64 (4.14.17-1), nvidia-legacy-340xx-driver-bin:amd64 (340.106-2), nvidia-support:amd64 (20151021+8), libgegl-0.3-0:amd64 (1:0.3.26-dmo2), nvidia-settings-legacy-340xx:amd64 (340.106-1), libegl1-nvidia-legacy-340xx:amd64 (340.106-2), libegl1-nvidia-legacy-340xx:i386 (340.106-2), linux-headers-4.16.0-1-amd64:amd64 (4.16.5-1), libgles1-nvidia-legacy-340xx:amd64 (340.106-2), libgles1-nvidia-legacy-340xx:i386 (340.106-2), libprocps6:amd64 (2:3.3.14-1+b1), libnvidia-legacy-340xx-eglcore:amd64 (340.106-2), libnvidia-legacy-340xx-eglcore:i386 (340.106-2), nvidia-legacy-340xx-driver-libs:amd64 (340.106-2), nvidia-legacy-340xx-driver-libs:i386 (340.106-2), libgeoclue-2-0:amd64 (2.4.10-1), nvidia-legacy-340xx-driver-libs-i386:i386 (340.106-2), libgl1-nvidia-legacy-340xx-glx:amd64 (340.106-2), libgl1-nvidia-legacy-340xx-glx:i386 (340.106-2), linux-headers-4.14.0-3-rt-amd64:amd64 (4.14.17-1), libgles2-nvidia-legacy-340xx:amd64 (340.106-2), libgles2-nvidia-legacy-340xx:i386 (340.106-2), libopenexr22:amd64 (2.2.0-11.1+b1), nvidia-persistenced:amd64 (390.25-1), libbabeltrace-ctf1:amd64 (1.5.5-1), libnvidia-legacy-340xx-glcore:amd64 (340.106-2), libnvidia-legacy-340xx-glcore:i386 (340.106-2), linux-headers-4.16.0-1-common:amd64 (4.16.5-1), linux-kbuild-4.14:amd64 (4.14.17-1), libnvidia-legacy-340xx-ml1:amd64 (340.106-2), libsmpeg0:amd64 (0.4.5+cvs20030824-7.2+b1), libnvidia-legacy-340xx-cfg1:amd64 (340.106-2), libnvidia-legacy-340xx-cfg1:i386 (340.106-2)
End-Date: 2018-06-12  21:04:45

Al tentativo di reinstallare i pacchetti nvidia-legacy-304* ma mi viene detto che è impossibile installarli

apt install nvidia-legacy-340*
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Nota, viene selezionato "nvidia-legacy-340xx-smi" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-driver-bin" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-vdpau-driver" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-alternative--kmod-alias" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-opencl-icd" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-dkms" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-driver-libs" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-driver-libs-i386" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-340.106" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-support" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-support--v1" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-driver" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-alternative" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-source" per l'espressione glob "nvidia-legacy-340*"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-dkms" al posto di "nvidia-legacy-340xx-kernel-340.106"
Nota, viene selezionato "nvidia-legacy-340xx-alternative" al posto di "nvidia-legacy-340xx-alternative--kmod-alias"
Nota, viene selezionato "nvidia-legacy-340xx-driver-libs-i386:i386" al posto di "nvidia-legacy-340xx-driver-libs-i386"
Nota, viene selezionato "nvidia-legacy-340xx-kernel-support" al posto di "nvidia-legacy-340xx-kernel-support--v1"
nvidia-legacy-340xx-alternative è già alla versione più recente (340.106-2).
È stato impostato nvidia-legacy-340xx-alternative per l'installazione manuale.
nvidia-legacy-340xx-kernel-dkms è già alla versione più recente (340.106-2).
È stato impostato nvidia-legacy-340xx-kernel-dkms per l'installazione manuale.
nvidia-legacy-340xx-kernel-support è già alla versione più recente (340.106-2).
È stato impostato nvidia-legacy-340xx-kernel-support per l'installazione manuale.
nvidia-legacy-340xx-vdpau-driver è già alla versione più recente (340.106-2).
È stato impostato nvidia-legacy-340xx-vdpau-driver per l'installazione manuale.
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:
 
I seguenti pacchetti hanno dipendenze non soddisfatte:
 nvidia-legacy-340xx-driver : Dipende: xserver-xorg-video-nvidia-legacy-340xx (= 340.106-2) ma non sta per essere installato
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2911

Troppi pacchetti tutti insieme! Credo che ti servano solo il modulo del kernel (nvidia-legacy-340xx-driver) e il driver Xorg (xserver-xorg-video-nvidia-legacy-340xx). Prova a installare solo questi e vedi che errori ti dà.

In questi casi io preferisco usare aptitude in modalità interattiva: ti dice subito se e quali conflitti ci sono.

Ritratto di Claudio
Claudio
(Guru)
Offline
Guru
Iscritto: 05/09/2007
Messaggi: 1071

Dopo aver dato il comando
# apt install xserver-xorg-video-nvidia-legacy-340xx sddm
la situazione è tornata quasi a posto.
Putroppo dovrò aprire altri topic per segnalare questi problemi.
Grazie

Notebook Hp Pavilvion dv6 i5 amd64, 4 GB Ram, scheda grafica nVidia Corporation GT216 [GeForce GT 320M] (rev a2)
Notebook Acer Asprire 5755G amd64, 8 GB Ram, scheda grafica nVidia GeForce GT 540M
Debian testing kde