Problema rete Gigabit chip r8168

11 risposte [Ultimo contenuto]
Ritratto di africano86
africano86
(Junior)
Offline
Junior
Iscritto: 01/04/2015
Messaggi: 6

Salve a tutti.
Ho un serverino con installato debian 7. Volevo creare una rete gigabit all'interno dell'ufficio ma non riesco a configurare la scheda ethernet integrata con chip r8168.
Navigo su internet ma non riesco ad impostare il collegamento a 1000 MB.
Con il comando ethtool -s eth0 speed 1000 autoneg off non ottengo alcun risultato.

Ho letto che c'era un problema con i driver ma sono riuscito a caricare il modulo giusto.
Ora non so come andare avanti.

Grazie.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Ciao,
scusa la domanda che potrà sembrarti stupida ma lo switch, o il router, a cui è collegato il PC ha le porte di rete gigabit ?
Per quanto riguarda il driver non so dirti, sul mio pc uso il driver r8169, la scheda è gigabit ma non il router che è vecchiotto e quindi la velocità è a 100MB/s.
L'output di :

sudo /sbin/ethtool eth0

dovrebbe visualizzare le modalità supportare e la velocità attuale.
Ultima nota, ogni tanto sento che qualche tecnico imputa la lentezza della rete anche a cablaggi di rete vecchi, presine difettose ecc.

Ritratto di africano86
africano86
(Junior)
Offline
Junior
Iscritto: 01/04/2015
Messaggi: 6

Ciao,
il router è un Tp link w8970 e ha le porte gigabit.
L'output di ethtool eth0 mi dice che lamia scheda supporta i 1000 ma è impostata a 100.
I cavi sono tutti 5e appena passati.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Quale driver/modulo hai che gestisce la scheda ?
Posta l'output di :

lspci -k|grep -2 Eth

hai per caso già provato a compilare i driver proprietari?

Ritratto di africano86
africano86
(Junior)
Offline
Junior
Iscritto: 01/04/2015
Messaggi: 6

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
Subsystem: Giga-byte Technology GA-EP45-DS5/GA-EG45M-DS2H Motherboard
Kernel driver in use: r8168

Si ho compilato quelli ma non è cambiato nulla.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

Quindi r8168 è il driver proprietario che hai compilato giusto ?
Se è così puoi postare l'output di :

/sbin/modinfo r8168

non è che per caso nella documentazione che accompagna il driver ci sono delle note/istruzioni particolari, tipo opzioni da passare al modulo o simili ?

Ritratto di africano86
africano86
(Junior)
Offline
Junior
Iscritto: 01/04/2015
Messaggi: 6

Citazione:

filename: /lib/modules/3.2.0-4-amd64/kernel/drivers/net/ethernet/realtek/r8168.ko
version: 8.039.00-NAPI
license: GPL
description: RealTek RTL-8168 Gigabit Ethernet driver
author: Realtek and the Linux r8168 crew
srcversion: 1ABAB2C5CDB55DDB867B0D8
alias: pci:v00001186d00004300sv00001186sd00004B10bc*sc*i*
alias: pci:v000010ECd00008168sv*sd*bc*sc*i*
depends:
vermagic: 3.2.0-4-amd64 SMP mod_unload modversions
parm: speed:force phy operation. Deprecated by ethtool (8). (ushort)
parm: duplex:force phy operation. Deprecated by ethtool (8). (int)
parm: autoneg:force phy operation. Deprecated by ethtool (8). (int)
parm: aspm:Enable ASPM. (int)
parm: s5wol:Enable Shutdown Wake On Lan. (int)
parm: rx_copybreak:Copy breakpoint for copy-only-tiny-frames (int)
parm: timer_count:Timer Interrupt Interval. (int)
parm: eee_enable:Enable Energy Efficient Ethernet. (int)
parm: debug:Debug verbosity level (0=none, ..., 16=all) (int)

Già guardato nella documentazione ma niente neanche li.

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

dal file README ha scritto:

88
89 1. Force the link status when insert the driver.
90
91 If the user is in the path ~/r8168, the link status can be forced
92 to one of the 5 modes as following command.
93
94 # insmod ./src/r8168.ko speed=SPEED_MODE duplex=DUPLEX_MODE autoneg=NWAY_OPTION
95
96 ,where
97 SPEED_MODE = 1000 for 1000Mbps
98 = 100 for 100Mbps
99 = 10 for 10Mbps
100 DUPLEX_MODE = 0 for half-duplex
101 = 1 for full-duplex
102 NWAY_OPTION = 0 for auto-negotiation off (true force)
103 = 1 for auto-negotiation on (nway force)
104 For example:
105
106 # insmod ./src/r8168.ko speed=100 duplex=0 autoneg=1

Visto che non lo menzioni te lo chiedo, hai provato a caricare il modulo con i parametri indicati nel file README, nel tuo caso usando 1000 per l'opzione speed?

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Magari prova a caricare il modulo con un valore alto di debug così da renderlo verboso, poi vedi che messaggi produce in dmesg quando cerchi di settarlo a 1000 Mb/s tramite ethtool.

Ritratto di africano86
africano86
(Junior)
Offline
Junior
Iscritto: 01/04/2015
Messaggi: 6

Si provato ma l'unica cosa che ottengo è che da full duplex mi passa ad half.

@mcortese: come faccio a modificare il debug del modulo?

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2075

africano86 ha scritto:

@mcortese: come faccio a modificare il debug del modulo?

sudo insmod r8168 debug=16

Ovviamente prima devi rimuovere l'attuale modulo caricato con rmmod.