Problema installazione driver ATI

6 risposte [Ultimo contenuto]
Ritratto di Bricco
Bricco
(Newbie)
Offline
Newbie
Iscritto: 01/05/2013
Messaggi: 4

Ciao a tutti, sono nuovo da queste parti! E siccome sono nuovo anche nel mondo linux (quindi vi chiederei di non andare troppo sul complesso, hehe), volevo chiedere a qualcuno di più esperto un aiuto per i problemi che sto avendo ad installare i driver ATI proprietari.

Sto seguendo la seguente guida: http://wiki.debian.org/ATIProprietary#Squeeze

Il problema arriva al comando:
invoke-rc.d gdm3 stop
Quando do invio, lo schermo diventa completamente nero e non viene più mostrato nulla, non riesco a procedere con l'installazione insomma. Vi dico anche che la prima volta che l'ho eseguito, c'era schermata nera con cursore lampeggiante in alto a sinistra, potevo inserire testo ma non accadeva nulla dando invio. Dalla seconda volta che ci ho riprovato (dopo riavvio) non ho più avuto la possibilità di inserire nemmeno testo, zero. Ho anche trovato in rete cose tipo premere ctrl+alt+Fx (x=1...6) ma nulla accade.

Ho un portatile Dell studio 1558, con grafica ATI mobiliy radeon HD 5470, in caso servisse Smile ah, eh debian squeeze 6.0.7.

Vi ringrazio in anticipo per l'aiuto, vorrei riuscire a installare questi driver perché con quelli open installati in automatico la ventola resta accesa continuamente, ho letto che con catalyst dovrebbe andare a posto. Un saluto Smile

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Stampati quella guida poi avvia il pc e quando sei sulla schermata in cui dovresti fare login, tieni schiacciati i tasti CTRL ed ALT e schiaccia su F1.
Ti si aprirà un terminale/shell/chiamalo_come_vuoi , inserisci le credenziali , tue o di root dipende dalla guida, e seguila.

ciao

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di Bricco
Bricco
(Newbie)
Offline
Newbie
Iscritto: 01/05/2013
Messaggi: 4

Ti ringrazio per il suggerimento, purtroppo stesso risultato di prima: schermo nero e basta.. può essere che avendo ripetuto la procedura più di una volta ci sia qualche problema anche con i driver preinstallati ora? In caso potrei anche reinstallare debian, che non mi costerebbe granché alla fine.. però se si può evitare sempre meglio ovviamente!

Ritratto di Bricco
Bricco
(Newbie)
Offline
Newbie
Iscritto: 01/05/2013
Messaggi: 4

Ho provato a reinstallare Debian, aggiunto il non-free a source.list, dopodiché ho riavviato, seguito la guida alla lettera e tutto andava bene, ma a:
modprobe -r radeon drm
mi dà l'errore che cita nella guida, al che riavvio come dice lì e quando arrivo alla schermata di login premo ctrl+alt+F1 per tornare nella shell, ma a questo punto schermo nero e non dà più segni di vita, devo spegnere il pc a forza Worried idee?

Ritratto di apofis
apofis
(Monster)
Offline
Monster
Iscritto: 19/09/2007
Messaggi: 309

Il problema è che non puoi eliminare un modulo dal kernel se questo è in uso e se hai gnome e/o kde attivo, quest'ultimo carica il modulo.

Per questo ti avevo detto di farti TUTTA la procedura direttamente dalla shell di F1!!

I@ legge Apo-genetica: chini nascia tunnu un ci mora quatratu.
II@ legge Apo-genetica: munnu e munnu un s'incontranu mai, ma cristiani e cristiani sì
III@ legge Apo-genetica: si vidi nu ghiegghiu e nu lupu, ammazza 'u ghiegghiu!

Ritratto di Bricco
Bricco
(Newbie)
Offline
Newbie
Iscritto: 01/05/2013
Messaggi: 4

Aspetta, io HO fatto tutta la procedura dalla shell. Quello che ti ho descritto mi succede facendo tutto dalla shell per l'appunto. Worried

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Bah, perché complicarsi la vita, quando c'è un pacchetto Debian bell'e pronto?

apt-get install fglrx-glx