Problema con scheda ATI solo con UBUNTU 10.10

11 risposte [Ultimo contenuto]
Ritratto di lucam
lucam
(Junior)
Offline
Junior
Iscritto: 07/03/2007
Messaggi: 44

Salve amici.
Ho un portatile acer aspire 1680 con scheda ati, e la cosa che nn mi va bene è che solo con ubuntu 10.10 non va l'acceleratore 3d.
Ma vediamo come stanno le cose.
Fino alla 10.04 bastava installare , fare gli aggiornamenti proposti, scaricare tutto dai repo ufficiale e tutto funzionava, compreso il 3d.
Ora con la 10.10 va tutto, ma non il 3d. Non ho capito niente dl perché . Qualcuno ha qualche idea?
Grazie

La mente va tenuta bene aperta, ma non troppo che il cervello non rotoli fuori.

www.scetticamente.it

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Ciao, prova ad esser piu` preciso sulle "coordinate" della tua scheda video, ATI e` un po` troppo generico Wink

Intanto ti lascio un paio di link: http://forum.ubuntu-it.org/index.php?topic=438471.0 e http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di Sarkiapone
Sarkiapone
(Webmaster)
Offline
Webmaster
Iscritto: 04/09/2004
Messaggi: 234

Se il modello del tuo portatile è questo: http://support.acer.com/acerpanam/notebook/0000/Acer/Aspire1680/Aspire1680sp2.shtml, monta una ATI Radeon Mobility 9700

Purtroppo i nuovi driver proprietari ATI non supportano più le vecchie schede e credo che la tua rientri nella categoria di quelle non supportate. Puoi provare installando i driver open.

Ritratto di lucam
lucam
(Junior)
Offline
Junior
Iscritto: 07/03/2007
Messaggi: 44

Sarkiapone ha scritto:

Se il modello del tuo portatile è questo: http://support.acer.com/acerpanam/notebook/0000/Acer/Aspire1680/Aspire1680sp2.shtml, monta una ATI Radeon Mobility 9700

Purtroppo i nuovi driver proprietari ATI non supportano più le vecchie schede e credo che la tua rientri nella categoria di quelle non supportate. Puoi provare installando i driver open.

Infatti monta una radeon mobility 9700 . e non vi è verso di sistemare le cose con gli ufficiali ati, ho provato in tutti i modi.
Per driver open cosa intendi?
Quelli da repository ?
Grazie

La mente va tenuta bene aperta, ma non troppo che il cervello non rotoli fuori.

www.scetticamente.it

Ritratto di lucam
lucam
(Junior)
Offline
Junior
Iscritto: 07/03/2007
Messaggi: 44

Da repo ho installato fglrx ei driver ati, ma non abilita il 3d. ATI Catalist CC dice
Si è verificato un problema durante l'inizializzazione del Catalyst Control Center nell'edizione Linux. Le cause potrebbero essere le seguenti.

Non è installato alcun driver grafico ATI oppure il driver ATI non funziona correttamente.
Pregasi installare il controllore ATI adatto al vostro hardware ATI o di configurarlo usando anticonfig.

La mente va tenuta bene aperta, ma non troppo che il cervello non rotoli fuori.

www.scetticamente.it

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non sono sicuro, ma credo sia una questione di firmware: io ho un problema simile con la mia Radeon 9200.

Con le distribuzioni più vecchie (ad esempio Lenny), il driver video (nel mio caso il pacchetto xserver-xorg-video-radeon) comprendeva anche del firmware non libero. Poi gli sviluppatori hanno deciso per una separazione più netta tra parti free e quelle non free, e il firmware è stato tolto dai driver video e messo in pacchetti specifici.

Nel mio caso, il firmware è stato tolto dal pacchetto xserver-xorg-video-radeon a partire dalla 6.12.2 e messo in firmware-linux-nonfree. Ecco l'estratto della descrizione:

Citazione:


* Radeon R200-family CP microcode (radeon/R200_cp.bin)

Ora, non so cosa sia successo esattamente, ma da quel momento l'accelerazione 3D (compiz) non funziona più. Mi viene spontaneo pensare che sia stato tolto dal driver più di quanto sia stato aggiunto nel binario. A suo tempo avevo aperto un thread specifico, ma finora nessuno aveva mai riportato casi simili.

Ritratto di lucam
lucam
(Junior)
Offline
Junior
Iscritto: 07/03/2007
Messaggi: 44

Una domanda a voi più esperti, ma e invece di ubuntu installo Mint avrò lo stesso peroblema esserndo una derivata?
In caso potrò anche vivere senza 3d giocare non gioco, ma mi rallenta le elaborazioni di Boinc.

La mente va tenuta bene aperta, ma non troppo che il cervello non rotoli fuori.

www.scetticamente.it

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Aggiornamento importante: l'accelerazione 3D torna se si passa radeon.modeset=1 come argomento del kernel all'avvio o, alternativamente, se si cambia il file /etc/modprobe.d/radeon-kms.conf e poi si disinserisce e ricarica i moduli radeon e drm, così:

# rmmod radeon drm
# modprobe drm
# modprobe radeon

Ovviamente il tutto va fatto da root e senza X attivo.

In altre parole, bisogna dare al kernel (e quindi ai suoi componenti aggiuntivi, tipo il firmware specifico) il pieno controllo della scheda grafica e questo si fa attivando il KMS (Kernel Mode Setting), altrimenti il controllo dell'hardware rimane al driver di X, che non ha più alcun firmware al suo interno, come ho scritto sopra. Altre info sul KMS qui.

Il problema è che compaiono artifatti strani a video, tipo delle striature verticali ogni 16 pixel. Non molto usabile! Sad Adesso proverò a "giocare" con gli altri parametri (agpmode, gartsize, dynclks...) per vedere se c'è qualcosa configurato male. Se non trovo niente mi sa che non c'è altro da fare che aprire un bug (ma su quale pacchetto? Quello del kernel? Quello del firmware? Boh...)

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Allora, se avete una Radeon 9200, i paramentri giusti da passare al kernel per attivare l'accelerazione 3D sono "radeon.modeset=1 radeon.agpmode=-1" (il primo attiva il KMS, il secondo forza la scheda in modalità PCI).

Per chi non ha un kernel compilato a mano, e ha dunque il driver radeon sotto forma di modulo, si possono mettere questi parametri nel file /etc/modprobe.d/radeon-kms.conf:

options radeon modeset=1
options radeon agpmode=-1

Ritratto di AS
AS
(Junior)
Offline
Junior
Iscritto: 05/10/2011
Messaggi: 37

Riprendo a distanza di un anno (sic!) questa discussione; mi sono accorto che anch'io ho il file /etc/modprobe.d/radeon-kms.conf ma ha presente solo la riga options radeon modeset=1
Prima di fare modifiche vorrei sapere se possibile cosa significa

Citazione:

il secondo forza la scheda in modalità PCI

. Sono affezionato al muletto (come lo chiamo io...) e non vorrei farlo esplodere! Angel

Se la casa del tuo vicino brucia, la cosa ti riguarda e parecchio...

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Il parametro modeset non fa altro che attivare il KMS (Kernel Mode Setting) cioè è il kernel ad avere l'onere di configurare il modo video (storicamente, invece, era il server X a farlo). Questo, tra altre cose, permette l'accelerazione 3D.

Il parametro agpmode imposta la velocità di trasferimento dati tra scheda madre e scheda video e va da 1x a 8x. Teoricamente, tutte le schede che supportano lo standard AGP versione 3.0 dovrebbero reggere l'8x, ma in pratica dipende moltissimo dalla combinazione di scheda video con scheda madre: io ad esempio devo usare 4, ma non c'è una ricetta unica che vale per tutti. Impostando il parametro a -1, si regola la velocità a quella delle porte PCI (133 MB/s), quindi ancora più lenta dello standard AGP base (definito 1x).

Dovrai sperimentare un po' per trovare il settaggio ottimale per te. Il problema è che i parametri non possono essere cambiati una volta caricato il modulo, quindi non hai altra scelta che rimuoverlo e ricaricarlo ogni volta. Ma attenzione: non appena lo rimuovi, il kernel perde il controllo della scheda video, quindi non può farti vedere cosa scrivi ecc. Ti consiglio di avviare in modalità single user e dare comandi come il seguente:

rmmod -f radeon; sleep 1; modprobe radeon agpmode=8
cambiando via via l'8 con 4, 2, 1, -1 fino a trovare una grafica priva di difetti.