Problema Clickpad HP Pavilion dv6 3030

11 risposte [Ultimo contenuto]
Ritratto di mikyago
mikyago
(Junior)
Offline
Junior
Iscritto: 17/03/2011
Messaggi: 14

Buon giorno a tutti.
Sono nuovo del forum e nuovo del mondo Debian, che ho appena finito di installare!

Come da oggetto ho un Hp Pavilion dv6 3030sl. Come alcuni di voi sapranno questa serie di portatili dell'Hp ha il clickpad, non un semplice touchpad.
Appena finita l'installazione di Debian 6, con entusiasmo effettuo il primo log in, ma con dispiacere noto che anche in Debian, come in Ubuntu d'altronde, il clickpad non viene riconosciuto e da seri problemi all'utilizzo. Cioè non è supportato il multitouch e soprattutto il 'click sinistro' viene rilevato solo con il click 'fisico' del tasto, non viene rilevato tramite una pressione in qualsiasi punto del clickpad, come avviene anche per i touchpad.

In Ubuntu una soluzione 'totale' non è stata trovata, ma alcune di compromesso che rende utilizzabile il pc si, tramite gli ultimi aggiornamenti o tramite guide come questa:
http://bigbrovar.aoizora.org/index.php/2011/01/12/enable-multitouch-support-for-clickpad-on-ubuntu-10-10/

La mia domanda da totale 'nuovo arrivato' nel mondo debian è:
-qualcuno ha lo stesso problema? c'è qualche pacchetto da installare o qualche guida?

Purtroppo ora sto scrivendo da Ubuntu, spero presto di avere vostre risposte per poter rendere utilizzabile il mio pc con Debian e scrivervi da li le prossime volte!

"Ubuntu è un'antica parola africana che significa: non so usare Debian", da nuovo utente di Debian allora devo ammetterlo: "Ubuntu!"

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Credo proprio che tu possa trovare qui le informazione necessarie.

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di mikyago
mikyago
(Junior)
Offline
Junior
Iscritto: 17/03/2011
Messaggi: 14

Ciao Marco, ti ringrazio innanzitutto per la risposta!
Penso davvero che in quella guida ci siano tutte le info necessarie per riuscire a trovare una soluzione, nel frattempo sono comunque riuscito a trovare un buon compromesso di utilizzo tramite questo altro topic:

http://forums.debian.net/viewtopic.php?f=5&t=61055&hilit=clickpad

Penso che sia meno completa ovviamente della guida che mi hai postato tu, e per questo ti ringrazio, ma permette comunque di abilitare il pannello delle opzioni del touchpad che è abbastanza completo e funzionale.
Ora ho altri problemi da risolvere prima di poter usare debian come so ufficiale (penso che dovrò chiedervi aiuto in un altro topic a proposito! =S), poi quando sarà tutto apposto magari sfrutterò anche la tua guida per mettere a posto i dettagli! Wink

Grazie ancora! Smile

"Ubuntu è un'antica parola africana che significa: non so usare Debian", da nuovo utente di Debian allora devo ammetterlo: "Ubuntu!"

Ritratto di Sarkiapone
Sarkiapone
(Webmaster)
Offline
Webmaster
Iscritto: 04/09/2004
Messaggi: 234

L'importante è il risultato Wink Puoi impostare il post come risolto? Per farlo vai su "Modifica" e poi dal menù a tendin stato imposti "Risolto"

Grazie Smile

Ritratto di mikyago
mikyago
(Junior)
Offline
Junior
Iscritto: 17/03/2011
Messaggi: 14

Mi scuso per la mancanza! Smile

"Ubuntu è un'antica parola africana che significa: non so usare Debian", da nuovo utente di Debian allora devo ammetterlo: "Ubuntu!"

Ritratto di mikyago
mikyago
(Junior)
Offline
Junior
Iscritto: 17/03/2011
Messaggi: 14

Dopo qualche giorno per valutare mi sono deciso a tornare a GNOME. Per questo ho rimodificato il topic come 'Non Risoloto', in effetti il problema è tornato alla sua forma originale come si poteva facilmente prevedere purtroppo.
MI sono messo quindi sulla interessantissima guida postata da marcosan. Purtroppo però, causa la mia ignoranza probabilmente, non sono riuscito a venirne fuori e quindi sono di nuovo qui a chiedervi qualche consiglio.

Per specificare meglio la mia situazione, posto i risultati di alcuni comandi presi da quella guida.

Il primo per l'identificazione del tipo ti touchoad:

root@Peter:/home/mikyago# egrep -i 'synap|alps|etps' /proc/bus/input/devices
N: Name="SynPS/2 Synaptics TouchPad"

Continuo a leggere la guida. Non sapendo se avessi un xorg.conf, provo il comando:

root@Peter:/home/mikyago# Xorg -configure
 
Fatal server error:
Server is already active for display 0
	If this server is no longer running, remove /tmp/.X0-lock
	and start again.
 
 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 

Il che mi fa pensare, ma non ne sono sicuro, chiedo quindi a voi, che non abbia tale file cosi passo al comando:

root@Peter:/home/mikyago# Xorg :1 -configure
 
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 x86_64 Debian
Current Operating System: Linux Peter 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=81e6d85d-9ddc-4899-a5fa-e36eea5e61dd ro quiet
Build Date: 12 January 2011  02:59:50AM
xorg-server 2:1.7.7-11 (Cyril Brulebois <kibi@debian.org>) 
Current version of pixman: 0.16.4
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Thu Mar 24 00:49:05 2011
List of video drivers:
	nouveau
	mach64
	sis
	savage
	siliconmotion
	cirrus
	radeon
	openchrome
	ark
	s3
	nv
	apm
	vmware
	i128
	mga
	s3virge
	rendition
	sisusb
	vmwlegacy
	voodoo
	tdfx
	trident
	ati
	intel
	neomagic
	chips
	r128
	tseng
	fbdev
	vesa
vmware: Please ignore above "FATAL: Module vmwgfx not found."
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] No DRICreatePCIBusID symbol, no kernel modesetting.
 
 
Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.
 
Your xorg.conf file is /root/xorg.conf.new
 
To test the server, run 'X -config /root/xorg.conf.new'

Purtroppo poi mi perdo nella guida, almeno fino al punto in cui posso leggere:

You can check which buttons are reported in Xorg.0.log to see if you have multitouch. A touchpad without this capability reports only the usual "left", "right" and "middle" buttons:

Quindi provo il comando:

root@Peter:~# grep "TouchPad: buttons:" /var/log/Xorg.0.log
(II) SynPS/2 Synaptics TouchPad: buttons: left

Qui, come temevo e prevedevo, mi pare di capire che l'unico tasto riconosciuto sia il sinistro. Cosa che coincide con l'attuale utilizzo che posso fare del mio touchpad! Infatti contrariamente la risposta sarebbe dovuta essere, secondo la guida:

$ grep "TouchPad: buttons:" /var/log/Xorg.0.log
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle double triple

Ma sono sicuro che il mio touchpad supporta queste potenzialità in quanto funzionano in ubuntu o w7.
Purtroppo poi non riesco a trovare la via per sfruttare le tante informazioni presenti nella guida in modo utile al mio caso. Dai risultati che ho postato avere per caso qualche suggerimento? C'è qualche altro comando che posso usare per aiutarvi a capire meglio la mia situazione?

In ogni modo vi ringrazio per la vostra attenzione e continuo imperterrito a provare. Forse è proprio questo che ti insegna Debian, no? Smile
A presto! Smile

"Ubuntu è un'antica parola africana che significa: non so usare Debian", da nuovo utente di Debian allora devo ammetterlo: "Ubuntu!"

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 391

Quello che consiglio a tutti/e e sempre, è di testare il proprio pc prima con una versione Live, scoprire eventuali bugs e cercare se ci sono soluzioni.

Purtroppo il mondo è composto in base al lucro e a loro non interessa se a te gira o no Linux...

Comunque può essere che sia stato risolto, ma sia ancora non tradotto, per cui chi si è trovato di fronte alla soluzione non ha capito ed ha "rimandato". Ti consiglio di cercare su Google, ma usando termini in inglese . Qualcosa come "HP Pavilion dv6 3030 clickpad not working on Ubuntu".

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Io proverei

$ synclient TapButton1=1 TapButton2=3

Dovrebbe attivare il "tap" con un dito come un click del tasto sinistro, e il "tap" con due dita come un click del tasto destro. Alternativamente, il comando seguente mappa i "tap" a 1, 2 e 3 dita come click del sinistro, centrale e destro, rispettivamente:

$ synclient TapButton1=1 TapButton2=2 TapButton3=3

Se funziona, per rendere il tutto persistente, creati un file "desktop" come il seguente e salvalo come .config/autostart/AbilitaTap.desktop

[Desktop Entry]
Name=AbilitaTap
Comment=Dice a Synaptics di riconoscere i tap sul touchpad
Exec=synclient TapButton1=1 TapButton2=3
Type=Application

Ritratto di mikyago
mikyago
(Junior)
Offline
Junior
Iscritto: 17/03/2011
Messaggi: 14

Ciao Mcortese, ti ringrazio per la risposta!
Ho provato i due comandi, ma non ho avuto risultati.
Dando il comando come root, ricevo il seguente messaggio di risposta:

root@Peter:/home/mikyago# synclient TapButton1=1 TapButton2=3
No protocol specified
Failed to connect to X Server.

Mentre come utente normale il comando sembra andare a buon fine, ma non genera il risultato sperato.
Il problema potrebbe risiedere nel fatto che è un comando da lanciare come root? Smile

"Ubuntu è un'antica parola africana che significa: non so usare Debian", da nuovo utente di Debian allora devo ammetterlo: "Ubuntu!"

Ritratto di marcosan
marcosan
(Collaboratore)
Offline
Collaboratore
Iscritto: 16/05/2005
Messaggi: 896

Ciao, torniamo al punto di partenza...hai il file /etc/X11/xorg.conf? Se si copialo nel post! Hai una cartella /etc/X11/xorg.conf.d? Se si copia l'elenco dei file contenuti nel post!

Infine tornando alla guida prova a spiegarci cosa non ti e` chiaro...dire "non la capisco" non basta Wink Prova a dirci "il comando pippo alla della sezione paperino mi da questo errore..." sara` piu` facile darti una mano!

Ciao,
Marco

"La matematica e' l'arte di dare lo stesso nome a cose diverse."
H.Poincare (1854-1912).

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Il comando synclient è da dare come utente (infatti ho usato $ come prompt, non #). Comunque se non ti funziona, come non detto.