Problema audio

11 risposte [Ultimo contenuto]
Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Ciao a tutti,
innanzi tutto mi scuso se ho sbagliato a scegliere la sezione, ma credo sia un problema di driver.
Il problema è questo: ho l'audio perfettamente funzionante sulla mia debian wheezy solo con un'applicazione alla volta. Se sto usando vlc non ho audio su flashplayer, per esempio. E se sto usando vlc non ho audio su altre applicazioni. In pratica l'audio funziona (e anche bene) ma solo con un'applicazione alla volta non importa quale esse siano.
lspci
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
l'hardware sembra configurato bene, 5.1 test funziona alla grande anche alsamixer è ok.
Quanche suggerimento?
Grazie in anticipo.

Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Sono risucito a trovare questo:

http://alsa.opensrc.org/AlsaSharing

ma nn va...
Qualche suggerimento?

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

Vedi se risolvi seguendo queste indicazioni.

Ciao, Franco

Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Ciao e grazie della risposta.
Quella guida che mi hai postato non è altro che per installare alsa cosa che io ho già in più è datatissima non vorrei fare sciocchezze e peggiorare la situazione...

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

Ma devi veramente ascoltare l'output di due applicazioni audio sulla stessa uscita?
Il link della guida che ti ho segnalato parla di settare il mixer nella GUI, che di certo tu usi dalle applicazioni che citi, in particolare:

Citazione:

Wrong mixer in use: Sometimes the volume control chooses the OSS mixer if the compatibility module is loaded. You may need to right click on the volume control applet in your gnome-panel and go to the preferences and change the device to the one called Alsa Mixer. The same applies to the gnome volume control program.

Mixer doesn't seem to work: The HD Audio standard has many output channels. As a result, the correct volume sliders might not be visible. Enable the volume sliders through Edit->Preferences in gnome volume control.


Non mi sembrano manovre alle quali poi non porvi rimedio.

Ciao, Franco

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 16/05/2011
Messaggi: 129

Hai installato pulseaudio?

ciao,
mandian

Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Scusa ma che dici? Ma ti sembra corretto che vada solo un audio alla volta? E come ho spigato ampiamente sopra il problema si verifica con tutte le applicazioni che usano l'audio. Io uso spesso audacity per editare file audio che faccio registrando con vari strumenti musicali e non posso farlo. Ti sembra normale? mah!!!

Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Ciao,
si l'ho installato e ho fatto diverse prove ma senza riuscire a risolvere. Mi sembra strano però perchè, dato che usavo (per tantissimi anni circa otto) una ubuntu non ho mai avuto questo problema con i diversi hardware che via via si sono succeduti. Confused

Ritratto di mandian
mandian
(Geek)
Offline
Geek
Iscritto: 16/05/2011
Messaggi: 129

È normale che ALSA permetta una sorgente audio alla volta ed è proprio per questo che si usa pulseaudio, il cui compito è proprio quello di prendere uno o più sorgenti più flussi alla volta e passarli al driver ALSA come se fosse un flusso unico (sto semplificando un po'). Per questo mi pareva che pulseaudio non fosse istallato o ben configurato (ma di solito si configura da solo). Altrimenti non saprei ...

ciao,
mandian

Ritratto di frank67
frank67
(Monster)
Offline
Monster
Iscritto: 10/07/2013
Messaggi: 487

MixEnd ha scritto:

Scusa ma che dici? Ma ti sembra corretto che vada solo un audio alla volta? E come ho spigato ampiamente sopra il problema si verifica con tutte le applicazioni che usano l'audio. Io uso spesso audacity per editare file audio che faccio registrando con vari strumenti musicali e non posso farlo. Ti sembra normale? mah!!!


OK scusa ho detto una cavolata, visto che pensi che sia un problema hardware cosa riporta l'output di:
~$ lspci -k

Ciao, Franco

Ritratto di MixEnd
MixEnd
(Junior)
Offline
Junior
Iscritto: 21/10/2011
Messaggi: 17

Innanzi tutto ancora grazie a tutti per l'interessamento. Posto qui di seguito output di lspci -K che è chilometrico quindi metto solo quello relativo alla scheda audio:

	Subsystem: ASUSTeK Computer Inc. P5Q Deluxe Motherboard
	Kernel driver in use: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1

Si, so che pulse serve proprio a quello ma sono un po' a digiuno in materia... ho sempre fatto le configurazioni lasciando, appunto, all'autoconfigurazione il grosso del lavoro. Non mi arrendo perchè è veramente fastidioso come problema...