Nvidia su Jessie

11 risposte [Ultimo contenuto]
Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

Ciao a tutti,
ho provato ad istallare i driver Nvidia sulla Jessi nuova nuova e fresca di installazione.

E' risultato in un fallimento.

Seguento l'installazione con la debian way, l'unico risultato che ho ottenuto è stato quello di non avviare più l'interfaccia grafica.

Il file Xorg.conf non esiste, ho quindi istallato il pacchetto nvidia-config che mi ha creato lui un xorg.conf, ma sempre con lo stesso risultato... ho googlato un po' qui e li ma senza nessun risultato.

Credo che il problema siano i noveau, ma da quanto avevo letto l'istallazione dei driver nvidia avrebbe dovuto metterli in blacklist...

Qualcuno sa aiutarmi?

Grazie mille

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Ciao,
posta tutti i comandi che hai passato al terminale e il contenuto di xorg.conf.

hai installato il linux-headers relativo al tuo kernel?

.theShort Big Grin

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

E poi: che errore dà? La console si avvia o neanche quella? Un lsmod non guasterebbe, e neanche sapere che scheda video hai (lspci)...

Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

ciao! per cominciare grazie mille per la pazienza Smile
i comandi per istallare sono questi:

# aptitude update
# aptitude -r install linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') nvidia-kernel-dkms

poi ho dato:

# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "nvidia"\nEndSection' > /etc/X11/xorg.conf.d/20-nvidia.conf

la scheda video è una nvidia 650m (non ho il pc ora Laughing

xorg.conf non esisteva proprio... se provavo a dare Xorg -config mi dava un errore tipo "two monitor"qualcosa...
il sistema si avvia, ma si ferma prima di caricare login, praticamente posso lavorare solo da riga di comando.

grazie ancora

Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

Mi viene un dubbio...
Spulciando internet, noto spesso che viene citato un software chiamato BUMBELBEE... non è che necessito per forza quello?

P.S.
se serve, io non uso gnome, ma kade.

Grazie ancora

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 596

Appena puoi posta il contenuto del tuo xorg.conf.

Bumbelbee ti serve se hai un portatile con due schede grafiche con diverso consumo. In particolare serve per passare da una scheda all'altra per ottimizzare i consumo durante la sessione di lavoro.
E' il tuo caso? Che pc hai? che scheda grafica hai?

Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

Ecco, mi sa che allora fa al caso mio...

Ho un notebook ekoore:
Cpu: Intel i5 3210M @ 2.5GHz Chipset: Intel HM76
Memoria RAM: 4/8GB DDR3
Hard Disk: 500GB/1TB SATA2
Scheda Video: Nvidia GT650M 2GB DDR3

E non sono sicuro, ma credo sia presente anche la scheda derivante dal chipset dell'intel...

Appena mi è possibile posto il resto, intanto grazie mille!

Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

Allora,
dopo altri tentativi di istallare questo o quello ho preferito ricominciare da 0 e reinstallare tutto quanto. Ho l'istallazione bella pulita con KDE e per ora funziona tutto. Appena posso posto il risultato del lspci, che in effetti, ora restituisce due schede video, l'nvidia 650M e una intell (integrata). Prima di dover compromettere nuovamente l'istallazione vorrei procedere con passo cauto.

L'obbiettivo è quello di istallare Steam e poi vari giochi, quindi pensavo di sfruttare l'accelerazione grafica dell'Nvidia. Il portatile principalmente lo uso solo per svago.

Come mi consigliate di procedere?
Mi butto nei vari Bumblebee per disattivare la scheda integrata, oppure riprovo con i driver dell'Nvidia?
Oppure ancora uso i Noveau (magari, se possibile, attivando l'accelerazione grafica su quelli)?

Grazie ancora a tutti

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Non hai molta scelta: senza Bumblebee puoi usare una sola scheda per volta: o quella integrata che non ha accelerazione 3D, o quella discreta, che però non ha uscite video (quindi la scheda lavora ma lo schermo rimane nero).

Ritratto di haxar
haxar
(Junior)
Offline
Junior
Iscritto: 08/03/2006
Messaggi: 48

Ciao!
mi sono di nuovo bloccato con l'istallazione:
ho seguito la guida della debian wiki per istallare bumblebee... i passaggi seguiti sino adesso sono:

sudo apt-get install build-essential pkg-config help2man libx11-dev libbsd-dev libglib2.0-de
 
sudo apt-get install -t squeeze-backports nvidia-glx linux-headers-$(uname -r) nvidia-kernel-dkms
 
sudo update-alternatives --set glx /usr/lib/mesa-diverted
 
sudo apt-get install bumblebee-nvidia primus

ma quando devo configurare:

./configure CONF_LDPATH_NVIDIA=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib32/nvidia   CONF_MODPATH_NVIDIA=/usr/lib/nvidia,/usr/lib/xorg/modules --sysconfdir=/etc

ho l'errore

bash: ./configure: File o directory non esistente

cosa sbaglio? Tongue
grazie!

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1453

Perché vuoi farti male da solo ?

Nel wiki di Debian è riportato:

Citazione:

Installazione

Dal repository

Gli utenti di Sid e Jessie possono installare tutto direttamente dai repository ufficiali.

Per gli utenti che vogliono usare il nuovo driver libero nouveau::

sudo apt-get install bumblebee primus

Per gli utenti che vogliono usare il driver nvidia proprietario:

sudo apt-get install bumblebee-nvidia primus