Impossibile modificare velocità, accelerazione e scroll del puntatore

3 risposte [Ultimo contenuto]
Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Salve, ho Debian Stretch con XFCE e per quanto ci abbia provato non sono riuscito a trovare un modo per modificare in maniera pratica i parametri di mouse e touchpad, nello specifico nelle impostazioni di sistema non c'è nulla per modificare lo scroll, e ho ovviato con imwheel, però per quanto riguarda velocità ed accelerazione, ogni modifica apportata non mostra alcuna differenza.
Ho cercato praticamente ovunque ma sono arrivato ad un punto cieco.

QUI al #10 ho trovato una soluzione che ha funzionato per alcuni utenti (anche su un altro forum inglese) e anche senza installare evdev ma usando synaptics, ma in simulazione ho visto che eliminare xserver-xorg-input-libinput avrebbe comportato l'eliminazione di mezzo sistema, non ho davvero spiegazione, mi farebbe anche eliminare libreoffice e vlc tanto per dirne una, se qualcuno sapesse il perché sarei curioso di saperlo.

Ho provato con xset, e a differenza di molti altri utenti non ho notato NESSUNA differenza nel cursore.

L'unico che ha ottenuto qualche risultato è stato xinput, che usando i driver libinput mi permetteva di modificare solo accelerazione e non velocità o scroll.
Ho studiato tutto il driver libinput e quello synaptics, e vedendo i problemi che ci sono ancora con libinput ho provato ad usare synaptics, pur aumentando la sua priorità nei file di configurazione xinput continua ad usare i driver libinput, magari mi sta sfuggendo qualcosa (?), anche volendo accontentarmi di intervenire solo sull'accelerazione ho provato a modificare il file di configurazione per far sì che la modifica fosse permanente, in questo modo (provando con il touchpad):

...
Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
	# Option "libinput Accel Speed" 1
EndSection
...

Ho aggiunto la linea che ora è commentata, commentata perché dopo la modifica al login non potevo più accedere all'interfaccia grafica.

Si accetta qualunque suggerimento, grazie in anticipo.

Ritratto di 2019
2019
(Newbie)
Offline
Newbie
Iscritto: 15/08/2019
Messaggi: 2

Mi accodo.
Anche io ho lo stesso problema, però uso LXDE.
Sembra che non ci sia alcun modo di rallentare il puntatore per fare lavori di precisione Crying

L'unico modo per modificare leggermente la velocità è cambiare la marca del mouse! Ma possibile che non esista un driver che funzioni?
Non vorrei dover passare a Gnome o KDE per uno stupido problema come questo.

Ritratto di 2019
2019
(Newbie)
Offline
Newbie
Iscritto: 15/08/2019
Messaggi: 2

Problema risolto:
ho capito che non è necessario alcun driver...
Bisogna solamente acquistare un mouse che abbia diverse velocità ovvero diversi DPI (punti per pollice). Dovrebbe essere riportato sulla confezione.

Io ho scelto un mouse semplice semplice per videogiocatori e il sistema operativo lo ha riconosciuto immediatamente senza problemi. La velocità si seleziona sul pulsante che sta in alto, prima della rotella.

L'accelerazione invece non si può modificare, tuttavia quella di default è accettabile.

Ritratto di ale.a
ale.a
(Geek)
Offline
Geek
Iscritto: 12/03/2017
Messaggi: 80

Grazie della risposta, sì è possibile ovviare con mouse che permettano di modificare il DPI, tuttavia questo workaround è ben lontano dall'essere la soluzione al problema di base.