Errore Ati 8.1+Lenny

5 risposte [Ultimo contenuto]
Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 82

Sto Seguendo questa guida: http://wiki.cchtml.com/index.php/Debian_Installation_Guide#Method_2:_Generating.2FInstalling_Debian_packages_from_the_ATI_installer
Con essa son riuscito ad installare tutti i driver ati. Ma adesso che sto reinstallando il sistema (con sources.list LENNY), mi da questo errore:

./packages/Debian/ati-packager.sh --buildpkg lenny
Package build failed!
Package build utility output:
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 8.452.1-1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
debian/rules build
dpkg-buildpackage: host architecture i386
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
mkdir -p usr/share/doc/fglrx; \
mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
usr/X11R6/lib \
usr/X11R6/lib64 \
usr/share usr/src -type f | xargs chmod -x
find: usr/X11R6/lib64: No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then \
chmod 755 etc/ati ; \
chmod 644 etc/ati/* ; \
chmod a+x etc/ati/*.sh ; \
fi
if [ -f debian/fglrx.default ]; then \
mv -v debian/fglrx.default debian/fglrx; \
fi
`debian/fglrx.default' -> `debian/fglrx'
debian/rules binary
dh_testdir
# move licenses away from binary dir
if [ ! -d usr/share/doc/fglrx ]; then \
mkdir -p usr/share/doc/fglrx; \
mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
fi
# set executable on user apps
find usr/X11R6/bin -type f | xargs chmod a+x
# remove exec bit from files that don't deserve it
find usr/X11R6/include \
usr/X11R6/lib \
usr/X11R6/lib64 \
usr/share usr/src -type f | xargs chmod -x
find: usr/X11R6/lib64: No such file or directory
find lib -not -name "*.sh" -type f | xargs chmod -x
find lib -name "*.sh" -type f | xargs chmod +x
# set proper permissions on /etc files
if [ -d etc/ati ]; then \
chmod 755 etc/ati ; \
chmod 644 etc/ati/* ; \
chmod a+x etc/ati/*.sh ; \
fi
if [ -f debian/fglrx.default ]; then \
mv -v debian/fglrx.default debian/fglrx; \
fi
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
# Create the directories to install into
dh_installdirs -pfglrx-driver \
usr \
usr/lib/xorg \
usr/lib/xorg/modules \
usr/lib/dri \
usr/bin \
usr/sbin \
etc/acpi \
etc/acpi/events \
etc/default \
etc/X11/Xsession.d
dh_installdirs -pfglrx-driver-dev \
usr \
usr/include \
usr/lib
dh_installdirs -pfglrx-kernel-src \
usr/src/modules/fglrx \
usr/src/modules/fglrx/debian
dh_installdirs -A -pfglrx-amdcccle \
usr \
usr/bin \
usr/share \
usr/share/applnk \
usr/share/applications \
usr/share/icons \
usr/share/pixmaps
dh_installdirs -p \
usr/src
dh_install
dh_install -pfglrx-driver "usr/X11R6/bin/fgl*" "usr/bin"
dh_install -pfglrx-driver "usr/X11R6/bin/aticonfig" "usr/bin"
dh_install -pfglrx-driver "usr/sbin/atieventsd" "usr/sbin"
dh_installman -pfglrx-driver "usr/share/man/man8/atieventsd.8"
# amd64 needs some library redirection
dh_install -pfglrx-driver "usr/X11R6/lib/*.so*" "usr/lib"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/dri" "usr/lib"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/linux" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/drivers" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/*.so" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "usr/X11R6/lib/modules/*.a" "usr/lib/xorg/modules"
dh_install -pfglrx-driver "etc/fglrx*" "etc"
dh_install -pfglrx-driver "etc/ati" "etc"
dh_install -pfglrx-driver "debian/70fglrx" "etc/X11/Xsession.d"
dh_install -pfglrx-driver "debian/fglrx-powermode.sh" "etc/acpi"
dh_install -pfglrx-driver "debian/fglrx-*-aticonfig" "etc/acpi/events"
dh_install -pfglrx-driver "debian/fglrx" "etc/default"
dh_installinit -pfglrx-driver --name="atieventsd"
# create symlinks to shared libs
dh_link -pfglrx-driver "usr/lib/libGL.so.1.2" "usr/lib/libGL.so.1"
dh_install -pfglrx-driver-dev "usr/X11R6/lib/*.a" "usr/lib"
dh_install -pfglrx-driver-dev "usr/X11R6/include/*" "usr/include"
dh_install -pfglrx-driver-dev "usr/include/*" "usr/include"
dh_install -pfglrx-kernel-src \
lib/modules/fglrx/build_mod/*.c \
lib/modules/fglrx/build_mod/*.h \
lib/modules/fglrx/build_mod/*.sh \
lib/modules/fglrx/build_mod/lib* \
lib/modules/fglrx/build_mod/2.6.x/Makefile \
usr/src/modules/fglrx
dh_install -pfglrx-kernel-src "debian/changelog" "usr/src/modules/fglrx/debian"
dh_install -pfglrx-kernel-src \
debian/copyright \
debian/compat \
module/rules \
module/control.template \
module/dirs.template \
module/postinst \
usr/src/modules/fglrx/debian
(cd debian/fglrx-kernel-src/usr/src \
&& chown -R root:src modules \
&& tar -jcf fglrx.tar.bz2 modules \
&& rm -rf modules)
# control panel package
dh_install -A -pfglrx-amdcccle "usr/X11R6/bin/amdcccle" "usr/bin"
dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/icons"
dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/pixmaps"
dh_install -A -pfglrx-amdcccle "debian/amdcccle.desktop" "usr/share/applications"
dh_install -A -pfglrx-amdcccle "debian/amdcccle.kdelnk" "usr/share/applnk"
dh_install -A -pfglrx-amdcccle "usr/share/ati" "usr/share"
dh_desktop -pfglrx-amdcccle
dh_installdocs
dh_installdocs -pfglrx-driver usr/share/doc/fglrx/*
#dh_installchangelogs
dh_link
dh_strip
dh_compress
dh_makeshlibs
dh_installdeb
LD_PRELOAD= dh_shlibdeps --exclude=emul
dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libpthread.so.0 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with librt.so.1 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libm.so.6 (it uses none of its symbols).
dpkg-shlibdeps: warning: debian/fglrx-driver/usr/bin/fglrxinfo shouldn't be linked with libXext.so.6 (it uses none of its symbols).
dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
dh_shlibdeps: command returned error code 512
make: *** [binary] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2

Spero riuscirete ad aiutarmi... Grazie

Ritratto di linuxnic
linuxnic
(Monster)
Offline
Monster
Iscritto: 10/07/2005
Messaggi: 241

Io su Etch i driver Ati li installo tranquillamente con i seguenti comandi:
Quote:

chmod +x ati-driver-installerxxxxxxxx.run
sh ./ati-driver-installerxxxxxxxx.run

seguo tutta la procedura grafica senza generare i pacchetti per Etch.
Poi alla fine eseguo
Quote:

aticonfig --initial
aticonfig --overlay-type=Xv

Sia sul linux-image-2.6.18 di default che su vanilla ricompilati.
Ciao

-= Nic =-
Amico di Emergency_2009
Linux registered user # 380338
Linux registered machine # 283289

Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 82

Ho seguito la tua guida... ma ho avuto questi errori. Consigli?

@:~$ aticonfig --initial
Found fglrx primary device section
Nothing to do, terminating.
@:~$ aticonfig --overlay-type=Xv
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-1
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

Stesso errore anche con gli 8.42.3.
Grazie

Ritratto di linuxnic
linuxnic
(Monster)
Offline
Monster
Iscritto: 10/07/2005
Messaggi: 241

Quote:

aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.

A me la riga sopra non appare mai,mentre tutto il resto che hai postato si ma comunque i driver si installano...........scusa una cosa ma tu l'installazione la fai da root o da utente normale?
Ciao

-= Nic =-
Amico di Emergency_2009
Linux registered user # 380338
Linux registered machine # 283289

Ritratto di John_Tempesta
John_Tempesta
(Geek)
Offline
Geek
Iscritto: 17/11/2007
Messaggi: 82

Ho risolto il problema aggiornando la mia distro da etch a lenny! (apt-get dist-upgrade). Credo che era dovuto a mancanza di librerie importanti.

Ma se io volessi che i miei driver si aggiornassero da terminale con i soliti due comandi (apt-get update e apt-get upgrade), cosa devo aggiungere nella mia sources.list?

Grazie

Ritratto di linuxnic
linuxnic
(Monster)
Offline
Monster
Iscritto: 10/07/2005
Messaggi: 241

Quote:

John_Tempesta ha scritto:
Ho risolto il problema aggiornando la mia distro da etch a lenny! (apt-get dist-upgrade). Credo che era dovuto a mancanza di librerie importanti.

Ma se io volessi che i miei driver si aggiornassero da terminale con i soliti due comandi (apt-get update e apt-get upgrade), cosa devo aggiungere nella mia sources.list?

Grazie

Se la tua scheda è supportata ti servono i driver xserver-xorg-video-ati presenti nei repo.
Ciao

-= Nic =-
Amico di Emergency_2009
Linux registered user # 380338
Linux registered machine # 283289