Driver fglrx e GNOME 3

1 risposta [Ultimo contenuto]
Ritratto di francst
francst
(Newbie)
Offline
Newbie
Iscritto: 26/03/2015
Messaggi: 1

Salve a tutti.
Qualche giorno fa ho trovato un vecchio portatile e ho deciso di divertirmici un po'; ho installato Wheezy, dopo anni in cui non ho messo mano su Debian (l'ultima versione che avevo usato era Lenny diventata stable da poco, quindi si parla di parecchi anni fa).
Mi sono accorto, però, che è un po' come andare in bicicletta: certe cose te le ricordi, qualcos'altro lo cerchi, se non sai leggi le guide, se non ci sono guide chiedi nei forum.

Ricordi a parte, ho due problemi diversi ma correlati: il primo è che, installando i driver proprietari ATI direttamente dai repo - fglrx - mi è saltata la visualizzazione di GNOME 3.
All'avvio, dopo aver invocato un variopinto numero di divinità a causa della scoperta che non esiste più xorg.conf di default, mi è comparsa una finestra che diceva che i driver video in uso non erano compatibili con l'ambiente grafico precedente.
C'è un modo per tornare a far funzionare il tutto?

Il secondo, invece, riguarda la scoperta che allo stato attuale mi ritrovo con due driver grafici in uso:

sudo lshw -c display | grep driver
       configuration: driver=fglrx_pci latency=0
       configuration: driver=i915 latency=0

...anche se non so, poi, se sono effettivamente in uso. Se do lsmod, il risultato è:

lsmod | grep video
uvcvideo               57744  0 
videodev               70889  1 uvcvideo
v4l2_compat_ioctl32    16655  1 videodev
media                  18148  2 videodev,uvcvideo
i2c_core               23876  6 i2c_algo_bit,drm,drm_kms_helper,i915,i2c_i801,videodev
usbcore               128741  3 ehci_hcd,uvcvideo
[b]video                  17683  1 i915[/b]
thermal_sys            18040  3 thermal,video,processor

Le schede video del notebook sono:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5400 Series]

L'unico driver in blacklist, per ora, è il radeon - che dovrebbe essere quello open.
Come detto, ho provato a cercare un po' in giro ma non ho trovato nulla di risolutivo.
Per ora, comunque, il problema che mi preme di più riguarda la visualizzazione di GNOME 3, che sono curioso di usare.

Se risolvo il problema, invio una birra per posta Smile

Ritratto di mcortese
mcortese
(Moderatore)
Offline
Moderatore
Iscritto: 27/02/2009
Messaggi: 2918

Credo tu abbia due schede video: la Intel integrata (quella fisicamente collegata all'uscita video) e l'ATI discreta (usata per l'accelerazione 3D, il suo output va alla Intel). Cerca info su "switcheroo". Non avendo una configurazione simile, non saprei dirti di più.