Debian lento in tutto, possibile problema con driver NVIDIA proprietari

7 risposte [Ultimo contenuto]
Ritratto di linuxatico1988
linuxatico1988
(Junior)
Offline
Junior
Iscritto: 15/04/2007
Messaggi: 6

Ciao a tutti,
ho un problema con la mia wheezy 64bit che è fastidioso e non riesco a risolvere, fino a un paio di settimane fa avevo i driver nouveau per la mia scheda 230M, poi ho messo i driver proprietari per vedere se le prestazioni di app 3D miglioravano (e ci sono state) poi però dopo un update ho cominciato ad avere il mio pc molto meno "reattivo" nel senso che anche solo il menù di gnome viene visualizzato con ritardo, muovendo il mouse sulle voci, queste vengono attivate con un ritardo decisamente sopra alla norma. Questo come anche la navigazione con iceweasel, l'esplorazione con nautilus ecc ecc.... Vorrei capire il motivo, qualcuno ha avuto un problema simile?
Ho anche disinstallato i driver proprietari e riutilizzato i nouveau ma così facendo il desktop rimane sfasato come se il lato destro dello schermo fosse in mezzo allo schermo stesso.. non sono riuscito a resettarlo neanche con i vesa, ho editato xorg.conf togliendo tutti i moduli e lasciando il minimo ma evidentemente sbaglio qualcosa, sono tutto orecchi.
Spero di essermi spiegato a sufficienza, grazie in anticipo
LiNuXaTiCo

"There are only 10 types of people in the world: Those who understand binary, and those who don't"

"Che Dio Abbia Pietà dei miei nemici, perché io non ne avrò!"

Ritratto di Anubi_Debian_3
Offline
Geek
Iscritto: 08/01/2011
Messaggi: 100

In che modo hai installato i driver della tua scheda Nvidia ? Hai usato i .run del sito ufficiale ? Dopo averli installati hai usato il comando "nvidia-xconfig" ? In oltre, se potessi postarci il tuo xorg.conf potremo aiutarti meglio.

Ritratto di linuxatico1988
linuxatico1988
(Junior)
Offline
Junior
Iscritto: 15/04/2007
Messaggi: 6

Citazione:

In che modo hai installato i driver della tua scheda Nvidia ? Hai usato i .run del sito ufficiale ?


Li ho installati con il .run ufficiale: NVIDIA-Linux-x86_64-260.19.44.run
Oggi ho provato a installare il pacchetto nei miei repo: nvidia-glx che mi ha installato la stessa versione di driver, nessun miglioramento cmq..
Citazione:

Dopo averli installati hai usato il comando "nvidia-xconfig" ?


No e non ho quel pacchetto installato al momento, però mi sembra che alla fine dell'installazione col .run venga richiesta l'esecuzione del comando e gli ho detto di farlo..
Ecco il mio xorg.conf:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath     "built-ins"
EndSection
 
Section "Module"
	Load  "dri2"
	Load  "glx"
	Load  "dri"
	Load  "extmod"
	Load  "record"
	Load  "dbe"
EndSection
 
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection
 
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection
 
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection
 
Section "Device"
	Identifier  "Card0"
	Driver      "nvidia"
	BusID       "PCI:1:0:0"
EndSection
 
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Ciao

"There are only 10 types of people in the world: Those who understand binary, and those who don't"

"Che Dio Abbia Pietà dei miei nemici, perché io non ne avrò!"

Ritratto di theShort
theShort
(Collaboratore)
Offline
Collaboratore
Iscritto: 02/08/2006
Messaggi: 595

Per prima cosa, direi che per installare i driver ufficiali Nvidia sia meglio farlo alla "debian-way", ovvero tramite repository.

A parte questo incomincierei a modificare l'xorg.conf in questo modo:

  • in Section "Module" prova a commentare (mettendo un "#" all'inizio della riga) la riga:
      Load  "dri"
     

  • in Section "Device" aggiungi le seguenti righe:
      Option      "NvAGP"                   "On"
      Option      "XAANoOffscreenPixmaps"   "true"
      Option      "AllowGLXWithComposite"   "true"
     

Fai sapere...

Bye!

.theShort Big Grin

Ritratto di linuxatico1988
linuxatico1988
(Junior)
Offline
Junior
Iscritto: 15/04/2007
Messaggi: 6

mmh non cambia niente... Phbbbbt!
Mi sorge il dubbio che magari Xorg usa un altro file di configurazione diverso da /etc/X11/xorg.conf

"There are only 10 types of people in the world: Those who understand binary, and those who don't"

"Che Dio Abbia Pietà dei miei nemici, perché io non ne avrò!"

Ritratto di drago
drago
(Geek)
Offline
Geek
Iscritto: 18/09/2005
Messaggi: 111

Driver Video Proprietario NVIDIA

Se vogliamo il massimo dalla nostra scheda video NVIDIA dobbiamo installare il driver proprietario.

Per farlo apriamo il terminale e digitiamo

su -> inseriamo la password
apt-get install module-assistant
apt-get install nvidia-kernel-common
apt-get install nvidia-glx
apt-get install nvdia-kernel-source
apt-get install nvidia-xconfig

Installati i pacchetti attiviamo il driver lanciando dallo stesso terminale

m-a prepare
m-a a-i nvidia
modprobe nvidia
nvidia-xconfig

Riavviamo il PC.

Verifichiamo il funzionamento del driver lanciando da terminale il comando glxinfo | grep render
fonte:
http://www.megalab.it/
su LMDE li installo cosi
ciao
chiaramente devi brasare i binari con:
nvidia-installer --uninstall

Chi si scorda del passato è destinato/a a riviverlo/a

Ritratto di linuxatico1988
linuxatico1988
(Junior)
Offline
Junior
Iscritto: 15/04/2007
Messaggi: 6

Ho fatto i passi indicati prima rimuovendo e purgando tutto ciò che conteneva la stringa "nvidia" ma ho ancora gli stessi problemi e ho notato dei cambiamenti:

root@debian:/home/debianiaco# glxinfo | grep render
No protocol specified
Error: unable to open display :0.0
root@debian:/home/debianiaco#

inoltre appena si avvia gnome in alto a destra mi appare un messaggio popup che dice che non è stata trovata una configurazione dello schermo valida, cosa sta succedendo al mio pc??

riposto lo xorg.conf attuale:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildd@barber)  Sun Jun 13 12:08:56 UTC 2010
 
 
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
    ModulePath      "/usr/lib/xorg/modules"
    FontPath        "/usr/share/fonts/X11/misc"
    FontPath        "/usr/share/fonts/X11/cyrillic"
    FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/X11/Type1"
    FontPath        "/usr/share/fonts/X11/100dpi"
    FontPath        "/usr/share/fonts/X11/75dpi"
    FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath        "built-ins"
EndSection
 
Section "Module"
    Load           "dri2"
    Load           "glx"
	#Load  "dri"
    Load           "extmod"
    Load           "record"
    Load           "dbe"
EndSection
 
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection
 
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection
 
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection
 
Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
EndSection
 
Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    Option         "NvAGP" "On"
    Option         "XAANoOffscreenPixmaps" "true"
    Option         "AllowGLXWithComposite" "true"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

"There are only 10 types of people in the world: Those who understand binary, and those who don't"

"Che Dio Abbia Pietà dei miei nemici, perché io non ne avrò!"

Ritratto di fareyes
fareyes
(Monster)
Offline
Monster
Iscritto: 14/03/2011
Messaggi: 391

Da quello che ho imparato da Linux e le sue installazioni osso dirti che per levare i driver che non vuoi più, va bene usare il disinstallatore, ma poi ti conviene anche ripassare a mano le varie directories e levare ogni cosa a mano. Solo dopo installi i driver che ritieni funzionare.

Controlla anche il framebuffer, perché in alcuni pc è richiesto, ma in altri dà grandi problemi... vedi anche nel bios se è abilitato o no.