Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01) su kali\linux

2 risposte [Ultimo contenuto]
Ritratto di 93Manuel
93Manuel
(Newbie)
Offline
Newbie
Iscritto: 02/04/2016
Messaggi: 2

Ciao a tutti, innanzitutto premetto che sono nuovo nel forum quindi chiedo scusa in anticipo se la sezione non è quella giusta, e in generale per le eventuali cavolate che dovessi scrivere, ma ahimè, sono un novizio anche per quanto riguarda linux, mi spiego meglio:

ho sempre usato solo windows, poi spinto dalla curiosità di provare linux, circa 2 mesi fà decisi di installare appunto una distribuzione linux cosi, per provare, e che dire, ne sono rimasto affascinato...

il primo errore che ho commesso è stato sicuramente nella scelta della distribuzione (kali) che sicuramente non è la piu adatta ai novizi, ma sorvolando su questo, non ho avuto grossi problemi fino a 3 giorni fà, visto che, in casa mi connetto ad internet tramite cavo, però appunto 3 giorni fà ho avuto la necessità di connettermi tramite wi-fi ed ho avuto una brutta sorpresa! la scheda di rete( appunto broadcom BCM43142) viene rilevata ma non è utilizabile.
ovviamente la prima cosa che ho pensato è che ci fosse un qualche problema di driver, cosi ho iniziato a cercare possibili soluzioni in rete ma, dopo un'infinità di comandi \ procedure e tentativi vari che ho eseguito (incessantemente per 3 giorni..) ancora ad oggi non sono riuscito a venirne a capo...
perciò eccomi qui, chiedo aiuto a voi, piu esperti di me, in che modo devo procedere e soprattutto di quali informazioni avete bisogno per tentare di capirci qualcosa? ringrazio tutti in anticipo per l'attenzione e spero che ci sia qualcuno in grado di aiutarmi! a presto!

P.S.:allego l'output del comando "lspci -vvnn | grep -A 9 Network"

lspci -vvnn | grep -A 9 Network 
03:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
	DeviceName: Harrier
	Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n [103c:2230]
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 0
	Region 0: Memory at f0c00000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: [40] Power Management version 3
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=2 PME-

Ritratto di badroot
badroot
(Guru)
Offline
Guru
Iscritto: 22/08/2008
Messaggi: 2083

Ciao,
non conosco Kali nello specifico ma il wiki debian ha una pagina dedicata con i dettagli sull'installazione del driver e informazioni su possibili problemi, leggi qui.

Ritratto di 93Manuel
93Manuel
(Newbie)
Offline
Newbie
Iscritto: 02/04/2016
Messaggi: 2

Ciao badroot, grazie mille ho risolto seguendo le procedure trovate nel post che mi hai linkato! grazie mille veramente stavo impazzendo! =)