Problematiche con VirtualMin con gestione sottodominio

6 risposte [Ultimo contenuto]
Ritratto di freddyfoxx
freddyfoxx
(Newbie)
Offline
Newbie
Iscritto: 29/03/2013
Messaggi: 3

Buon Giorno a tutti ho un grosso problema... da un po di tempo che mi sto dedicando alla creazione di vps e sotto dominio della mia macchina debian 6.0

non riesco a risolvere questo grosso problema ben si.. ne riuscirne a capo...

creato tutto con virtualmin tutto configurato come si deve appena creo un user "demouser.org" non riesco ad accedere http://userdmeo.org

il mio server ha questo indirizzo locale 192.168.1.13 da li riesco a visualizzare il mio sito pricipale "non demouser" sia da interno e esterno!!

il mio problema e con virtualhost non riesco a venirne a capo... qualcuno mi aiutati Sad

un grazie in anticipo!!

buona giornata a tutti!! Wink

Ritratto di Claudio_fe11
Claudio_fe11
(Collaboratore)
Offline
Collaboratore
Iscritto: 03/02/2011
Messaggi: 454

http://forum.debianizzati.org/viewtopic.php?f=19&t=47706&p=165328&hilit=Problematiche+con+VirtualMin+con+gestione+sottodominio#p165328

"Scriva le equazioni sulla lavagna". Poi aggiunse,
"Per favore vada piano, non afferro le cose molto in fretta".

Albert Einstein

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

Virtualmin non lo conosco.
Immagino che, come altri sistemi del genere (io lavoro con ispConfig), vada a creare configurazioni sul web server (apache2?).
Il problema che dettagli, in maniera un po' confusionaria mischiando funzioni, mi pare sia da ricondurre a qualcosa relativo ai dns.
Mi spiego.
Hai creato un host virtuale. A livello sistemistico hai creato un file che espande la configurazione del webserver. Se tutto funziona la macchina ridirigerà internamente il traffico a quell'host sulla directory specificata.
Quello che chiedi è che il vhost sia risolto dai dns prima locali e poi della macchina dalla quale fai il test.
Certamente c'è un inghippo. A naso basta l'assegnazione statica del dns nel file /etc/hosts )se win e mac o hosts in qualche sottodirectory di sistema se win) della macchina dalla quale stai tentando di accedere al tuo ambiente di test.

Tante idee e confuse Wink

Prova a dettagliare maglio l'ambiente sul quale stai sperimentando a livello di flusso logico e di macchine in gioco. (Tipo: ho installato virtualmin su una VM blabla / ho usato l'immagine in downalod nlbla / con ip blabla... dal mio pc blabla... eccecc... )

PS: Al di la del mio gusto personale mi pare che il cross-posting non sia gradito in questa comunità. Se non è d'impiccio scusati su entrambi i forum e decidi dove continuare.

Ritratto di freddyfoxx
freddyfoxx
(Newbie)
Offline
Newbie
Iscritto: 29/03/2013
Messaggi: 3

kripsio ha scritto:

Virtualmin non lo conosco.
Immagino che, come altri sistemi del genere (io lavoro con ispConfig), vada a creare configurazioni sul web server (apache2?).
Il problema che dettagli, in maniera un po' confusionaria mischiando funzioni, mi pare sia da ricondurre a qualcosa relativo ai dns.
Mi spiego.
Hai creato un host virtuale. A livello sistemistico hai creato un file che espande la configurazione del webserver. Se tutto funziona la macchina ridirigerà internamente il traffico a quell'host sulla directory specificata.
Quello che chiedi è che il vhost sia risolto dai dns prima locali e poi della macchina dalla quale fai il test.
Certamente c'è un inghippo. A naso basta l'assegnazione statica del dns nel file /etc/hosts )se win e mac o hosts in qualche sottodirectory di sistema se win) della macchina dalla quale stai tentando di accedere al tuo ambiente di test.

Tante idee e confuse Wink

Prova a dettagliare maglio l'ambiente sul quale stai sperimentando a livello di flusso logico e di macchine in gioco. (Tipo: ho installato virtualmin su una VM blabla / ho usato l'immagine in downalod nlbla / con ip blabla... dal mio pc blabla... eccecc... )

PS: Al di la del mio gusto personale mi pare che il cross-posting non sia gradito in questa comunità. Se non è d'impiccio scusati su entrambi i forum e decidi dove continuare.

grazie kripsio per la risposta!!

mi scuso con tutti non volevo fare del crooss posting ma sinceramente non pensavo che i due forum fossero collegati....

comunque ti spiego meglio.
non riesco a creare sottodominio con lo stesso ip.
funziona la prima pagina di default (192.168.1.13) creando un dominio con il pannello virtualmin non riesco a visualizzare nel mio browser
il nuovo dominio creato. es: http://testdominio.com
tutto questo è configurato con apache2 in automatico dal panello.
la mia machina sulla quale è installato linux debian 6.0
vi mostro un video che rappresenta quello che vorrei fare.

Video Esempio Youtube

spero di essere riuscito a farmi comprendere meglio

se vi serve la configurazione del mio server ve la posto subito

grazie mille in anticipo

Ritratto di homeless
homeless
(Guru)
Offline
Guru
Iscritto: 21/10/2011
Messaggi: 1411

Se le configurazioni che hai realizzato sono corrette, i server sono verosimilmente non raggiungibili per mancata configurazione della risoluzone dei nomi (DNS, come precedentemente accennato: vedi http://httpd.apache.org/docs/2.2/vhosts/name-based.html). Nel filmato che hai inviato, questo aspetto tecnico è aggirato configurando manualmente il file /etc/hosts , ma questo funziona solo per le chiamate effettuate in locale cioè dallo stesso computer del server.

Ritratto di kripsio
kripsio
(Collaboratore)
Offline
Collaboratore
Iscritto: 10/09/2004
Messaggi: 1511

No, i forum non sono collegati (da che ne so io almeno). Il cross-posting, in se, non "cortese" http://it.wikipedia.org/wiki/Cross-posting . Poi possiamo discuterne ma non in questa sede Wink

Isoliamo il problema.

Apri un terminale sul computer dal quale vuoi raggiungere il sito e fai un ping verso userdmeo.org se risponde il tuo server (192.168.1.13 da quello che ho capito) ha livello di DNS sei apposto. Altrimenti, il problema è (anche) lì.

Ciaoo Laughing

Ritratto di freddyfoxx
freddyfoxx
(Newbie)
Offline
Newbie
Iscritto: 29/03/2013
Messaggi: 3

kripsio ha scritto:

No, i forum non sono collegati (da che ne so io almeno). Il cross-posting, in se, non "cortese" http://it.wikipedia.org/wiki/Cross-posting . Poi possiamo discuterne ma non in questa sede Wink

Isoliamo il problema.

Apri un terminale sul computer dal quale vuoi raggiungere il sito e fai un ping verso userdmeo.org se risponde il tuo server (192.168.1.13 da quello che ho capito) ha livello di DNS sei apposto. Altrimenti, il problema è (anche) lì.

Ciaoo Laughing

Scusatemi se rispondo ora ma ero assente... cmq mi arrendo non ci riesco con virtualmin, ora sto provando con ispconfig3 qualche sugerimento o guide???

in anticipo grazie a tutti per le risposte!!