Impossibile accedere ai siti in un server LAMP da altri computer

19 risposte [Ultimo contenuto]
Ritratto di FabioB
FabioB
(Junior)
Offline
Junior
Iscritto: 04/10/2015
Messaggi: 12

Esattamente, puntavo ad un indirizzo diverso, ma perché ho configurato un IP staticamente ed utilizzavo questo, non avrei mai pensato che non fosse stato quello da me impostato.
Io gli ho dato un IP statico è lui che si riappropria di quello che gli aveva dato il DHCP appena installato Debian.
Il problema è che devo fare questa tiritera disconnetti/connetti ogni volta che riavvio il server perché per lui l'IP torna sempre quello precedente.
Ho fatto uno screen shot per far capire meglio.
Come puoi vedere ho configurato staticamente con l'IP 192.168.10.102 ma ogni volta che riavvio torna 192.168.10.67 nonostante poi nelle proprietà della connessione rimane tutto invariato ovvero l'IP risulterebbe essere 192.168.10.102

Attached images:

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1123

Ti dico subito qual è il problema secondo me: hai configurato wicd in maniera statica ma con molta probabilità hai anche network-manager configurato in maniera dinamica.

Prova ad eseguire il comando "nm-connection-editor" e vedi se parte la finestra di configurazione della rete di NetworkManager. In caso affermativo controlla come è impostata la NIC: al 99% ce l'hai in DHCP.

Devi decidere quale gestore di configurazione di rete usare, non puoi usarli entrambi altrimenti il comportamento non è predicibile (dipende da chi parte prima). Quello che non usi lo disinstalli così sei sicuro.

Debian. Be unique.

Ritratto di FabioB
FabioB
(Junior)
Offline
Junior
Iscritto: 04/10/2015
Messaggi: 12

Mi dice: comando non trovato.

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1123

Magari ti manca solo il front-end. Prova a vedere se c'è il pacchetto base:

dpkg -l |grep network-manager

e posta anche il contenuto del file /etc/network/interfaces.

Debian. Be unique.

Ritratto di FabioB
FabioB
(Junior)
Offline
Junior
Iscritto: 04/10/2015
Messaggi: 12

Ho lanciato dpkg -l | grep network-manager e successivamente nm-connection-editor ma dice sempre comando non trovato.

interfaces
 
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
source /etc/network/interfaces.d/*
 
# The loopback network interface
auto lo
iface lo inet loopback
 
# The primary network interface
auto eth0
iface eth0 inet dhcp

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1123

FabioB ha scritto:


# The primary network interface
auto eth0
iface eth0 inet dhcp

Non vedi che eth0 è configurata in DHCP? È questo il problema. Elimina queste due righe e dovresti essere a posto.

NetworkManager non ce l'hai, il comando serviva solo per capire se ce l'hai o meno, non certo per installarlo, quindi se il comando non lo trovava prima non lo trovava neanche dopo.

Debian. Be unique.

Ritratto di FabioB
FabioB
(Junior)
Offline
Junior
Iscritto: 04/10/2015
Messaggi: 12

Sì certo lo vedo ma non sapevo che dovevo guardare in quel file. In verità mi sarei aspettato che una volta configurato l'IP quanto meno ad un riavvio fosse andato in automatico senza dover modificare nessun file.
Cancellate le due righe funziona ma nel frattempo avevo provato anche con successo modificandolo così:

# The primary network interface
auto eth0
iface eth0 inet static
 
  address 192.168.10.102
 
  netmask 255.255.255.0
 
  gateway 192.168.10.254
 
  dns-nameserver 8.8.8.8

Direi che per ora avrei risolto ogni problema quindi ti ringrazio molto per il supporto, ovviamente grazie anche agli altri che hanno partecipato.

Ritratto di pietro
pietro
(Collaboratore)
Offline
Collaboratore
Iscritto: 30/06/2005
Messaggi: 1123

È uguale, o la configuri dal file o da wicd. Ma non su entrambi.

NetworkManager, invece, è più sicuro perché fa un controllo in quel file: se un'interfaccia è presente nel file non te la fa configurare dall'interfaccia grafica, quindi il problema non si pone.

Debian. Be unique.

Ritratto di FabioB
FabioB
(Junior)
Offline
Junior
Iscritto: 04/10/2015
Messaggi: 12

Torno sul tema, allo scopo informativo, perché ieri ho installato un altro Debian stavolta con desktop Mate, invece che LXDE come l'altro. Ho impostato l'IP statico ed immediatamente non era stato cambiato ossia era rimasto quello assegnato dal DHCP ma al riavvio di Debian la configurazione statica è stata assegnata regolarmente.