apache+php4+php5

5 risposte [Ultimo contenuto]
Ritratto di Incubus
Incubus
(Junior)
Offline
Junior
Iscritto: 08/12/2004
Messaggi: 40

Ciao a tutti

Qualcuno è riuscito a instalalre php5 come cgi su un server apache 1.3.X con php4 già presente come modulo?
In caso affermativo potrebbe indicare che modifiche sono satte fatte a httpd.conf?

Grazie 1000

Sciauz

Ritratto di OldSparky
OldSparky
(Geek)
Offline
Geek
Iscritto: 07/01/2005
Messaggi: 158

Cioè vorresti implementare entrambe le versioni di php su apache contemporaneamente?

Penso sia impossibile, a meno che la direttiva virtualhost permetta di caricare moduli a parte, ma è poco probabile.

Ritratto di Incubus
Incubus
(Junior)
Offline
Junior
Iscritto: 08/12/2004
Messaggi: 40

Quando mi ero messo a fare il lavoro aveto sotto mano una guida che pero' ora nn riesco più a trovare.
Il lavoro cmq è passato in secondo piano in quanto sono sopraggiunti problemi "più garvi" sul server...
Se trovo una soluzione farò cmq sapere Smile

Ritratto di bankomat
bankomat
(Geek)
Offline
Geek
Iscritto: 29/09/2004
Messaggi: 76

In qualche ng avevo letto una richiesta molto simile e avevano proposto una soluzione.

Se la trovo ti posto il link

Ritratto di alex1978
alex1978
(Junior)
Offline
Junior
Iscritto: 04/06/2005
Messaggi: 14

Ciao..
pirtroppo non ho avuto ancora modo di provare PHP5 ma.. credo che tu possa risolvere la cosa installando solo il PHP5 e configurando poi i vari vhost facendogli utilizzare il motore zend vecchio se sviluppati in PHP4 o il nuovo se in PHP5.

Appena riesco a provare questa cosa ti faccio risapere. Questo è quello che avevo letto un pò di tempo fa quando a lavoro sembrava volessimo passare al 5.. poi non se ne fece nulla per mancanza di tempo.. o voglia..

Ritratto di alex1978
alex1978
(Junior)
Offline
Junior
Iscritto: 04/06/2005
Messaggi: 14

http://freephp.html.it/articoli/print_articolo.asp?id=145

Cerca su google e trovi parecchie cose interessanti. Qui spiega quello che (credo) voelvi fare tu.

Qui invece c'è quello che ti dicevo io

http://it2.php.net/manual/it/faq.migration5.php

CIAO!!